summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-02-18 15:24:31 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-02-18 15:24:31 +0000
commitea65200ce736a85d9f60e0bee53fffbfc515535b (patch)
tree02e0800486f8e4de784bc5870bf367738342ceb4 /net-irc/ninja/ninja-1.5.9_pre14.ebuild
parentStable on ppc wrt bug 166529 (diff)
downloadgentoo-2-ea65200ce736a85d9f60e0bee53fffbfc515535b.tar.gz
gentoo-2-ea65200ce736a85d9f60e0bee53fffbfc515535b.tar.bz2
gentoo-2-ea65200ce736a85d9f60e0bee53fffbfc515535b.zip
Version bump to fix bug 152483 and directly stable x86
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-irc/ninja/ninja-1.5.9_pre14.ebuild')
-rw-r--r--net-irc/ninja/ninja-1.5.9_pre14.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/ninja/ninja-1.5.9_pre14.ebuild b/net-irc/ninja/ninja-1.5.9_pre14.ebuild
new file mode 100644
index 000000000000..46d0992adeaa
--- /dev/null
+++ b/net-irc/ninja/ninja-1.5.9_pre14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/ninja/ninja-1.5.9_pre14.ebuild,v 1.1 2007/02/18 15:24:31 armin76 Exp $
+
+S=${WORKDIR}/${P/_*/}
+
+DESCRIPTION="Ninja IRC Client"
+HOMEPAGE="http://ninja.qoop.org/"
+SRC_URI="ftp://qoop.org/ninja/stable/${P/_/}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE="ncurses ipv6 ssl"
+
+DEPEND="virtual/libc
+ ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_compile() {
+ econf $(use_enable ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}