summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-07-20 23:44:11 +0000
committerSven Wegener <swegener@gentoo.org>2004-07-20 23:44:11 +0000
commitaf1b6928795ef6ed0e1268ef163d375ce7218d04 (patch)
tree0172c4893acf4e11eda97883b2f801c0a8a7aa72 /net-irc/xchat-systray
parentMoved package to the net-irc herd. (Manifest recommit) (diff)
downloadgentoo-2-af1b6928795ef6ed0e1268ef163d375ce7218d04.tar.gz
gentoo-2-af1b6928795ef6ed0e1268ef163d375ce7218d04.tar.bz2
gentoo-2-af1b6928795ef6ed0e1268ef163d375ce7218d04.zip
Don't override "MAKEOPTS". Moved net-irc/xchat into "RDEPEND" and "DEPEND". Made CFLAGS aware.
Diffstat (limited to 'net-irc/xchat-systray')
-rw-r--r--net-irc/xchat-systray/ChangeLog7
-rw-r--r--net-irc/xchat-systray/xchat-systray-2.3.1.ebuild28
-rw-r--r--net-irc/xchat-systray/xchat-systray-2.4.0.ebuild25
3 files changed, 43 insertions, 17 deletions
diff --git a/net-irc/xchat-systray/ChangeLog b/net-irc/xchat-systray/ChangeLog
index 43f03500f9a3..e5b028786cc7 100644
--- a/net-irc/xchat-systray/ChangeLog
+++ b/net-irc/xchat-systray/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat-systray
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/ChangeLog,v 1.7 2004/07/20 23:18:10 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/ChangeLog,v 1.8 2004/07/20 23:44:11 swegener Exp $
+
+ 21 Jul 2004; Sven Wegener <swegener@gentoo.org> xchat-systray-2.3.1.ebuild,
+ xchat-systray-2.4.0.ebuild:
+ Don't override "MAKEOPTS". Moved net-irc/xchat into "RDEPEND" and "DEPEND".
+ Made CFLAGS aware.
21 Jul 2004; Sven Wegener <swegener@gentoo.org> metadata.xml:
Moved package to the net-irc herd.
diff --git a/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild b/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild
index f626344729dc..8c849ced5ab7 100644
--- a/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild
+++ b/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild,v 1.7 2004/06/24 23:10:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.3.1.ebuild,v 1.8 2004/07/20 23:44:11 swegener Exp $
+
+MY_P=${PN}-plugin_${PV}
-S=${WORKDIR}/${PN}-plugin_${PV}
DESCRIPTION="KDE/GNOME system tray plugin for X-Chat."
-SRC_URI="http://blight.altervista.org/Downloads/${PN}-plugin_${PV}.tar.gz"
+SRC_URI="http://blight.altervista.org/Downloads/${MY_P}.tar.gz"
HOMEPAGE="http://blight.altervista.org/"
LICENSE="GPL-2"
@@ -14,18 +15,27 @@ IUSE=""
RDEPEND=">=dev-libs/glib-2.0.3
>=x11-libs/gtk+-2.0.3
- sys-devel/gettext"
+ >=net-irc/xchat-2.0.3"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.7
- >=net-irc/xchat-2.0.3"
+ sys-devel/gettext
+ >=sys-apps/sed-4"
-src_compile() {
+S=${WORKDIR}/${MY_P}
- MAKEOPTS="-j1" emake || die "Compile failed"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s/-O2 -Wall/${CFLAGS}/" Makefile
+}
+
+src_compile() {
+ emake -j1 || die "Compile failed"
}
src_install() {
- insinto /usr/lib/xchat/plugins
- doins systray.so
+ exeinto /usr/lib/xchat/plugins
+ doexe systray.so
}
diff --git a/net-irc/xchat-systray/xchat-systray-2.4.0.ebuild b/net-irc/xchat-systray/xchat-systray-2.4.0.ebuild
index ad8bac4e8e72..d9e89fdcd15d 100644
--- a/net-irc/xchat-systray/xchat-systray-2.4.0.ebuild
+++ b/net-irc/xchat-systray/xchat-systray-2.4.0.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.4.0.ebuild,v 1.4 2004/06/24 23:10:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-systray/xchat-systray-2.4.0.ebuild,v 1.5 2004/07/20 23:44:11 swegener Exp $
+
+MY_P=${PN}-integration-${PV}
-S=${WORKDIR}/${PN}-integration-${PV}
DESCRIPTION="System tray plugin for X-Chat."
-SRC_URI="mirror://sourceforge/xchat2-plugins/${PN}-integration-${PV}-src.tar.gz"
+SRC_URI="mirror://sourceforge/xchat2-plugins/${MY_P}-src.tar.gz"
HOMEPAGE="http://blight.altervista.org/"
LICENSE="GPL-2"
@@ -18,13 +19,23 @@ RDEPEND=">=dev-libs/glib-2.0.3
DEPEND="${RDEPEND}
sys-devel/gettext
- >=dev-util/pkgconfig-0.7"
+ >=dev-util/pkgconfig-0.7
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s/-O2 -Wall/${CFLAGS}/" Makefile
+}
src_compile() {
- MAKEOPTS="-j1" emake || die "Compile failed"
+ emake -j1 || die "Compile failed"
}
src_install() {
- insinto /usr/lib/xchat/plugins
- doins systray.so
+ exeinto /usr/lib/xchat/plugins
+ doexe systray.so
}