summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-08-20 14:40:56 +0000
committerAlex Alexander <wired@gentoo.org>2010-08-20 14:40:56 +0000
commit952f1979543053cf09e1f6e221ed78baa332a8a0 (patch)
treee56fc2531cd12800b9b685ce8a6fdccbe2f3f203 /net-irc/znc
parentFix building with recent videoproto wrt #332389 by Rahul Jain, Matteo Azzali ... (diff)
downloadgentoo-2-952f1979543053cf09e1f6e221ed78baa332a8a0.tar.gz
gentoo-2-952f1979543053cf09e1f6e221ed78baa332a8a0.tar.bz2
gentoo-2-952f1979543053cf09e1f6e221ed78baa332a8a0.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-irc/znc')
-rw-r--r--net-irc/znc/ChangeLog7
-rw-r--r--net-irc/znc/znc-0.094.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/net-irc/znc/ChangeLog b/net-irc/znc/ChangeLog
index c9995004cca1..8e19d241e517 100644
--- a/net-irc/znc/ChangeLog
+++ b/net-irc/znc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/znc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.40 2010/08/14 22:41:52 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/ChangeLog,v 1.41 2010/08/20 14:40:56 wired Exp $
+
+*znc-0.094 (20 Aug 2010)
+
+ 20 Aug 2010; Alex Alexander <wired@gentoo.org> +znc-0.094.ebuild:
+ version bump
*znc-0.092-r1 (14 Aug 2010)
diff --git a/net-irc/znc/znc-0.094.ebuild b/net-irc/znc/znc-0.094.ebuild
new file mode 100644
index 000000000000..2a084ade1dad
--- /dev/null
+++ b/net-irc/znc/znc-0.094.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/znc/znc-0.094.ebuild,v 1.1 2010/08/20 14:40:56 wired Exp $
+
+EAPI=2
+
+inherit base
+
+DESCRIPTION="An advanced IRC Bouncer"
+HOMEPAGE="http://znc.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ares debug extras ipv6 perl ssl sasl tcl"
+
+RDEPEND="
+ ares? ( >=net-dns/c-ares-1.5 )
+ perl? ( dev-lang/perl )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ tcl? ( dev-lang/tcl )
+"
+DEPEND="
+ dev-util/pkgconfig
+ ${DEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable ares c-ares) \
+ $(use_enable debug) \
+ $(use_enable extras extra) \
+ $(use_enable ipv6) \
+ $(use_enable perl) \
+ $(use_enable sasl) \
+ $(use_enable ssl openssl) \
+ $(use_enable tcl tcl) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed."
+ dodoc AUTHORS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog
+ elog "Run 'znc --makeconf' as the user you want to run ZNC as"
+ elog "to make a configuration file"
+ elog "If you are using SSL you should also run 'znc --makepem'"
+ elog
+}