summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-07-18 21:15:39 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-07-18 21:15:39 +0000
commit0f8f604fbcdf919e766dbdb444b666f3779224a1 (patch)
treec05952ace59f1449b7e8c77cb5ed22def0eb6250 /net-irc
parentversion bump (diff)
downloadgentoo-2-0f8f604fbcdf919e766dbdb444b666f3779224a1.tar.gz
gentoo-2-0f8f604fbcdf919e766dbdb444b666f3779224a1.tar.bz2
gentoo-2-0f8f604fbcdf919e766dbdb444b666f3779224a1.zip
Allow XMMS interface to compile, closes bug #99460. Patch by Morten Cools.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat-xsys/ChangeLog7
-rw-r--r--net-irc/xchat-xsys/files/2.0.7-glib_version.patch11
-rw-r--r--net-irc/xchat-xsys/xchat-xsys-2.0.7.ebuild5
3 files changed, 20 insertions, 3 deletions
diff --git a/net-irc/xchat-xsys/ChangeLog b/net-irc/xchat-xsys/ChangeLog
index 5fd3b5cbb422..bf00da8f1e04 100644
--- a/net-irc/xchat-xsys/ChangeLog
+++ b/net-irc/xchat-xsys/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat-xsys
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/ChangeLog,v 1.22 2005/07/17 18:45:37 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/ChangeLog,v 1.23 2005/07/18 21:15:39 chainsaw Exp $
+
+ 18 Jul 2005; Tony Vroon <chainsaw@gentoo.org>
+ +files/2.0.7-glib_version.patch, xchat-xsys-2.0.7.ebuild:
+ Make the XMMS side of things actually work, thanks to a patch from Morten
+ Cools <morten@cools.no>; closes bug #99460.
*xchat-xsys-2.0.7 (17 Jul 2005)
diff --git a/net-irc/xchat-xsys/files/2.0.7-glib_version.patch b/net-irc/xchat-xsys/files/2.0.7-glib_version.patch
new file mode 100644
index 000000000000..f4c226e0d72e
--- /dev/null
+++ b/net-irc/xchat-xsys/files/2.0.7-glib_version.patch
@@ -0,0 +1,11 @@
+--- xsys-2.0.7-old/Makefile 2005-07-17 20:13:33.000000000 +0200
++++ xsys-2.0.7/Makefile 2005-07-18 22:13:14.000000000 +0200
+@@ -11,7 +11,7 @@
+ CC = gcc
+ CFLAGS += -O2 -Wall -fPIC
+ # FOR BMP # CFLAGS += -I/usr/include/beep-media-player -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DUSE_BMP
+-# FOR XMMS # CFLAGS += -I/usr/include/xmms -I/usr/include/glib-1.2 -I/usr/lib/glib-1.2/include -DUSE_XMMS
++# FOR XMMS # CFLAGS += -I/usr/include/xmms -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DUSE_XMMS
+ CFLAGS += -DVER_MINOR=$(VER_MINOR) -DVER_MAJOR=$(VER_MAJOR) -DVER_PATCH=$(VER_PATCH) \
+ -DVER_STRING=\"$(VER_MAJOR).$(VER_MINOR).$(VER_PATCH)\" -DPCIIDS=\"$(PCIIDS)\" $(BUTTON)
+ LDFLAGS = $(CFLAGS) -shared
diff --git a/net-irc/xchat-xsys/xchat-xsys-2.0.7.ebuild b/net-irc/xchat-xsys/xchat-xsys-2.0.7.ebuild
index 8626a3d15eb5..5d60e4e7acbc 100644
--- a/net-irc/xchat-xsys/xchat-xsys-2.0.7.ebuild
+++ b/net-irc/xchat-xsys/xchat-xsys-2.0.7.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.0.7.ebuild,v 1.1 2005/07/17 18:45:37 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-xsys/xchat-xsys-2.0.7.ebuild,v 1.2 2005/07/18 21:15:39 chainsaw Exp $
inherit toolchain-funcs eutils
MY_P="${P/xchat-/}"
S=${WORKDIR}/${MY_P}
DESCRIPTION="Sysinfo plugin for X-Chat."
-SRC_URI="mirror://gentoo/${MY_P}.tar.bz2 http://dev.gentoo.org/~chainsaw/xsys/download/${MY_P}.tar.bz2"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
HOMEPAGE="http://dev.gentoo.org/~chainsaw/xsys/"
LICENSE="GPL-2"
@@ -32,6 +32,7 @@ src_unpack() {
if use bmp; then
sed -i -e "s:# FOR BMP # ::g" ${S}/Makefile
elif use xmms; then
+ epatch ${FILESDIR}/${PV}-glib_version.patch
sed -i -e "s:# FOR XMMS # ::g" ${S}/Makefile
fi
}