summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-12-06 21:33:23 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-12-06 21:33:23 +0000
commita6db9ecf340948947a6df2f76fc1fa7c294e94cd (patch)
treee66afb912a0ac22873da8ec2682ade51d7d53e33 /net-irc
parentA version of xawtv-3.64 has already been committed to the portage tree. (diff)
downloadgentoo-2-a6db9ecf340948947a6df2f76fc1fa7c294e94cd.tar.gz
gentoo-2-a6db9ecf340948947a6df2f76fc1fa7c294e94cd.tar.bz2
gentoo-2-a6db9ecf340948947a6df2f76fc1fa7c294e94cd.zip
fixed xchat's python support
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/xchat-1.8.2-r3.ebuild59
-rw-r--r--net-irc/xchat/xchat-1.8.4.ebuild59
-rw-r--r--net-irc/xchat/xchat-1.8.5.ebuild75
3 files changed, 35 insertions, 158 deletions
diff --git a/net-irc/xchat/xchat-1.8.2-r3.ebuild b/net-irc/xchat/xchat-1.8.2-r3.ebuild
deleted file mode 100644
index 2fd2f1101e1e..000000000000
--- a/net-irc/xchat/xchat-1.8.2-r3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyrigth 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>, Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.2-r3.ebuild,v 1.1 2001/10/15 14:36:05 hallski Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="xchat irc client"
-SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
-HOMEPAGE="http://www.xchat.org/"
-
-DEPEND=">=x11-libs/gtk+-1.2.10-r4
- perl? ( sys-devel/perl )
- python? ( >=dev-lang/python-2.0-r4 )
- nls? ( >=sys-devel/gettext-0.10.38 )
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
- ssl? ( >=dev-libs/openssl-0.9.6a )"
-
-RDEPEND=">=x11-libs/gtk+-1.2.10-r4
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
- ssl? ( >=dev-libs/openssl-0.9.6a )"
-
-
-src_unpack() {
- unpack ${A}
-}
-
-src_compile() {
- local myopts myflags
-
- use gnome && myopts="--enable-gnome --enable-panel"
- use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
- use ssl && myopts="$myopts --enable-openssl"
- use perl || myopts="$myopts --disable-perl"
- use python && myflags="`python-config --libs` -lm"
- use python || myopts="$myopts --disable-python"
- use nls || myopts="$myopts --disable-nls"
-
- CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
-
- ./configure --prefix=/usr --host=${CHOST} ${myopts} --enable-ipv6 || die
-
- if [ "$myflags" ] ; then
- for i in src/fe-gtk src/fe-text
- do
- if [ -e $i/Makefile ] ; then
- cp $i/Makefile $i/Makefile.orig
- sed -e "s:-lpython2.0:$myflags:" \
- $i/Makefile.orig > $i/Makefile
- fi
- done
- fi
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr install || die
- dodoc AUTHORS COPYING ChangeLog README
-}
diff --git a/net-irc/xchat/xchat-1.8.4.ebuild b/net-irc/xchat/xchat-1.8.4.ebuild
deleted file mode 100644
index a96d51141576..000000000000
--- a/net-irc/xchat/xchat-1.8.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyrigth 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>, Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.4.ebuild,v 1.1 2001/10/15 23:39:18 lordjoe Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="xchat irc client"
-SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
-HOMEPAGE="http://www.xchat.org/"
-
-DEPEND=">=x11-libs/gtk+-1.2.10-r4
- perl? ( sys-devel/perl )
- python? ( >=dev-lang/python-2.0-r4 )
- nls? ( >=sys-devel/gettext-0.10.38 )
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
- ssl? ( >=dev-libs/openssl-0.9.6a )"
-
-RDEPEND=">=x11-libs/gtk+-1.2.10-r4
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
- ssl? ( >=dev-libs/openssl-0.9.6a )"
-
-
-src_unpack() {
- unpack ${A}
-}
-
-src_compile() {
- local myopts myflags
-
- use gnome && myopts="--enable-gnome --enable-panel"
- use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
- use ssl && myopts="$myopts --enable-openssl"
- use perl || myopts="$myopts --disable-perl"
- use python && myflags="`python-config --libs` -lm"
- use python || myopts="$myopts --disable-python"
- use nls || myopts="$myopts --disable-nls"
-
- CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
-
- ./configure --prefix=/usr --host=${CHOST} ${myopts} --enable-ipv6 || die
-
- if [ "$myflags" ] ; then
- for i in src/fe-gtk src/fe-text
- do
- if [ -e $i/Makefile ] ; then
- cp $i/Makefile $i/Makefile.orig
- sed -e "s:-lpython2.0:$myflags:" \
- $i/Makefile.orig > $i/Makefile
- fi
- done
- fi
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr install || die
- dodoc AUTHORS COPYING ChangeLog README
-}
diff --git a/net-irc/xchat/xchat-1.8.5.ebuild b/net-irc/xchat/xchat-1.8.5.ebuild
index 9723224b04c2..621615059c5c 100644
--- a/net-irc/xchat/xchat-1.8.5.ebuild
+++ b/net-irc/xchat/xchat-1.8.5.ebuild
@@ -1,7 +1,7 @@
# Copyrigth 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>, Donny Davies <woodchip@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.5.ebuild,v 1.2 2001/10/30 02:26:36 lordjoe Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.5.ebuild,v 1.3 2001/12/06 21:33:23 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="xchat irc client"
@@ -9,51 +9,46 @@ SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
HOMEPAGE="http://www.xchat.org/"
DEPEND=">=x11-libs/gtk+-1.2.10-r4
- perl? ( sys-devel/perl )
- python? ( >=dev-lang/python-2.0-r4 )
- nls? ( >=sys-devel/gettext-0.10.38 )
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
- >=media-libs/gdk-pixbuf-0.11.0-r1 )
- ssl? ( >=dev-libs/openssl-0.9.6a )"
+perl? ( sys-devel/perl )
+python? ( >=dev-lang/python-2.0-r4 )
+nls? ( >=sys-devel/gettext-0.10.38 )
+gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ssl? ( >=dev-libs/openssl-0.9.6a )"
RDEPEND=">=x11-libs/gtk+-1.2.10-r4
- gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1
- >=media-libs/gdk-pixbuf-0.11.0-r1 )
- ssl? ( >=dev-libs/openssl-0.9.6a )"
+gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ if [ "`use python`" ]
+ then
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' configure.orig > configure
+ fi
+}
src_compile() {
- local myopts myflags
-
- #use gnome && myopts="--enable-gnome --enable-panel"
- use gnome || myopts="--enable-gtkfe --disable-gnome \
- --disable-gdk-pixbuf --disable-zvt"
- use ssl && myopts="$myopts --enable-openssl"
- use perl || myopts="$myopts --disable-perl"
- use python && myflags="`python-config --libs` -lm"
- use python || myopts="$myopts --disable-python"
- use nls || myopts="$myopts --disable-nls"
- use mmx && myopts="$myopts --enable-mmx"
-
- CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
-
- ./configure --prefix=/usr --host=${CHOST} ${myopts} --enable-ipv6 || die
-
- if [ "$myflags" ] ; then
- for i in src/fe-gtk src/fe-text
- do
- if [ -e $i/Makefile ] ; then
- cp $i/Makefile $i/Makefile.orig
- sed -e "s:-lpython2.0:$myflags:" \
- $i/Makefile.orig > $i/Makefile
- fi
- done
- fi
-
+ local myopts myflags
+
+ #use gnome && myopts="--enable-gnome --enable-panel"
+ use gnome || myopts="--enable-gtkfe --disable-gnome --disable-gdk-pixbuf --disable-zvt"
+ use ssl && myopts="$myopts --enable-openssl"
+ use perl || myopts="$myopts --disable-perl"
+ use python && myflags="`python-config`"
+ use python || myopts="$myopts --disable-python"
+ use nls || myopts="$myopts --disable-nls"
+ use mmx && myopts="$myopts --enable-mmx"
+ CFLAGS="$CFLAGS -I/usr/include/orbit-1.0"
+ ./configure --prefix=/usr --host=${CHOST} ${myopts} --enable-ipv6 || die
patch -p1 < ${FILESDIR}/xc185fixbnc.diff
emake || die
}
src_install() {
- make prefix=${D}/usr install || die
- dodoc AUTHORS COPYING ChangeLog README
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS COPYING ChangeLog README
}