summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-10-16 11:06:29 +0000
committerAlin Năstac <mrness@gentoo.org>2005-10-16 11:06:29 +0000
commit1e30ae5f088486c94e743baa39267b6385077d87 (patch)
tree1b9037c5db546d29e1ef55a52d74980d527f06c8 /net-libs/wvstreams/wvstreams-4.0.2.ebuild
parentx86 (diff)
downloadgentoo-2-1e30ae5f088486c94e743baa39267b6385077d87.tar.gz
gentoo-2-1e30ae5f088486c94e743baa39267b6385077d87.tar.bz2
gentoo-2-1e30ae5f088486c94e743baa39267b6385077d87.zip
Fix DEPEND by adding unconditional dependency of openssl (#108095). Mark 4.0.2-r1 stable on x86.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-libs/wvstreams/wvstreams-4.0.2.ebuild')
-rw-r--r--net-libs/wvstreams/wvstreams-4.0.2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-libs/wvstreams/wvstreams-4.0.2.ebuild b/net-libs/wvstreams/wvstreams-4.0.2.ebuild
index 35dc373f6753..d7de175f68ff 100644
--- a/net-libs/wvstreams/wvstreams-4.0.2.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.2.ebuild,v 1.11 2005/07/02 18:33:08 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.2.ebuild,v 1.12 2005/10/16 11:06:29 mrness Exp $
inherit eutils
@@ -11,21 +11,21 @@ SRC_URI="http://www.csclub.uwaterloo.ca/~ja2morri/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha ~amd64 hppa ppc sparc x86"
-IUSE="gtk qt vorbis speex fam qdbm pam slp ssl doc fftw tcltk debug"
+IUSE="gtk qt vorbis speex fam qdbm pam slp doc fftw tcltk debug"
RDEPEND="virtual/libc
+ >=sys-libs/db-3
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.7
dev-libs/xplc
gtk? ( >=x11-libs/gtk+-2.2.0 )
qt? ( =x11-libs/qt-3* )
vorbis? ( >=media-libs/libvorbis-1.0 )
speex? ( media-libs/speex !=media-libs/speex-1.1.4 )
fam? ( virtual/fam )
- >=sys-libs/db-3
qdbm? ( dev-db/qdbm )
pam? ( >=sys-libs/pam-0.75 )
slp? ( >=net-libs/openslp-1.0.9a )
- >=sys-libs/zlib-1.1.4
- ssl? ( >=dev-libs/openssl-0.9.7 )
doc? ( app-doc/doxygen )
fftw? ( sci-libs/fftw )
tcltk? ( >=dev-lang/tcl-8.4 dev-lang/swig )"
@@ -66,13 +66,13 @@ src_compile() {
`use_with qdbm` \
`use_with pam` \
`use_with fftw` \
- `use_with ssl openssl` \
`use_with slp openslp` \
`use_with tcltk tcl` \
`use_enable debug` \
--enable-verbose \
--with-bdb \
--with-zlib \
+ --with-openssl \
--with-xplc \
|| die "configure failed"
emake CXXOPTS="-fPIC -DPIC" COPTS="-fPIC -DPIC" || die "compile failed"