summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-11-26 10:33:12 +0000
committerAlin Năstac <mrness@gentoo.org>2005-11-26 10:33:12 +0000
commit47c69c5378a94b9f15684dfb172b28a163329413 (patch)
treea80ca0bfcdb62746dae59874f4b33bd598841cf0 /net-libs/wvstreams/wvstreams-4.0.2.ebuild
parentadd some upstream references (diff)
downloadgentoo-2-47c69c5378a94b9f15684dfb172b28a163329413.tar.gz
gentoo-2-47c69c5378a94b9f15684dfb172b28a163329413.tar.bz2
gentoo-2-47c69c5378a94b9f15684dfb172b28a163329413.zip
Remove obsolete versions. Fix broken compilation on gcc-4.1 (#113488).
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-libs/wvstreams/wvstreams-4.0.2.ebuild')
-rw-r--r--net-libs/wvstreams/wvstreams-4.0.2.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/net-libs/wvstreams/wvstreams-4.0.2.ebuild b/net-libs/wvstreams/wvstreams-4.0.2.ebuild
deleted file mode 100644
index d7de175f68ff..000000000000
--- a/net-libs/wvstreams/wvstreams-4.0.2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.0.2.ebuild,v 1.12 2005/10/16 11:06:29 mrness Exp $
-
-inherit eutils
-
-DESCRIPTION="A network programming library in C++"
-HOMEPAGE="http://open.nit.ca/wiki/?page=WvStreams"
-SRC_URI="http://www.csclub.uwaterloo.ca/~ja2morri/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha ~amd64 hppa ppc sparc x86"
-IUSE="gtk qt vorbis speex fam qdbm pam slp doc fftw tcltk debug"
-
-RDEPEND="virtual/libc
- >=sys-libs/db-3
- >=sys-libs/zlib-1.1.4
- >=dev-libs/openssl-0.9.7
- dev-libs/xplc
- gtk? ( >=x11-libs/gtk+-2.2.0 )
- qt? ( =x11-libs/qt-3* )
- vorbis? ( >=media-libs/libvorbis-1.0 )
- speex? ( media-libs/speex !=media-libs/speex-1.1.4 )
- fam? ( virtual/fam )
- qdbm? ( dev-db/qdbm )
- pam? ( >=sys-libs/pam-0.75 )
- slp? ( >=net-libs/openslp-1.0.9a )
- doc? ( app-doc/doxygen )
- fftw? ( sci-libs/fftw )
- tcltk? ( >=dev-lang/tcl-8.4 dev-lang/swig )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=sys-devel/autoconf-2.59"
-
-src_unpack() {
- unpack ${A} ; cd ${S}
-
- epatch ${FILESDIR}/${P}-linux-serial.patch
- epatch ${FILESDIR}/${P}-wireless-user.patch
- epatch ${FILESDIR}/${P}-speex-const.patch
-
- if useq tcltk; then
- epatch ${FILESDIR}/${P}-tcl_8_4.patch
- env WANT_AUTOCONF=2.59 autoconf || die "autoconf failed"
- fi
-
- useq qt && epatch ${FILESDIR}/${P}-MOC-fix.patch
-}
-
-src_compile() {
- local myconf
- if useq qt; then
- myconf="--with-qt=/usr/qt/3/"
- export MOC="/usr/qt/3/bin/moc"
- else
- myconf="--without-qt"
- fi
- econf ${myconf} \
- `use_with gtk` \
- `use_with vorbis ogg` \
- `use_with vorbis` \
- `use_with speex` \
- `use_with fam` \
- `use_with qdbm` \
- `use_with pam` \
- `use_with fftw` \
- `use_with slp openslp` \
- `use_with tcltk tcl` \
- `use_enable debug` \
- --enable-verbose \
- --with-bdb \
- --with-zlib \
- --with-openssl \
- --with-xplc \
- || die "configure failed"
- emake CXXOPTS="-fPIC -DPIC" COPTS="-fPIC -DPIC" || die "compile failed"
- use doc && doxygen
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc README COPYING.LIB
- use doc && dohtml -r Docs/doxy-html/*
-}