summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-25 15:10:26 +0000
commit3b400917584ce927f27df4cf507cc5630759f143 (patch)
treec5148d0abb45f9c45a2fd8ad233dcda899e8da92 /net-libs
parent*** empty log message *** (diff)
downloadgentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.gz
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.tar.bz2
gentoo-2-3b400917584ce927f27df4cf507cc5630759f143.zip
*** empty log message ***
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpcap/files/digest-libpcap-0.5.21
-rw-r--r--net-libs/libpcap/libpcap-0.5.2.ebuild34
-rw-r--r--net-libs/nss_ldap/files/digest-nss_ldap-1131
-rw-r--r--net-libs/pam_ldap/files/digest-pam_ldap-701
-rw-r--r--net-libs/pam_ldap/pam_ldap-70.ebuild38
5 files changed, 75 insertions, 0 deletions
diff --git a/net-libs/libpcap/files/digest-libpcap-0.5.2 b/net-libs/libpcap/files/digest-libpcap-0.5.2
new file mode 100644
index 000000000000..66c4563f9ca0
--- /dev/null
+++ b/net-libs/libpcap/files/digest-libpcap-0.5.2
@@ -0,0 +1 @@
+MD5 1138682b9bef56c8c9986346645f7216 libpcap-0.5.2.tar.gz
diff --git a/net-libs/libpcap/libpcap-0.5.2.ebuild b/net-libs/libpcap/libpcap-0.5.2.ebuild
new file mode 100644
index 000000000000..34f162ca0e49
--- /dev/null
+++ b/net-libs/libpcap/libpcap-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-0.5.2.ebuild,v 1.1 2000/08/25 15:10:24 achim Exp $
+
+P=libpcap-0.5.2
+A=${P}.tar.gz
+S=${WORKDIR}/libpcap-0.5
+DESCRIPTION="pcap-Library"
+SRC_URI="http://www.tcpdump.org/release/${A}
+ http://www.jp.tcpdump.org/release/${A}"
+
+HOMEPAGE="http://www.tcpdump.org/"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --enable-ipv6
+ make
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib
+ dodir /usr/include/net
+ dodir /usr/man/man3
+ make prefix=${D}/usr install
+ make prefix=${D}/usr install-incl
+ make prefix=${D}/usr install-man
+ prepman
+ dodoc CREDITS CHANGES FILES README VERSION
+}
+
+
+
diff --git a/net-libs/nss_ldap/files/digest-nss_ldap-113 b/net-libs/nss_ldap/files/digest-nss_ldap-113
new file mode 100644
index 000000000000..28e11732ec62
--- /dev/null
+++ b/net-libs/nss_ldap/files/digest-nss_ldap-113
@@ -0,0 +1 @@
+MD5 e87bc89fc4b36bed22c71814153f38ef nss_ldap-113.tar.gz
diff --git a/net-libs/pam_ldap/files/digest-pam_ldap-70 b/net-libs/pam_ldap/files/digest-pam_ldap-70
new file mode 100644
index 000000000000..ade7cc78b409
--- /dev/null
+++ b/net-libs/pam_ldap/files/digest-pam_ldap-70
@@ -0,0 +1 @@
+MD5 b4abdec81242136a685ee28166d72599 pam_ldap-70.tar.gz
diff --git a/net-libs/pam_ldap/pam_ldap-70.ebuild b/net-libs/pam_ldap/pam_ldap-70.ebuild
new file mode 100644
index 000000000000..06f58bc94003
--- /dev/null
+++ b/net-libs/pam_ldap/pam_ldap-70.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/pam_ldap/pam_ldap-70.ebuild,v 1.1 2000/08/25 15:10:24 achim Exp $
+
+P=pam_ldap-70
+A=pam_ldap-70.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="PAM LDAP Module"
+HOMEPAGE="http://www.padl.com/pam_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/"${A}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ touch NEWS
+ touch AUTHORS
+ ./configure --host=${CHOST} --prefix=/usr --with-ldap-lib=openldap
+ make
+}
+
+src_install() {
+ cd ${S}
+ exeinto /usr/lib/security
+ doexe pam_ldap.so
+ dodoc pam.conf ldap.conf
+ dodoc ChangeLog COPYING.* CVSVersionInfo.txt README
+ docinto pam.d
+ dodoc pam.d/*
+}
+
+
+
+
+