summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-09 00:18:32 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-09 00:18:32 +0000
commitde6d3fc6ae02bb82cee969bd5d4e4ca4f1ea92e8 (patch)
tree3beed5a834a63b6f6a681be35fe8e0a0ea67f2e1 /net-libs
parentrevision bump with h263 support (diff)
downloadgentoo-2-de6d3fc6ae02bb82cee969bd5d4e4ca4f1ea92e8.tar.gz
gentoo-2-de6d3fc6ae02bb82cee969bd5d4e4ca4f1ea92e8.tar.bz2
gentoo-2-de6d3fc6ae02bb82cee969bd5d4e4ca4f1ea92e8.zip
revision bump with h263 support
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/openh323/ChangeLog6
-rw-r--r--net-libs/openh323/Manifest6
-rw-r--r--net-libs/openh323/files/digest-openh323-1.12.0-r11
-rw-r--r--net-libs/openh323/openh323-1.12.0-r1.ebuild95
-rw-r--r--net-libs/openh323/openh323-1.12.0.ebuild9
5 files changed, 113 insertions, 4 deletions
diff --git a/net-libs/openh323/ChangeLog b/net-libs/openh323/ChangeLog
index d4729a718c56..a1f5031ccffb 100644
--- a/net-libs/openh323/ChangeLog
+++ b/net-libs/openh323/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
# $Header:
+*openh323-1.12.0-r1 (09 Jul 2003)
+
+ 09 Jul 2003; Alastair Tse <liquidx@gentoo.org> openh323-1.12.0-r1.ebuild,
+ openh323-1.12.0.ebuild:
+ adds ffmpeg support. also has backwards compatibility symlinks with -r0
+
29 Jun 2003; Alastair Tse <liquidx@gentoo.org> openh323-1.11.7.ebuild,
openh323-1.12.0.ebuild:
fix broken libopenh323 symlink
diff --git a/net-libs/openh323/Manifest b/net-libs/openh323/Manifest
index 6258e8d485e3..9ddf337bb5d7 100644
--- a/net-libs/openh323/Manifest
+++ b/net-libs/openh323/Manifest
@@ -1,9 +1,9 @@
-MD5 7761cc20feb75988c98bcd1a9ba46855 ChangeLog 3157
+MD5 9fd8b1975e9a9ad314e059223ad7de84 ChangeLog 3369
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 00792a32c848412e425a67c20a72b594 openh323-1.9.10-r1.ebuild 1120
-MD5 0275ad06793591aecbf4c72212608697 openh323-1.12.0.ebuild 2181
+MD5 c65a41c26c255742f72421fe4a6a8cb5 openh323-1.12.0.ebuild 2221
MD5 da0bf4fee9d0011905bcb66384df7b53 openh323-1.11.7.ebuild 1844
-MD5 0275ad06793591aecbf4c72212608697 openh323-1.12.0-r1.ebuild 2181
+MD5 7e4c9bd933000671b974c4610f9b6e8f openh323-1.12.0-r1.ebuild 2713
MD5 238a3a0b91aabce0a61e0dd5c4b9ee68 files/digest-openh323-1.12.0 68
MD5 238a3a0b91aabce0a61e0dd5c4b9ee68 files/digest-openh323-1.12.0-r1 68
MD5 47caff52a16cf5135ad984dcfe022f6a files/digest-openh323-1.9.10-r1 68
diff --git a/net-libs/openh323/files/digest-openh323-1.12.0-r1 b/net-libs/openh323/files/digest-openh323-1.12.0-r1
new file mode 100644
index 000000000000..e17382151a0f
--- /dev/null
+++ b/net-libs/openh323/files/digest-openh323-1.12.0-r1
@@ -0,0 +1 @@
+MD5 f7932f0a17d6afafc7332036a4b5d392 openh323_1.12.0.tar.gz 2325128
diff --git a/net-libs/openh323/openh323-1.12.0-r1.ebuild b/net-libs/openh323/openh323-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..a1a61382d440
--- /dev/null
+++ b/net-libs/openh323/openh323-1.12.0-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.12.0-r1.ebuild,v 1.1 2003/07/09 00:18:23 liquidx Exp $
+
+IUSE="ssl"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Open Source implementation of the ITU H.323 teleconferencing protocol"
+HOMEPAGE="http://www.openh323.org"
+SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~ppc -sparc "
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-libs/pwlib-1.5.0
+ >=media-libs/ffmpeg-0.4.7_pre20030624
+ ssl? ( dev-libs/openssl )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ # to prevent merge problems with broken makefiles from old
+ # pwlib versions, we double-check here.
+
+ if [ "` fgrep '\$(OPENSSLDIR)/include' /usr/share/pwlib/make/unix.mak`" ]
+ then
+ # patch unix.mak so it doesn't require annoying
+ # unmerge/merge cycle to upgrade
+ einfo "Fixing broken pwlib makefile."
+ cd /usr/share/pwlib/make
+ sed -i \
+ -e "s:-DP_SSL -I\$(OPENSSLDIR)/include -I\$(OPENSSLDIR)/crypto:-DP_SSL:" \
+ -e "s:^LDFLAGS.*\+= -L\$(OPENSSLDIR)/lib -L\$(OPENSSLDIR):LDFLAGS +=:" \
+ unix.mak
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ # enabling ffmpeg/h263 support
+ cd ${S}; sed -i -e "s:/usr/local/include/ffmpeg:/usr/include/ffmpeg:" configure
+}
+
+src_compile() {
+ local makeopts
+
+ export PWLIBDIR=/usr/share/pwlib
+ export OPENH323DIR=${S}
+
+ # NOTRACE avoid compilation problems, we disable PTRACING using NOTRACE=1
+ makeopts="${makeopts} ASNPARSER=/usr/bin/asnparser NOTRACE=1"
+
+
+ if [ "`use ssl`" ]; then
+ export OPENSSLFLAG=1
+ export OPENSSLDIR=/usr
+ export OPENSSLLIBS="-lssl -lcrypt"
+ fi
+
+ econf || die
+ emake ${makeopts} opt || die "make failed"
+}
+
+src_install() {
+ local OPENH323_ARCH ALT_ARCH
+ # make NOTRACE=1 opt ==> linux_$ARCH_n
+ # make opt ==> linux_$ARCH_r
+ OPENH323_ARCH="linux_${ARCH}_n"
+
+ dodir /usr/bin /usr/lib/ /usr/share
+ make PREFIX=${D}/usr install || die "install failed"
+ dobin ${S}/samples/simple/obj_${OPENH323_ARCH}/simph323
+
+ find ${D} -name 'CVS' -type d | xargs rm -rf
+
+ # mod to keep gnugk happy
+ insinto /usr/share/openh323/src
+ newins ${FILESDIR}/openh323-1.11.7-emptyMakefile Makefile
+
+ rm ${D}/usr/lib/libopenh323.so
+ dosym /usr/lib/libh323_${OPENH323_ARCH}.so.${PV} /usr/lib/libopenh323.so
+
+ # for backwards compatibility with _r versioned libraries
+ ALT_ARCH=${OPENH323_ARCH/_n/_r}
+ for pv in ${PV} ${PV%.[0-9]} ${PV%.[0-9]*.[0-9]}; do
+ einfo "creating /usr/lib/libh323_${ALT_ARCH}.so.${pv} symlink"
+ dosym /usr/lib/libh323_${OPENH323_ARCH}.so.${PV} /usr/lib/libh323_${ALT_ARCH}.so.${pv}
+ done
+ dosym /usr/lib/libh323_${OPENH323_ARCH}.so.${PV} /usr/lib/libh323_${ALT_ARCH}.so
+
+}
+
+
diff --git a/net-libs/openh323/openh323-1.12.0.ebuild b/net-libs/openh323/openh323-1.12.0.ebuild
index 7f890f197a1c..90798e0ba58f 100644
--- a/net-libs/openh323/openh323-1.12.0.ebuild
+++ b/net-libs/openh323/openh323-1.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.12.0.ebuild,v 1.3 2003/06/29 17:00:38 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openh323/openh323-1.12.0.ebuild,v 1.4 2003/07/09 00:18:23 liquidx Exp $
IUSE="ssl"
@@ -37,6 +37,13 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:/usr/local/include/ffmpeg:/usr/include/ffmpeg:" configure
+ epatch ${FILESDIR}/${P}-ptracing.patch
+}
+
src_compile() {
local makeopts