summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-08-09 17:47:19 +0000
committerMichał Górny <mgorny@gentoo.org>2011-08-09 17:47:19 +0000
commitb3f68e4f7b07c27015b843f0709de8126f0d1019 (patch)
tree2f6e2f1359edc5c708437dc34f3df61f0fce9163 /net-libs
parentMarked ~ppc wrt #360269 (diff)
downloadgentoo-2-b3f68e4f7b07c27015b843f0709de8126f0d1019.tar.gz
gentoo-2-b3f68e4f7b07c27015b843f0709de8126f0d1019.tar.bz2
gentoo-2-b3f68e4f7b07c27015b843f0709de8126f0d1019.zip
Split the Python module into separate dev-python/miniupnpc. Bump EAPI, cleanup.
(Portage version: 2.2.0_alpha50_p1/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/miniupnpc/ChangeLog9
-rw-r--r--net-libs/miniupnpc/miniupnpc-1.6-r1.ebuild (renamed from net-libs/miniupnpc/miniupnpc-1.6.ebuild)32
2 files changed, 18 insertions, 23 deletions
diff --git a/net-libs/miniupnpc/ChangeLog b/net-libs/miniupnpc/ChangeLog
index 190e5a45a254..8519f17dde12 100644
--- a/net-libs/miniupnpc/ChangeLog
+++ b/net-libs/miniupnpc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/miniupnpc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.14 2011/08/09 13:34:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.15 2011/08/09 17:47:19 mgorny Exp $
+
+*miniupnpc-1.6-r1 (09 Aug 2011)
+
+ 09 Aug 2011; Michał Górny <mgorny@gentoo.org> -miniupnpc-1.6.ebuild,
+ +miniupnpc-1.6-r1.ebuild:
+ Split the Python module into separate dev-python/miniupnpc. Bump EAPI,
+ cleanup.
09 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> miniupnpc-1.6.ebuild:
Marked ~ppc64 wrt #377513
diff --git a/net-libs/miniupnpc/miniupnpc-1.6.ebuild b/net-libs/miniupnpc/miniupnpc-1.6-r1.ebuild
index 04795471097d..e56eb9513d6d 100644
--- a/net-libs/miniupnpc/miniupnpc-1.6.ebuild
+++ b/net-libs/miniupnpc/miniupnpc-1.6-r1.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/miniupnpc-1.6.ebuild,v 1.3 2011/08/09 13:34:36 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/miniupnpc-1.6-r1.ebuild,v 1.1 2011/08/09 17:47:19 mgorny Exp $
-EAPI=3
-SUPPORT_PYTHON_ABIS=1
-PYTHON_DEPEND="python? 2"
-RESTRICT_PYTHON_ABIS="3.*"
+EAPI=4
-inherit base distutils eutils toolchain-funcs
+inherit base toolchain-funcs
DESCRIPTION="UPnP client library and a simple UPnP client"
HOMEPAGE="http://miniupnp.free.fr/"
@@ -16,7 +13,7 @@ SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="python static-libs"
+IUSE="static-libs"
DEPEND="sys-apps/lsb-release"
RDEPEND=""
@@ -34,35 +31,26 @@ src_prepare() {
-e '/$(INSTALL) -m 644 $(LIBRARY) $(INSTALLDIRLIB)/d' \
-i Makefile || die
fi
-
- use python && distutils_src_prepare
}
# Upstream cmake causes more trouble than it fixes,
# so we'll just stay with the Makefile for now.
src_compile() {
- emake CC=$(tc-getCC) || die
-
- use python && distutils_src_compile
+ emake CC="$(tc-getCC)"
}
src_install() {
emake \
PREFIX="${D}" \
INSTALLDIRLIB="${D}usr/$(get_libdir)" \
- install || die
-
- dodoc README Changelog.txt || die
- doman man3/* || die
+ install
- use python && distutils_src_install
+ dodoc README Changelog.txt
+ doman man3/*
}
pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
+ elog "Please note that the python counterpart has been moved to"
+ elog " dev-python/miniupnpc"
}