summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-05-14 20:15:09 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-05-14 20:15:09 +0000
commit27699d5a3df9678fece3dbe556a84db0dd7914d1 (patch)
tree6c1bc2faca86c45ed5beeeae4ad4eb464400cc44 /net-mail/courier
parenthtml-tree first relase (diff)
downloadgentoo-2-27699d5a3df9678fece3dbe556a84db0dd7914d1.tar.gz
gentoo-2-27699d5a3df9678fece3dbe556a84db0dd7914d1.tar.bz2
gentoo-2-27699d5a3df9678fece3dbe556a84db0dd7914d1.zip
New package.
Diffstat (limited to 'net-mail/courier')
-rw-r--r--net-mail/courier/ChangeLog8
-rw-r--r--net-mail/courier/courier-0.38.0.ebuild100
-rw-r--r--net-mail/courier/files/courier19
-rw-r--r--net-mail/courier/files/courier-authdaemond20
-rw-r--r--net-mail/courier/files/courier-esmtpd20
-rw-r--r--net-mail/courier/files/courier-esmtpd-msa20
-rw-r--r--net-mail/courier/files/courier-esmtpd-ssl20
-rw-r--r--net-mail/courier/files/courier-imapd20
-rw-r--r--net-mail/courier/files/courier-imapd-ssl20
-rw-r--r--net-mail/courier/files/courier-mta20
-rw-r--r--net-mail/courier/files/courier-pop3d20
-rw-r--r--net-mail/courier/files/courier-pop3d-ssl20
-rw-r--r--net-mail/courier/files/digest-courier-0.38.01
-rw-r--r--net-mail/courier/files/set-mime28
14 files changed, 336 insertions, 0 deletions
diff --git a/net-mail/courier/ChangeLog b/net-mail/courier/ChangeLog
new file mode 100644
index 000000000000..c814a2579e4f
--- /dev/null
+++ b/net-mail/courier/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-mail/courier-imap
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/net-mail/courier/ChangeLog,v 1.5 2002/05/04 03:10:05 woodchip Exp
+04.05.2002
+initial working release
+06.05.2002
+added some post install comments and a "set-mime" script which tweaks the
+mta's default behaviour regarding MIME headers. \ No newline at end of file
diff --git a/net-mail/courier/courier-0.38.0.ebuild b/net-mail/courier/courier-0.38.0.ebuild
new file mode 100644
index 000000000000..76f0b828282a
--- /dev/null
+++ b/net-mail/courier/courier-0.38.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# Adapted for courier MTA by Andreas Erhart <andi@as-computer.de> and
+# Alex Hartmann <alex@as-computer.de>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/courier/courier-0.38.0.ebuild,v 1.1 2002/05/14 20:15:09 g2boojum Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An MTA designed specifically for maildirs"
+SRC_URI="http://ftp1.sourceforge.net/courier/${P}.tar.gz"
+HOMEPAGE="http://www.courier-mta.org/"
+
+PROVIDE="virtual/mta
+ virtual/imapd"
+RDEPEND="virtual/glibc
+ >=dev-libs/openssl-0.9.6
+ >=dev-tcltk/expect-5.33.0
+ pam? ( >=sys-libs/pam-0.75 )
+ berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ mysql? ( >=dev-db/mysql-3.23.36 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1.3 )
+ tcltk? ( >=dev-tcltk/expect-5.33.0 )"
+DEPEND="${RDEPEND} sys-devel/perl sys-apps/procps"
+
+# I'm not sure about .maildir and Maildir issue. This package will probably work just
+# with Maildir. Is there a standard ? What's the best way to do it ?
+
+src_compile() {
+ local myconf
+ use pam || myconf="${myconf} --without-authpam"
+ use ldap || myconf="${myconf} --without-authldap"
+ use mysql || myconf="${myconf} --without-authmysql"
+ use postgres || myconf="${myconf} --without-authpostgresql"
+ use berkdb && myconf="${myconf} --with-db=db"
+ use berkdb || myconf="${myconf} --with-db=gdbm"
+
+ ./configure \
+ --prefix=/usr \
+ --disable-root-check \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/courier \
+ --libexecdir=/usr/lib/courier \
+ --datadir=/usr/share/courier \
+ --sharedstatedir=/var/lib/courier/com \
+ --localstatedir=/var/lib/courier \
+ --with-piddir=/var/run/courier \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --with-paranoid-smtpext \
+ --enable-mimetypes=/etc/apache/conf/mime.types \
+ --enable-workarounds-for-imap-client-bugs \
+ --with-authdaemonvar=/var/lib/courier/authdaemon \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ dodir /var/lib/courier
+ mkdir -p ${D}/etc/pam.d
+ mkdir -p ${D}/var/run/courier
+ make install DESTDIR=${D}
+
+ cd ${D}/etc/courier
+ local x
+ for x in courierd pop3d pop3d-ssl imapd imapd-ssl authdaemonrc
+ do
+ mv ${x}.dist ${x}
+ done
+
+ if [ -d ${D}/etc/pam.d ]
+ then
+ [ -f esmtp.authpam ] && mv esmtp.authpam ${D}/etc/pam.d/esmtp
+ [ -f pop3d.authpam ] && mv pop3d.authpam ${D}/etc/pam.d/pop3
+ [ -f imapd.authpam ] && mv imapd.authpam ${D}/etc/pam.d/imap
+ [ -f webmail.authpam ] && mv webmail.authpam ${D}/etc/pam.d/webmail
+ fi
+
+exeinto /etc/init.d
+ newexe ${FILESDIR}/courier courier
+ newexe ${FILESDIR}/courier-authdaemond courier-authdaemond
+ newexe ${FILESDIR}/courier-mta courier-mta
+ newexe ${FILESDIR}/courier-esmtpd courier-esmtpd
+ newexe ${FILESDIR}/courier-esmtpd-ssl courier-esmtpd-ssl
+ newexe ${FILESDIR}/courier-esmtpd-msa courier-esmtpd-msa
+ newexe ${FILESDIR}/courier-imapd courier-imapd
+ newexe ${FILESDIR}/courier-imapd-ssl courier-imapd-ssl
+ newexe ${FILESDIR}/courier-pop3d-ssl courier-pop3d-ssl
+ newexe ${FILESDIR}/courier-pop3d courier-pop3d
+exeinto /etc/courier
+ newexe ${FILESDIR}/set-mime set-mime
+}
+pkg_postinst() {
+ echo -e "\e[32;01m If you need imap-ssl you should edit /etc/courier/imapd.cnf \033[0m"
+ echo -e "\e[32;01m and then create a certificate with the command mkimapdcert. \033[0m"
+ echo -e "\e[32;01m You'll find a set-mime script in /etc/courier which you can use to \033[0m"
+ echo -e "\e[32;01m set the desired MIME headers behaviour. Have a look at comments for syntax. \033[0m"
+}
diff --git a/net-mail/courier/files/courier b/net-mail/courier/files/courier
new file mode 100644
index 000000000000..6c8675eed951
--- /dev/null
+++ b/net-mail/courier/files/courier
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond courier-mta courier-esmtpd courier-esmtpd-ssl courier-esmtpd-msa courier-imapd courier-imapd-ssl courier-pop3d courier-pop3d-ssl
+}
+
+start() {
+ ebegin "Courier MTA startet"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Courier MTA"
+ /etc/init.d/courier-authdaemond stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-authdaemond b/net-mail/courier/files/courier-authdaemond
new file mode 100644
index 000000000000..ecfcfc0e8200
--- /dev/null
+++ b/net-mail/courier/files/courier-authdaemond
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting courier authdaemon"
+ /usr/lib/courier/authlib/authdaemond start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier authdaemon"
+ /usr/lib/courier/authlib/authdaemond stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-esmtpd b/net-mail/courier/files/courier-esmtpd
new file mode 100644
index 000000000000..2340a77ca087
--- /dev/null
+++ b/net-mail/courier/files/courier-esmtpd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier esmtpd"
+ /usr/sbin/esmtpd start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier esmtpd"
+ /usr/sbin/esmtpd stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-esmtpd-msa b/net-mail/courier/files/courier-esmtpd-msa
new file mode 100644
index 000000000000..9454a8f6ede5
--- /dev/null
+++ b/net-mail/courier/files/courier-esmtpd-msa
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier esmtpd-msa"
+ /usr/sbin/esmtpd-msa start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier esmtpd-msa"
+ /usr/sbin/esmtpd-msa stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-esmtpd-ssl b/net-mail/courier/files/courier-esmtpd-ssl
new file mode 100644
index 000000000000..fe2725efd9ed
--- /dev/null
+++ b/net-mail/courier/files/courier-esmtpd-ssl
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier esmtpd-ssl"
+ /usr/sbin/esmtpd-ssl start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier esmtpd-ssl"
+ /usr/sbin/esmtpd-ssl stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-imapd b/net-mail/courier/files/courier-imapd
new file mode 100644
index 000000000000..b146243fb3d7
--- /dev/null
+++ b/net-mail/courier/files/courier-imapd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier imapd"
+ /usr/sbin/imapd start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier imapd"
+ /usr/sbin/imapd stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-imapd-ssl b/net-mail/courier/files/courier-imapd-ssl
new file mode 100644
index 000000000000..b41cdfe1106c
--- /dev/null
+++ b/net-mail/courier/files/courier-imapd-ssl
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier imapd-ssl"
+ /usr/sbin/imapd-ssl start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier imapd-ssl"
+ /usr/sbin/imapd-ssl stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-mta b/net-mail/courier/files/courier-mta
new file mode 100644
index 000000000000..87bc7c84e408
--- /dev/null
+++ b/net-mail/courier/files/courier-mta
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier-mta"
+ /usr/sbin/courier start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier-mta"
+ /usr/sbin/courier stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-pop3d b/net-mail/courier/files/courier-pop3d
new file mode 100644
index 000000000000..6c73f73936f4
--- /dev/null
+++ b/net-mail/courier/files/courier-pop3d
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier pop3d"
+ /usr/sbin/pop3d start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier pop3d"
+ /usr/sbin/pop3d stop
+ eend $?
+}
diff --git a/net-mail/courier/files/courier-pop3d-ssl b/net-mail/courier/files/courier-pop3d-ssl
new file mode 100644
index 000000000000..e34984db099c
--- /dev/null
+++ b/net-mail/courier/files/courier-pop3d-ssl
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.3 2002/02/09 01:08:04 woodchip Exp
+
+depend() {
+ need net courier-authdaemond
+}
+
+start() {
+ ebegin "Starting courier pop3d-ssl"
+ /usr/sbin/pop3d-ssl start
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping courier pop3d-ssl"
+ /usr/sbin/pop3d-ssl stop
+ eend $?
+}
diff --git a/net-mail/courier/files/digest-courier-0.38.0 b/net-mail/courier/files/digest-courier-0.38.0
new file mode 100644
index 000000000000..d54ee16ea3bd
--- /dev/null
+++ b/net-mail/courier/files/digest-courier-0.38.0
@@ -0,0 +1 @@
+MD5 980d03ed862375f61a9f8e93987a399f courier-0.38.0.tar.gz 3440513
diff --git a/net-mail/courier/files/set-mime b/net-mail/courier/files/set-mime
new file mode 100644
index 000000000000..840ce7b9cd1b
--- /dev/null
+++ b/net-mail/courier/files/set-mime
@@ -0,0 +1,28 @@
+#!/bin/sh
+# this has to be called with a list of configuration files to apply the
+# changes
+# example: ./set-mime /etc/courier/esmtpd /etc/courier/esmtpd-ssl
+
+files=$*
+
+chk_badmime='##NAME: BOFHBADMIME:0'
+pos_badmime='##NAME: NOADDMSGID:0'
+ins_badmime='\
+##NAME: BOFHBADMIME:0\
+#\
+# set BOFHBADMIME\
+# to \"reject\" to return mail with invalid MIME header\
+# to \"wrap\" to wrap mail with invalid MIME header in an attachmant\
+# to \"accept\" to pass mail with invalid MIME header untouched\
+\
+BOFHBADMIME=accept\
+'
+
+for f in ${files}
+do
+ if ! grep -q "${chk_badmime}" "${f}"
+ then
+ echo "adding parameter ${chk_badmime} to ${f}"
+ cat ${f} | sed -e"/${pos_badmime}/ i ${ins_badmime}" > "${f}.tmp" && mv -f "${f}.tmp" "${f}"
+ fi
+done