summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-07 16:55:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-07 16:55:04 +0000
commit93ff04ce5d0b5f2a757aa1333d472f9410345b8f (patch)
tree4e5724485c94c71696f949cf0e199b7f7f4faa75 /net-mail/qmailanalog
parenterrno fix #17012 (diff)
downloadgentoo-2-93ff04ce5d0b5f2a757aa1333d472f9410345b8f.tar.gz
gentoo-2-93ff04ce5d0b5f2a757aa1333d472f9410345b8f.tar.bz2
gentoo-2-93ff04ce5d0b5f2a757aa1333d472f9410345b8f.zip
glibc fix #17013
Diffstat (limited to 'net-mail/qmailanalog')
-rw-r--r--net-mail/qmailanalog/ChangeLog16
-rw-r--r--net-mail/qmailanalog/files/0.70-errno.patch11
-rw-r--r--net-mail/qmailanalog/files/digest-qmailanalog-0.70-r1 (renamed from net-mail/qmailanalog/files/digest-qmailanalog-0.70)0
-rw-r--r--net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild (renamed from net-mail/qmailanalog/qmailanalog-0.70.ebuild)24
4 files changed, 35 insertions, 16 deletions
diff --git a/net-mail/qmailanalog/ChangeLog b/net-mail/qmailanalog/ChangeLog
index d181955d8ec6..5f300403c25d 100644
--- a/net-mail/qmailanalog/ChangeLog
+++ b/net-mail/qmailanalog/ChangeLog
@@ -1,18 +1,20 @@
# ChangeLog for net-mail/qmailanalog
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmailanalog/ChangeLog,v 1.5 2003/02/12 08:15:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmailanalog/ChangeLog,v 1.6 2003/03/07 16:55:04 vapier Exp $
+
+*qmailanalog-0.70-r1 (07 Mar 2003)
+
+ 07 Mar 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added patch for glibc errno issue (#16267) #17013.
+ matrixise <stephane.wirtel@belgacom.net> submitted the patch #17013.
+
+*qmailanalog-0.70 (1 Feb 2002)
- 06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
17 Jun 2002; Thilo Bangert <bangert@gentoo.org> qmailanalog-0.70.ebuild
-
fixed conf-home, conf-cc & conf-ld. closes bug #2727
added LICENSE
-*qmailanalog-0.70 (1 Feb 2002)
-
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/net-mail/qmailanalog/files/0.70-errno.patch b/net-mail/qmailanalog/files/0.70-errno.patch
new file mode 100644
index 000000000000..4aca1b2b4e58
--- /dev/null
+++ b/net-mail/qmailanalog/files/0.70-errno.patch
@@ -0,0 +1,11 @@
+--- error.h.orig 2003-03-05 15:42:51.000000000 -0500
++++ error.h 2003-03-05 15:43:00.000000000 -0500
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/net-mail/qmailanalog/files/digest-qmailanalog-0.70 b/net-mail/qmailanalog/files/digest-qmailanalog-0.70-r1
index f3c4ea162048..f3c4ea162048 100644
--- a/net-mail/qmailanalog/files/digest-qmailanalog-0.70
+++ b/net-mail/qmailanalog/files/digest-qmailanalog-0.70-r1
diff --git a/net-mail/qmailanalog/qmailanalog-0.70.ebuild b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
index a262016bde27..1dc893efac21 100644
--- a/net-mail/qmailanalog/qmailanalog-0.70.ebuild
+++ b/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild
@@ -1,34 +1,40 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qmailanalog/qmailanalog-0.70.ebuild,v 1.8 2003/02/13 14:38:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qmailanalog/qmailanalog-0.70-r1.ebuild,v 1.1 2003/03/07 16:55:04 vapier Exp $
-S=${WORKDIR}/${P}
-DESCRIPTION="collection of tools to help you analyze qmail's activity record."
+inherit eutils
+
+DESCRIPTION="collection of tools to help you analyze qmail's activity record"
SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
HOMEPAGE="http://cr.yp.to/qmailanalog.html"
SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
DEPEND="sys-apps/groff"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-errno.patch
+}
+
src_compile() {
echo "/var/qmail" > conf-home
echo "gcc ${CFLAGS}" > conf-cc
echo "gcc" > conf-ld
-
+
emake || die
- gcc ${FILESDIR}/tai64nfrac.c -o tai64nfrac
+ gcc ${CFLAGS} ${FILESDIR}/tai64nfrac.c -o tai64nfrac || die
}
-src_install () {
- into /usr
+src_install() {
doman matchup.1 xqp.1 xsender.1 xrecipient.1 columnt.1
dodoc MATCHUP ACCOUNTING BLURB
insopts -o root -g qmail -m 755
- insinto /var/qmail/bin
+ insinto /var/qmail/bin
into /var/qmail
dobin columnt ddist deferrals failures matchup recipients rhosts
dobin rxdelay senders successes suids xqp xrecipient xsender