summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-26 03:52:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-26 03:52:52 +0000
commit5a1dfbfbed55a5fe357f169122e43a11385a0be3 (patch)
treed772afd564bcb21776f28be8a8e6c075f7ad1edb /net-mail
parentsome cleaning (diff)
downloadgentoo-2-5a1dfbfbed55a5fe357f169122e43a11385a0be3.tar.gz
gentoo-2-5a1dfbfbed55a5fe357f169122e43a11385a0be3.tar.bz2
gentoo-2-5a1dfbfbed55a5fe357f169122e43a11385a0be3.zip
version bump
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sylpheed/ChangeLog9
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.8.11
-rw-r--r--net-mail/sylpheed/sylpheed-0.8.1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-mail/sylpheed/ChangeLog b/net-mail/sylpheed/ChangeLog
index ce3546bfc363..328f746a7ea8 100644
--- a/net-mail/sylpheed/ChangeLog
+++ b/net-mail/sylpheed/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/sylpheed
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.11 2002/07/14 16:40:47 mjc Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/ChangeLog,v 1.12 2002/07/26 03:52:52 seemant Exp $
+
+*sylpheed-0.8.1 (25 Jul 2002)
+
+ 25 Jul 2002; Seemant Kulleen <seemant@gentoo.org> sylpheed-0.8.1.ebuild
+ files/digest-sylpheed-0.8.1 :
+
+ Version bump.
*sylpheed-0.8.0 (14 Jul 2002)
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.8.1 b/net-mail/sylpheed/files/digest-sylpheed-0.8.1
new file mode 100644
index 000000000000..91e8be9c5721
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.8.1
@@ -0,0 +1 @@
+MD5 ed678ccf9a2eafd54445f4c77cd800a4 sylpheed-0.8.1.tar.bz2 1822852
diff --git a/net-mail/sylpheed/sylpheed-0.8.1.ebuild b/net-mail/sylpheed/sylpheed-0.8.1.ebuild
new file mode 100644
index 000000000000..5cc653fcae53
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.8.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.8.1.ebuild,v 1.1 2002/07/26 03:52:52 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=media-libs/compface-1.4
+ ssl? ( dev-libs/openssl )
+ pda? ( app-misc/jpilot )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ crypt? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.3 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+
+ local myconf
+
+ use gnome || myconf="--disable-gdk-pixbuf --disable-imlib"
+ use nls || myconf="$myconf --disable-nls"
+ use ssl && myconf="$myconf --enable-ssl"
+ use crypt && myconf="$myconf --enable-gpgme"
+ use pda && myconf="$myconf --enable-jpilot"
+ use ldap && myconf="$myconf --enable-ldap"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --enable-ipv6 $myconf || die
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ manualdir=${D}/usr/share/doc/${PF}/html \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+}
+