summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-25 18:50:19 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-25 18:50:19 +0000
commitdf2a683e91d27d43262ed087e7b79d710a94a7d6 (patch)
treef3c6832020ea563532b6cfa4af04fa5a35afb6a3 /net-mail
parentbump (diff)
downloadgentoo-2-df2a683e91d27d43262ed087e7b79d710a94a7d6.tar.gz
gentoo-2-df2a683e91d27d43262ed087e7b79d710a94a7d6.tar.bz2
gentoo-2-df2a683e91d27d43262ed087e7b79d710a94a7d6.zip
Added DEBUG support and fixed the ssl certs directory
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/pine/ChangeLog6
-rw-r--r--net-mail/pine/pine-4.50.ebuild41
2 files changed, 30 insertions, 17 deletions
diff --git a/net-mail/pine/ChangeLog b/net-mail/pine/ChangeLog
index cc8c4c8442d9..4d43ed34d1dd 100644
--- a/net-mail/pine/ChangeLog
+++ b/net-mail/pine/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-mail/pine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.7 2002/11/22 07:06:09 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/ChangeLog,v 1.8 2002/11/25 18:50:19 raker Exp $
*pine-4.50 (22 Nov 2002)
+ 25 Nov 2002; Nick Hadaway <raker@gentoo.org> pine-4.50.ebuild :
+ Added ability to compile with/without debugging. Fixed the
+ ssl certs directory (openssl-0.9.6-r1 style)
+
22 Nov 2002; Nick Hadaway <raker@gentoo.org> pine-4.50.ebuild,
files/digest-pine-4.50 :
Version bump. lots of fixes. Threaded index is included.
diff --git a/net-mail/pine/pine-4.50.ebuild b/net-mail/pine/pine-4.50.ebuild
index e434ffb3d50d..17c08ccdb3f3 100644
--- a/net-mail/pine/pine-4.50.ebuild
+++ b/net-mail/pine/pine-4.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.50.ebuild,v 1.1 2002/11/22 07:06:09 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/pine/pine-4.50.ebuild,v 1.2 2002/11/25 18:50:19 raker Exp $
IUSE="ssl ldap"
@@ -56,21 +56,24 @@ src_unpack() {
# gets rid of a call to stripwhitespace()
patch -d ${S} -p1 < ${FILESDIR}/pine-4.33-whitespace.patch
- # 4.50 adds some support for multibyte character sets
- #patch -d ${S} -p1 < ${FILESDIR}/pine-4.44-multibyte.patch
-
- # threaded view and other diplay niceties are now built into
- # pine 4.50
- #bzcat ${FILESDIR}/fancy.patch.bz2 | patch -p0 || die "fancy patch failed"
-
- cd ${S}/pine
- cp makefile.lnx makefile.orig
- sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
- < makefile.orig > makefile.lnx
-
- cd ${S}/pico
- cp makefile.lnx makefile.orig
- sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+ if [ -n "$DEBUG" ]; then
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ < makefile.orig > makefile.lnx
+ else
+ cd ${S}/pine
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ < makefile.orig > makefile.lnx
+ cd ${S}/pico
+ cp makefile.lnx makefile.orig
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" makefile.orig > makefile.lnx
+ fi
}
@@ -79,6 +82,12 @@ src_compile() {
if [ "`use ssl`" ]
then
BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ cd ${S}/imap/src/osdep/unix
+ cp Makefile Makefile.orig
+ sed -e "s:$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:$(SSLCERTS):/etc/ssl/certs:" \
+ < Makefile.orig > Makefile
+ cd ${S}
else
BUILDOPTS="${BUILDOPTS} NOSSL"
fi