summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-12-09 02:22:06 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-12-09 02:22:06 +0000
commitd9e611f1a72b2340a26e90c84fa754ec8e324226 (patch)
treeb0e9e60969c5f31a44979d10b6aca90f63495296 /net-mail
parentVersion bump. (diff)
downloadgentoo-2-d9e611f1a72b2340a26e90c84fa754ec8e324226.tar.gz
gentoo-2-d9e611f1a72b2340a26e90c84fa754ec8e324226.tar.bz2
gentoo-2-d9e611f1a72b2340a26e90c84fa754ec8e324226.zip
fix bug #201686
(Portage version: 2.1.4_rc8)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot/ChangeLog5
-rw-r--r--net-mail/dovecot/dovecot-1.0.8.ebuild44
2 files changed, 23 insertions, 26 deletions
diff --git a/net-mail/dovecot/ChangeLog b/net-mail/dovecot/ChangeLog
index a12f4fac78b5..c462c64d0ac4 100644
--- a/net-mail/dovecot/ChangeLog
+++ b/net-mail/dovecot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/dovecot
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.127 2007/12/08 11:35:02 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/ChangeLog,v 1.128 2007/12/09 02:22:06 wschlich Exp $
+
+ 09 Dec 2007; Wolfram Schlich <wschlich@gentoo.org> dovecot-1.0.8.ebuild:
+ fix bug #201686
*dovecot-1.0.8 (08 Dec 2007)
diff --git a/net-mail/dovecot/dovecot-1.0.8.ebuild b/net-mail/dovecot/dovecot-1.0.8.ebuild
index 42773f3ed894..8bc26fd90277 100644
--- a/net-mail/dovecot/dovecot-1.0.8.ebuild
+++ b/net-mail/dovecot/dovecot-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0.8.ebuild,v 1.2 2007/12/08 23:02:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dovecot/dovecot-1.0.8.ebuild,v 1.3 2007/12/09 02:22:06 wschlich Exp $
inherit autotools eutils ssl-cert
@@ -141,15 +141,6 @@ src_install () {
sed -i -e 's,^#ssl_cert_file =.*,ssl_cert_file = /etc/ssl/dovecot/server.pem,' \
-e 's,^#ssl_key_file =.*,ssl_key_file = /etc/ssl/dovecot/server.key,' \
"${conf}" || die "failed to update SSL settings in dovecot.conf"
-
- # Let's not make a new certificate if we already have one
- if ! [[ -e "${ROOT:-/}"etc/ssl/dovecot/server.pem && \
- -e "${ROOT:-/}"etc/ssl/dovecot/server.key ]]; then
- SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
- insinto "${ROOT:-/}"etc/ssl/dovecot
- docert server
- fowners dovecot:mail /etc/ssl/dovecot/server.{key,pem}
- fi
fi
# Install SQL configuration
@@ -194,31 +185,34 @@ get_config_var() {
}
pkg_postinst() {
- # Touch ssl certs so that they are modified outisde of src_install
- # We do this so portage does't unmerge them - silly portage
- if use ssl; then
- touch "${ROOT:-/}"/etc/ssl/dovecot/server.{key,pem}
- fi
-
elog "The Dovecot configuration has vastly changed since 0.99."
elog "You are encouraged to start afresh with a new configuration file."
elog "see http://wiki.dovecot.org/ for configuration examples."
if [[ -e "${ROOT:-/}"etc/dovecot.conf ]]; then
- ewarn
+ echo
ewarn "The Dovecot configuration now resides in ${ROOT:-/}etc/dovecot"
fi
local base_dir="$(get_config_var base_dir)"
base_dir="${base_dir:-/var/run/dovecot}"
- if use ssl \
- && [[ ! -e "${ROOT:-/}${base_dir}/login/ssl-parameters.dat" ]]; then
- elog
- elog "Dovecot requires DH SSL Parameters if you use SSL connections"
- elog "These take some time to make, and dovecot will create them before"
- elog "it allows any SSL connections."
- elog "You can create them now before starting dovecot like so"
- elog " emerge --config =${PF}"
+ if use ssl; then
+ # Let's not make a new certificate if we already have one
+ if ! [[ -e "${ROOT:-/}"etc/ssl/dovecot/server.pem && \
+ -e "${ROOT:-/}"etc/ssl/dovecot/server.key ]]; then
+ einfo "Creating SSL certificate"
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+ install_cert "${ROOT:-/}"etc/ssl/dovecot/server
+ chown dovecot:mail "${ROOT:-/}"etc/ssl/dovecot/server.{key,pem}
+ fi
+ if [[ ! -e "${ROOT:-/}${base_dir}/login/ssl-parameters.dat" ]]; then
+ echo
+ elog "Dovecot requires DH SSL Parameters if you use SSL connections"
+ elog "These take some time to make, and dovecot will create them before"
+ elog "it allows any SSL connections."
+ elog "You can create them now before starting dovecot like so"
+ elog " emerge --config =${PF}"
+ fi
fi
}