summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-03-28 07:44:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-03-28 07:44:44 +0000
commite352103243d88bba7358fcc9ab52f6917c0a25d8 (patch)
treebd34b90ac48142d9dfcb2474f2a48ee553fc22e4 /net-misc/aget
parentinitial ebuild #33464 (diff)
downloadgentoo-2-e352103243d88bba7358fcc9ab52f6917c0a25d8.tar.gz
gentoo-2-e352103243d88bba7358fcc9ab52f6917c0a25d8.tar.bz2
gentoo-2-e352103243d88bba7358fcc9ab52f6917c0a25d8.zip
initial ebuild #43411
Diffstat (limited to 'net-misc/aget')
-rw-r--r--net-misc/aget/ChangeLog8
-rw-r--r--net-misc/aget/aget-0.4.ebuild34
-rw-r--r--net-misc/aget/files/digest-aget-0.42
3 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/aget/ChangeLog b/net-misc/aget/ChangeLog
new file mode 100644
index 000000000000..3a00a5ad892f
--- /dev/null
+++ b/net-misc/aget/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/aget
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aget/ChangeLog,v 1.1 2004/03/28 07:44:44 vapier Exp $
+
+*aget-0.4 (28 Mar 2004)
+
+ 28 Mar 2004; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Daniel Fullmer #43411.
diff --git a/net-misc/aget/aget-0.4.ebuild b/net-misc/aget/aget-0.4.ebuild
new file mode 100644
index 000000000000..af166c743268
--- /dev/null
+++ b/net-misc/aget/aget-0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/aget/aget-0.4.ebuild,v 1.1 2004/03/28 07:44:44 vapier Exp $
+
+inherit eutils
+
+DEB_PATCH="${PN}_${PV}-4.diff"
+DESCRIPTION="multithreaded HTTP download accelerator"
+HOMEPAGE="http://www.enderunix.org/aget/"
+SRC_URI="http://www.enderunix.org/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/a/${PN}/${DEB_PATCH}.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${DEB_PATCH}
+ sed -i "/^CFLAGS/s:-g:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin aget || die
+ dodoc AUTHORS ChangeLog README* THANKS TODO
+ doman debian/aget.1
+}
diff --git a/net-misc/aget/files/digest-aget-0.4 b/net-misc/aget/files/digest-aget-0.4
new file mode 100644
index 000000000000..73a3f7213407
--- /dev/null
+++ b/net-misc/aget/files/digest-aget-0.4
@@ -0,0 +1,2 @@
+MD5 1d32390f5ea2ddd82dfbb1794cdfa92f aget-0.4.tar.gz 11152
+MD5 351c102a10b2caaeefe5ff76ae5a0947 aget_0.4-4.diff.gz 2447