summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-22 18:12:31 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-22 18:12:31 +0000
commit405325bd568f8b32a9f2318e52419a0ef8b793d8 (patch)
treefe99dd16bdfd4e61d816b6e238fa131f66260673 /net-misc/apt-proxy
parentInstallation of apache1 and apache2 modules. Closes #40265. (Manifest recommit) (diff)
downloadgentoo-2-405325bd568f8b32a9f2318e52419a0ef8b793d8.tar.gz
gentoo-2-405325bd568f8b32a9f2318e52419a0ef8b793d8.tar.bz2
gentoo-2-405325bd568f8b32a9f2318e52419a0ef8b793d8.zip
Initial ebuild
Diffstat (limited to 'net-misc/apt-proxy')
-rw-r--r--net-misc/apt-proxy/ChangeLog10
-rw-r--r--net-misc/apt-proxy/Manifest4
-rw-r--r--net-misc/apt-proxy/apt-proxy-1.3.0.ebuild71
-rw-r--r--net-misc/apt-proxy/files/apt-proxy17
-rw-r--r--net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch11
-rw-r--r--net-misc/apt-proxy/files/digest-apt-proxy-1.3.01
6 files changed, 114 insertions, 0 deletions
diff --git a/net-misc/apt-proxy/ChangeLog b/net-misc/apt-proxy/ChangeLog
new file mode 100644
index 000000000000..a4a105db63e4
--- /dev/null
+++ b/net-misc/apt-proxy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/apt-proxy
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-proxy/ChangeLog,v 1.1 2004/04/22 18:12:31 mholzer Exp $
+
+*apt-proxy-1.3.0 (22 Apr 2004)
+
+ 22 Apr 2004; Martin Holzer <mholzer@gentoo.org> apt-proxy-1.3.0.ebuild,
+ files/apt-proxy, files/apt-proxy-1.3.0-sh.patch:
+ initial ebuild. submitted by Radek Podgorny <radek@podgorny.cz> in 20235
+
diff --git a/net-misc/apt-proxy/Manifest b/net-misc/apt-proxy/Manifest
new file mode 100644
index 000000000000..6152773bfcc4
--- /dev/null
+++ b/net-misc/apt-proxy/Manifest
@@ -0,0 +1,4 @@
+MD5 09cb71c7093fdea32105afd5644f8309 apt-proxy-1.3.0.ebuild 1964
+MD5 5c7dfb8096c89a0b3fb36df820d6cb55 files/apt-proxy 269
+MD5 6aca6a299de84e03dfb1aa12d43f2eb4 files/apt-proxy-1.3.0-sh.patch 423
+MD5 53f976abbe98f7765b80a2471282dcde files/digest-apt-proxy-1.3.0 66
diff --git a/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild b/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild
new file mode 100644
index 000000000000..93f4c7c9552c
--- /dev/null
+++ b/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-proxy/apt-proxy-1.3.0.ebuild,v 1.1 2004/04/22 18:12:31 mholzer Exp $
+
+
+DESCRIPTION="Caching proxy for the Debian package system"
+HOMEPAGE="http://sourceforge.net/projects/apt-proxy/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-apps/xinetd
+ net-misc/rsync
+ net-misc/wget"
+
+S=${WORKDIR}/${P}
+
+pkg_setup () {
+ enewgroup apt-proxy
+ enewuser apt-proxy -1 /bin/false /dev/null apt-proxy
+}
+
+src_compile() {
+ einfo "Applying patch..."
+ #patch -u apt-proxy < ${FILESDIR}/${P}-sh.patch
+ epatch ${FILESDIR}/${P}-sh.patch
+}
+
+src_install() {
+ dosbin apt-proxy
+
+ insinto /etc/apt-proxy ; doins apt-proxy.conf
+ insinto /etc/xinetd.d ; doins ${FILESDIR}/apt-proxy
+
+ dodoc README INSTALL HISTORY
+ doman apt-proxy.{8,conf.5}
+
+ # Create the log file with the proper permissions
+ dodir /var/log
+ touch ${D}/var/log/apt-proxy.log
+ fowners apt-proxy:apt-proxy /var/log/apt-proxy.log
+
+ # Create the cache directories and set the proper permissions
+ dodir /var/cache/apt-proxy
+ keepdir /var/cache/apt-proxy
+ fowners apt-proxy:apt-proxy /var/cache/apt-proxy
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Don't forget to modify the /etc/apt-proxy/apt-proxy.conf"
+ einfo "file to fit your needs..."
+ einfo ""
+ einfo "Also note that apt-proxy is called from running xinetd"
+ einfo "and you have to enable it first (/etc/xinetd.d/apt-proxy)..."
+ einfo ""
+}
+
+pkg_postrm() {
+ einfo ""
+ einfo "You have to remove the apt-proxy cache by hand. It's located"
+ einfo "in the \"/var/cache/apt-proxy\" dir..."
+ einfo ""
+ einfo "You can also remove the apt-proxy user and group..."
+ einfo ""
+}
diff --git a/net-misc/apt-proxy/files/apt-proxy b/net-misc/apt-proxy/files/apt-proxy
new file mode 100644
index 000000000000..e40e530b02f4
--- /dev/null
+++ b/net-misc/apt-proxy/files/apt-proxy
@@ -0,0 +1,17 @@
+# default: off
+# description: this is a proxy for debian packages.
+# $Header: /var/cvsroot/gentoo-x86/net-misc/apt-proxy/files/apt-proxy,v 1.1 2004/04/22 18:12:31 mholzer Exp $
+
+service apt-proxy
+{
+ type = UNLISTED
+ port = 9999
+ protocol = tcp
+ socket_type = stream
+ only_from = 0.0.0.0
+ wait = no
+ user = apt-proxy
+ server = /usr/sbin/apt-proxy
+ server_args = /var/log/apt-proxy.log
+ disable = yes
+}
diff --git a/net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch b/net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch
new file mode 100644
index 000000000000..be30ff4d68fe
--- /dev/null
+++ b/net-misc/apt-proxy/files/apt-proxy-1.3.0-sh.patch
@@ -0,0 +1,11 @@
+--- apt-proxy 2002-04-04 14:30:19.000000000 +0200
++++ apt-proxy.new 2003-03-13 00:49:48.000000000 +0100
+@@ -1,5 +1,7 @@
+-#!/bin/ash
++#!/bin/sh
+ # (You may safely change the above to /bin/sh if you do not have ash available)
++### I really modified it (was /bin/ash)
++### Radek Podgorny <radek@podgorny.cz> (for Gentoo)
+ #
+ # $Id: apt-proxy-1.3.0-sh.patch,v 1.1 2004/04/22 18:12:31 mholzer Exp $
+ # Copyright Paul Russell <rusty@samba.org>
diff --git a/net-misc/apt-proxy/files/digest-apt-proxy-1.3.0 b/net-misc/apt-proxy/files/digest-apt-proxy-1.3.0
new file mode 100644
index 000000000000..15d86b6c309d
--- /dev/null
+++ b/net-misc/apt-proxy/files/digest-apt-proxy-1.3.0
@@ -0,0 +1 @@
+MD5 72573d1df60d267e7fcf16db519f1c7e apt-proxy_1.3.0.tar.gz 37951