summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-09-01 10:19:29 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-09-01 10:19:29 +0000
commitacbf9d4fe9f74360a0de2e14857ec20cb8c026f3 (patch)
treea1bfb353e839abc6af59e6cfbf8bb9869ca41567 /net-misc/autossh/autossh-1.2g.ebuild
parentmade gawk use $(get_libdir) (Manifest recommit) (diff)
downloadgentoo-2-acbf9d4fe9f74360a0de2e14857ec20cb8c026f3.tar.gz
gentoo-2-acbf9d4fe9f74360a0de2e14857ec20cb8c026f3.tar.bz2
gentoo-2-acbf9d4fe9f74360a0de2e14857ec20cb8c026f3.zip
Closing #62329.
Diffstat (limited to 'net-misc/autossh/autossh-1.2g.ebuild')
-rw-r--r--net-misc/autossh/autossh-1.2g.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/autossh/autossh-1.2g.ebuild b/net-misc/autossh/autossh-1.2g.ebuild
new file mode 100644
index 000000000000..54729fe39668
--- /dev/null
+++ b/net-misc/autossh/autossh-1.2g.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/autossh/autossh-1.2g.ebuild,v 1.1 2004/09/01 10:19:29 aliz Exp $
+
+DESCRIPTION="Automatically restart SSH sessions and tunnels"
+HOMEPAGE="http://www.harding.motd.ca/autossh/"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc alpha ~ia64 ~amd64 ~ppc"
+SRC_URI="http://www.harding.motd.ca/autossh/${P}.tgz"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/libc sys-apps/sed"
+RDEPEND="virtual/libc net-misc/openssh"
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ sed -i "s|CFLAGS=|CFLAGS=${CFLAGS}|g" Makefile.linux
+}
+
+src_compile() {
+ emake -f Makefile.linux || die "make failed"
+}
+
+src_install() {
+ dobin autossh
+ dodoc CHANGES README autossh.host rscreen
+ doman autossh.1
+}