summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:38:30 +0000
commit67c8b060271109f68d8b0a44de61d297ddfbe2e7 (patch)
tree42ce8164da9dd6d55caa82dfe6832b4a2a0a6ad5 /net-misc/gtm/gtm-0.4.11-r2.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.gz
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.tar.bz2
gentoo-2-67c8b060271109f68d8b0a44de61d297ddfbe2e7.zip
Diffstat (limited to 'net-misc/gtm/gtm-0.4.11-r2.ebuild')
-rw-r--r--net-misc/gtm/gtm-0.4.11-r2.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/net-misc/gtm/gtm-0.4.11-r2.ebuild b/net-misc/gtm/gtm-0.4.11-r2.ebuild
index fd1d189ae877..badf47d997eb 100644
--- a/net-misc/gtm/gtm-0.4.11-r2.ebuild
+++ b/net-misc/gtm/gtm-0.4.11-r2.ebuild
@@ -1,19 +1,15 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gtm/gtm-0.4.11-r2.ebuild,v 1.15 2005/11/15 14:29:26 gustavoz Exp $
-
-inherit eutils
-
-IUSE="ssl nls gnome"
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gtm/gtm-0.4.11-r2.ebuild,v 1.1 2002/06/28 03:10:38 spider Exp $
+S=${WORKDIR}/${P}
DESCRIPTION="GTM - a transfer manager"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://gtm.sourceforge.net/"
SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86"
+LICENSE="GPL-"
-DEPEND="virtual/libc
+DEPEND="virtual/glibc
virtual/x11
x11-libs/gtk+
gnome-base/oaf
@@ -23,11 +19,11 @@ DEPEND="virtual/libc
gnome? ( gnome-base/gnome-applets )
ssl? ( dev-libs/openssl )"
-RDEPEND="virtual/libc
+RDEPEND="virtual/glibc
virtual/x11
net-misc/wget
>=gnome-base/gnome-libs-1.4.0.2
- =gnome-base/orbit-0*"
+ >=gnome-base/ORBit-0.5.11"
src_unpack() {
@@ -42,11 +38,11 @@ src_unpack() {
>${S}/doc/${lang}/Makefile.in
done
- epatch ${FILESDIR}/wget-log.c.patch || die "epatch failed."
+ patch -p0 < ${FILESDIR}/wget-log.c.patch
}
src_compile() {
-
+
local myconf
use nls || myconf="--disable-nls"
use gnome || myconf="${myconf} --disable-applet"
@@ -62,11 +58,12 @@ src_compile() {
--sysconfdir=/etc \
--without-debug \
$myconf || die
-
+
emake || die
}
src_install() {
-
+
make DESTDIR=${D} install || die
}
+