summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-08-11 03:10:09 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-08-11 03:10:09 +0000
commit95dc30bb5ac377db9fb2cc379d8203a410e94259 (patch)
tree74a747b31799215f0e7175adb88a8645559b7251 /net-misc/iperf/iperf-2.0.2.ebuild
parentAdd support for cross-compiling. Grabbed patches from uClibc/OpenEmbedded. (diff)
downloadgentoo-2-95dc30bb5ac377db9fb2cc379d8203a410e94259.tar.gz
gentoo-2-95dc30bb5ac377db9fb2cc379d8203a410e94259.tar.bz2
gentoo-2-95dc30bb5ac377db9fb2cc379d8203a410e94259.zip
Version bump for bug 101960.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/iperf/iperf-2.0.2.ebuild')
-rw-r--r--net-misc/iperf/iperf-2.0.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/iperf/iperf-2.0.2.ebuild b/net-misc/iperf/iperf-2.0.2.ebuild
new file mode 100644
index 000000000000..63a38f7e7fa0
--- /dev/null
+++ b/net-misc/iperf/iperf-2.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/iperf-2.0.2.ebuild,v 1.1 2005/08/11 03:10:09 ka0ttic Exp $
+
+DESCRIPTION="tool to measure IP bandwidth using UDP or TCP"
+HOMEPAGE="http://dast.nlanr.net/Projects/Iperf"
+SRC_URI="http://dast.nlanr.net/Projects/Iperf2.0/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ipv6 threads debug"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable threads) \
+ $(use_enable debug debuginfo) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc INSTALL README
+ dohtml doc/*
+ newinitd ${FILESDIR}/${PN}.initd ${PN}
+ newconfd ${FILESDIR}/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ echo
+ einfo "To run iperf in server mode, run:"
+ einfo " /etc/init.d/iperf start"
+ echo
+}