summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2001-07-31 02:23:51 +0000
committerChad Huneycutt <chadh@gentoo.org>2001-07-31 02:23:51 +0000
commit892ef4107678fbfc1646b8950d4239698b9a472a (patch)
tree2e60694938a8c9a74628136ec9a710866fb2d79b /net-misc/lrzsz
parentAdded this to rc.d/init.d/mountall (diff)
downloadgentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.tar.gz
gentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.tar.bz2
gentoo-2-892ef4107678fbfc1646b8950d4239698b9a472a.zip
Finally getting around to committing some ebuilds I have been working on.
My first 2 ebuilds: freeciv and lrzsz gzip and gdbm just have small fixes to fix the info dir entry problem.
Diffstat (limited to 'net-misc/lrzsz')
-rw-r--r--net-misc/lrzsz/files/digest-lrzsz-0.12.201
-rw-r--r--net-misc/lrzsz/lrzsz-0.12.20.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/lrzsz/files/digest-lrzsz-0.12.20 b/net-misc/lrzsz/files/digest-lrzsz-0.12.20
new file mode 100644
index 000000000000..6ef729bf106b
--- /dev/null
+++ b/net-misc/lrzsz/files/digest-lrzsz-0.12.20
@@ -0,0 +1 @@
+MD5 b5ce6a74abc9b9eb2af94dffdfd372a4 lrzsz-0.12.20.tar.gz
diff --git a/net-misc/lrzsz/lrzsz-0.12.20.ebuild b/net-misc/lrzsz/lrzsz-0.12.20.ebuild
new file mode 100644
index 000000000000..a28c312df279
--- /dev/null
+++ b/net-misc/lrzsz/lrzsz-0.12.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Chad Huneycutt <chad.huneycutt@acm.org>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.5 2001/07/24 22:30:35 lordjoe Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="communication package providing the X, Y, and ZMODEM file transfer protocols"
+SRC_URI="http://www.ohse.de/uwe/releases/lrzsz-0.12.20.tar.gz"
+HOMEPAGE="http://www.ohse.de/uwe/software/lrzsz.html"
+
+DEPEND=""
+
+#RDEPEND=""
+
+src_compile() {
+ local options
+ if [ -z "`use nls`" ]; then
+ options=${options} --disable-nls
+ fi
+ CFLAGS="${CFLAGS} -Wstrict-prototypes" try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} ${options}
+
+ CFLAGS=${CFLAGS} -Wstrict-prototypes try emake
+}
+
+src_install () {
+ try make prefix=${D}/usr install
+
+ dosym /usr/bin/lrb /usr/bin/rb
+ dosym /usr/bin/lrx /usr/bin/rx
+ dosym /usr/bin/lrz /usr/bin/rz
+ dosym /usr/bin/lsb /usr/bin/sb
+ dosym /usr/bin/lsx /usr/bin/sx
+ dosym /usr/bin/lsz /usr/bin/sz
+
+ dodoc ABOUT-NLS AUTHORS COMPATABILITY COPYING ChangeLog NEWS README README.cvs README.gettext README.isdn4linux README.tests THANKS TODO
+}
+