summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-08 18:55:25 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-08 18:55:25 +0000
commit90145f3fa715081b1ba353ba713e2b9496117441 (patch)
tree607ceff603a141323799d176eec1cd75f9a987a8 /net-misc/mdidentd
parentStable for HPPA (bug #276776). (diff)
downloadgentoo-2-90145f3fa715081b1ba353ba713e2b9496117441.tar.gz
gentoo-2-90145f3fa715081b1ba353ba713e2b9496117441.tar.bz2
gentoo-2-90145f3fa715081b1ba353ba713e2b9496117441.zip
Adding patch to build against glibc 2.10 , bug #275954
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-misc/mdidentd')
-rw-r--r--net-misc/mdidentd/ChangeLog8
-rw-r--r--net-misc/mdidentd/files/1.04a-glibc210.patch32
-rw-r--r--net-misc/mdidentd/mdidentd-1.04c.ebuild8
3 files changed, 43 insertions, 5 deletions
diff --git a/net-misc/mdidentd/ChangeLog b/net-misc/mdidentd/ChangeLog
index 4555b8287588..ea4adaa95f7f 100644
--- a/net-misc/mdidentd/ChangeLog
+++ b/net-misc/mdidentd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/mdidentd
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mdidentd/ChangeLog,v 1.7 2007/04/10 13:40:40 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mdidentd/ChangeLog,v 1.8 2009/08/08 18:55:25 vostorga Exp $
+
+ 08 Aug 2009; Víctor Ostorga <vostorga@gentoo.org>
+ +files/1.04a-glibc210.patch, mdidentd-1.04c.ebuild:
+ Adding patch to build against glibc 2.10 , bug #275954
*mdidentd-1.04c (10 Apr 2007)
diff --git a/net-misc/mdidentd/files/1.04a-glibc210.patch b/net-misc/mdidentd/files/1.04a-glibc210.patch
new file mode 100644
index 000000000000..9f059cef3309
--- /dev/null
+++ b/net-misc/mdidentd/files/1.04a-glibc210.patch
@@ -0,0 +1,32 @@
+diff -NrU5 ezbounce-1.04c.original/lib/general.cpp ezbounce-1.04c/lib/general.cpp
+--- ezbounce-1.04c.original/lib/general.cpp 2009-08-08 18:50:44.000000000 -0600
++++ ezbounce-1.04c/lib/general.cpp 2009-08-08 18:55:30.000000000 -0600
+@@ -366,11 +366,11 @@
+ while (*p == sep)
+ p++;
+ do {
+ if (numfound == which && *p)
+ {
+- char * next = strchr(p, sep);
++ const char * next = strchr(p, sep);
+ if ((get_rest && buffer) || (!next /* && *(p+1) */) )
+ {
+ if (buffer)
+ safe_strcpy(buffer, p, maxsize);
+ return 1;
+diff -NrU5 ezbounce-1.04c.original/mdidentd/identd.cpp ezbounce-1.04c/mdidentd/identd.cpp
+--- ezbounce-1.04c.original/mdidentd/identd.cpp 2009-08-08 18:50:44.000000000 -0600
++++ ezbounce-1.04c/mdidentd/identd.cpp 2009-08-08 19:00:08.000000000 -0600
+@@ -739,11 +739,11 @@
+ while (*p == sep)
+ p++;
+ do {
+ if (numfound == which && *p)
+ {
+- char * next = strchr(p, sep);
++ const char * next = strchr(p, sep);
+ if ((get_rest && buffer) || (!next /* && *(p+1) */) )
+ {
+ if (buffer)
+ safe_strcpy(buffer, p, maxsize);
+ return 1;
diff --git a/net-misc/mdidentd/mdidentd-1.04c.ebuild b/net-misc/mdidentd/mdidentd-1.04c.ebuild
index 6700d05adbba..157a765878e4 100644
--- a/net-misc/mdidentd/mdidentd-1.04c.ebuild
+++ b/net-misc/mdidentd/mdidentd-1.04c.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/mdidentd/mdidentd-1.04c.ebuild,v 1.1 2007/04/10 13:40:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/mdidentd/mdidentd-1.04c.ebuild,v 1.2 2009/08/08 18:55:25 vostorga Exp $
inherit eutils
@@ -14,6 +14,7 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="ssl"
DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/ezbounce-${PV}
@@ -27,11 +28,12 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/1.04a-security.patch
epatch "${FILESDIR}"/1.04a-pidfile.patch
+ epatch "${FILESDIR}"/1.04a-glibc210.patch
}
src_compile() {
econf $(use_with ssl) || die
- emake -C mdidentd CXX_OPTIMIZATIONS="${CXXFLAGS}" || die
+ emake CXX="$(tc-getCXX)" -C mdidentd CXX_OPTIMIZATIONS="${CXXFLAGS}" || die
}
src_install() {