summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-04-28 13:41:31 +0000
committerJon Nelson <jnelson@gentoo.org>2002-04-28 13:41:31 +0000
commit796665f89d927cad88ee69ebd244c10b70b3dc60 (patch)
treef3e68c5dad084cfcb1578fb00b048e775b2e5b1c /net-misc/ntp
parentdescription fix (diff)
downloadgentoo-2-796665f89d927cad88ee69ebd244c10b70b3dc60.tar.gz
gentoo-2-796665f89d927cad88ee69ebd244c10b70b3dc60.tar.bz2
gentoo-2-796665f89d927cad88ee69ebd244c10b70b3dc60.zip
update to -r2 which fixes 1882 and makes ntp compile
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/ChangeLog12
-rw-r--r--net-misc/ntp/files/digest-ntp-4.1.72-r21
-rw-r--r--net-misc/ntp/ntp-4.1.72-r2.ebuild42
3 files changed, 54 insertions, 1 deletions
diff --git a/net-misc/ntp/ChangeLog b/net-misc/ntp/ChangeLog
index 7e70d7e1d983..302ab2b04090 100644
--- a/net-misc/ntp/ChangeLog
+++ b/net-misc/ntp/ChangeLog
@@ -1,7 +1,17 @@
# ChangeLog for net-misc/ntp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.2 2002/03/24 14:25:31 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.3 2002/04/28 13:41:31 jnelson Exp $
+*ntp-4.1.72-r2 (28 Apr 2002)
+ 28 Apr 2002; Jon Nelson <jnelson@gentoo.org> ntp-4.1.72-r2.ebuild :
+
+ Remove -lncurses from LDFLAGS environment, it screws up
+ the build.
+ If there is a good reason for it to be there, prefix it with
+ -L/lib so that configure can find it there (it's not in /usr/lib).
+ Closes bug #1882 and allows compilation
+ Update ebuild for lintool compliance
+
*ntp-4.1.72-r1 (24 March 2002)
24 March 2002; M.Schlemmer <azarah@gentoo.org> :
diff --git a/net-misc/ntp/files/digest-ntp-4.1.72-r2 b/net-misc/ntp/files/digest-ntp-4.1.72-r2
new file mode 100644
index 000000000000..af9d351edea8
--- /dev/null
+++ b/net-misc/ntp/files/digest-ntp-4.1.72-r2
@@ -0,0 +1 @@
+MD5 de9ed6a28f4c4ffea932a49db5b745fa ntp-4.1.72.tar.gz 2523934
diff --git a/net-misc/ntp/ntp-4.1.72-r2.ebuild b/net-misc/ntp/ntp-4.1.72-r2.ebuild
new file mode 100644
index 000000000000..a2bb33923e16
--- /dev/null
+++ b/net-misc/ntp/ntp-4.1.72-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Terry Chan <tchan@enteract.com>
+# Maintainer: Jon Nelson <jnelson@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.72-r2.ebuild,v 1.1 2002/04/28 13:41:31 jnelson Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Time Protocol suite/programs"
+SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${P}.tar.gz"
+HOMEPAGE="http://www.ntp.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cp configure configure.orig
+ sed -e "s:-Wpointer-arith::" configure.orig > configure
+# If there is a reason why we need -lncurses in LDFLAGS, please
+# read the ChangeLog and contact me, jnelson@gentoo.org
+# LDFLAGS="$LDFLAGS -L/lib -lncurses"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --host=${CHOST} --build=${CHOST} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+
+ dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
+ insinto /usr/share/doc/${PF}/html ; doins html/*.htm
+ insinto /usr/share/doc/${PF}/html/hints ; doins html/hints/*
+ insinto /usr/share/doc/${PF}/html/pic ; doins html/pic/*
+
+ insinto /usr/share/ntp ; doins scripts/*
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ntpd.rc6 ntpd
+ insinto /etc/conf.d ; newins ${FILESDIR}/ntpd.confd ntpd
+}