summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-07-09 14:36:49 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-07-09 14:36:49 +0000
commite2bc05acf11bf9f87b83eb5b7b8328087756d5f7 (patch)
tree4584f94397b33fafcea9489ebb302fc9aafb9f60 /net-misc/openssh
parentmask openssh ebuild I'm about to commit (diff)
downloadgentoo-2-e2bc05acf11bf9f87b83eb5b7b8328087756d5f7.tar.gz
gentoo-2-e2bc05acf11bf9f87b83eb5b7b8328087756d5f7.tar.bz2
gentoo-2-e2bc05acf11bf9f87b83eb5b7b8328087756d5f7.zip
md5 support please test!
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/ChangeLog9
-rw-r--r--net-misc/openssh/files/digest-openssh-3.4_p1-r31
-rw-r--r--net-misc/openssh/openssh-3.4_p1-r3.ebuild94
3 files changed, 103 insertions, 1 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index c12b21395168..df5998e10bae 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openssh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.14 2002/07/09 10:25:07 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.15 2002/07/09 14:36:49 lostlogic Exp $
+
+*openssh-3.4_p1-r3 (04 July 2002)
+
+ 09 Jul 2002; Brandon Low <lostlogic@gentoo.org> openssh-3.4_p1-r3.ebuild :
+
+ New revision enables md5 passwords, please test and let me know how it
+ goes so I can unmask. Thanks.
*openssh-3.4_p1-r2 (04 July 2002)
diff --git a/net-misc/openssh/files/digest-openssh-3.4_p1-r3 b/net-misc/openssh/files/digest-openssh-3.4_p1-r3
new file mode 100644
index 000000000000..fae8682e3e76
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-3.4_p1-r3
@@ -0,0 +1 @@
+MD5 459c1d0262e939d6432f193c7a4ba8a8 openssh-3.4p1.tar.gz 837668
diff --git a/net-misc/openssh/openssh-3.4_p1-r3.ebuild b/net-misc/openssh/openssh-3.4_p1-r3.ebuild
new file mode 100644
index 000000000000..87b59d65f04d
--- /dev/null
+++ b/net-misc/openssh/openssh-3.4_p1-r3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.4_p1-r3.ebuild,v 1.1 2002/07/09 14:36:49 lostlogic Exp $
+
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="http://www.openssh.com/"
+
+# openssh recognizes when openssl has been slightly upgraded and refuses to run.
+# This new rev will use the new openssl.
+RDEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.73 >=sys-apps/shadow-4.0.2-r2 )
+ >=dev-libs/openssl-0.9.6d
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ sys-devel/perl
+ sys-apps/groff
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+
+SRC_URI="ftp://ftp.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/${PARCH}.tar.gz"
+S=${WORKDIR}/${PARCH}
+
+LICENSE="as-is"
+SLOT="0"
+
+src_compile() {
+ local myconf
+ use tcpd || myconf="${myconf} --without-tcp-wrappers"
+ use tcpd && myconf="${myconf} --with-tcp-wrappers"
+ use pam || myconf="${myconf} --without-pam"
+ use pam && myconf="${myconf} --with-pam"
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/ssh \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5 \
+ --host=${CHOST} ${myconf} || die "bad configure"
+
+ if [ "`use static`" ]
+ then
+ # statically link to libcrypto -- good for the boot cd
+ perl -pi -e "s|-lcrypto|/usr/lib/libcrypto.a|g" Makefile
+ fi
+
+ make || die " compile problem"
+}
+
+src_install() {
+ make install-files DESTDIR=${D} || die
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+ insinto /etc/pam.d ; newins ${FILESDIR}/sshd.pam sshd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/sshd.rc6 sshd
+ touch ${D}/var/empty/.keep
+}
+
+pkg_preinst() {
+
+ userdel sshd 2> /dev/null
+ if ! groupmod sshd; then
+ groupadd -g 90 sshd 2> /dev/null || \
+ die "Failed to create sshd group"
+ fi
+ useradd -u 22 -g sshd -s /dev/null -d /var/empty -c "sshd" sshd || \
+ die "Failed to create sshd user"
+
+}
+
+pkg_postinst() {
+
+ # empty dir for the new priv separation auth chroot..
+ install -d -m0755 -o root -g root ${ROOT}/var/empty
+
+ einfo
+ einfo "Remember to merge your config files in /etc/ssh!"
+ einfo "As of version 3.4 the default is to enable the UsePrivelegeSeparation"
+ einfo "functionality, but please ensure that you do not explicitly disable"
+ einfo "this in your configuration as disabling it opens security holes"
+ einfo
+ einfo "This revision has removed your sshd user id and replaced it with a"
+ einfo "new one with UID 22. If you have any scripts or programs that"
+ einfo "that referenced the old UID directly, you will need to update them."
+ einfo
+}