summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-05-14 08:23:50 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-05-14 08:23:50 +0000
commitf78f0c6060cb0be42e115853687d0ea25ffba9dc (patch)
tree6afd13af66536cb7edbae513449a61f73c5ebc56 /net-misc/openvpn
parentRemove buggy version (bug #415431). (diff)
downloadgentoo-2-f78f0c6060cb0be42e115853687d0ea25ffba9dc.tar.gz
gentoo-2-f78f0c6060cb0be42e115853687d0ea25ffba9dc.tar.bz2
gentoo-2-f78f0c6060cb0be42e115853687d0ea25ffba9dc.zip
Update openvpn live ebuild for new build system.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/openvpn')
-rw-r--r--net-misc/openvpn/ChangeLog6
-rw-r--r--net-misc/openvpn/openvpn-9999.ebuild67
2 files changed, 24 insertions, 49 deletions
diff --git a/net-misc/openvpn/ChangeLog b/net-misc/openvpn/ChangeLog
index 2290ba01fd06..220ee628559e 100644
--- a/net-misc/openvpn/ChangeLog
+++ b/net-misc/openvpn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openvpn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.226 2012/04/14 05:48:20 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.227 2012/05/14 08:23:50 djc Exp $
+
+ 14 May 2012; Dirkjan Ochtman <djc@gentoo.org> openvpn-9999.ebuild:
+ Update live ebuild to deal with new build system (thanks Alon Bar-Lev, bug
+ 409577).
14 Apr 2012; Zac Medico <zmedico@gentoo.org> openvpn-2.2.2.ebuild:
Add ~amd64-linux keyword.
diff --git a/net-misc/openvpn/openvpn-9999.ebuild b/net-misc/openvpn/openvpn-9999.ebuild
index cf67848acc3e..97b52deea387 100644
--- a/net-misc/openvpn/openvpn-9999.ebuild
+++ b/net-misc/openvpn/openvpn-9999.ebuild
@@ -1,52 +1,38 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-9999.ebuild,v 1.2 2012/03/01 12:10:51 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-9999.ebuild,v 1.3 2012/05/14 08:23:50 djc Exp $
EAPI=4
inherit eutils multilib toolchain-funcs autotools flag-o-matic git-2
DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compatible with many OSes."
-EGIT_REPO_URI="git://${PN}.git.sourceforge.net/gitroot/${PN}/${PN}.git"
+EGIT_REPO_URI="https://github.com/OpenVPN/${PN}.git"
HOMEPAGE="http://openvpn.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="examples iproute2 minimal pam passwordsave selinux +ssl static pkcs11 userland_BSD"
+IUSE="examples iproute2 minimal pam passwordsave selinux +ssl +lzo static pkcs11 userland_BSD"
-DEPEND=">=dev-libs/lzo-1.07
+REQUIRED_USE="static? ( minimal )"
+
+DEPEND="
kernel_linux? (
iproute2? ( sys-apps/iproute2[-minimal] ) !iproute2? ( sys-apps/net-tools )
)
!minimal? ( pam? ( virtual/pam ) )
selinux? ( sec-policy/selinux-openvpn )
- ssl? ( >=dev-libs/openssl-0.9.6 )
+ ssl? ( >=dev-libs/openssl-0.9.7 )
+ lzo? ( >=dev-libs/lzo-1.07 )
pkcs11? ( >=dev-libs/pkcs11-helper-1.05 )"
RDEPEND="${DEPEND}"
src_prepare() {
- epatch "${FILESDIR}/${P}-pkcs11.patch"
- sed -i \
- -e "s/gcc \${CC_FLAGS}/\${CC} \${CFLAGS} -Wall/" \
- -e "s/-shared/-shared \${LDFLAGS}/" \
- plugin/*/Makefile || die "sed failed"
-
- # Add GIT commit ID to Product Version
- sed -i \
- -e "/^define(PRODUCT_VERSION/s/])/-git-${EGIT_VERSION}])/" \
- version.m4
eautoreconf
}
src_configure() {
- # basic.h defines a type 'bool' that conflicts with the altivec
- # keyword bool which has to be fixed upstream, see bugs #293840
- # and #297854.
- # For now, filter out -maltivec on ppc and append -mno-altivec, as
- # -maltivec is enabled implicitly by -mcpu and similar flags.
- (use ppc || use ppc64) && filter-flags -maltivec && append-flags -mno-altivec
-
local myconf=""
if use minimal ; then
@@ -56,29 +42,26 @@ src_configure() {
myconf="$(use_enable pkcs11)"
fi
+ use static && LDFLAGS="${LDFLAGS} -Xcompiler -static"
econf ${myconf} \
$(use_enable passwordsave password-save) \
$(use_enable ssl) \
$(use_enable ssl crypto) \
+ $(use_enable lzo) \
$(use_enable iproute2) \
--docdir="${EPREFIX}/usr/share/doc/${PF}"
}
src_compile() {
-
- if use static ; then
- sed -i -e '/^LIBS/s/LIBS = /LIBS = -static /' Makefile || die "sed failed"
- fi
-
emake
if ! use minimal ; then
- cd plugin
+ cd src/plugins
for i in *; do
[[ ${i} == "README" || ${i} == "examples" || ${i} == "defer" ]] && continue
[[ ${i} == "auth-pam" ]] && ! use pam && continue
einfo "Building ${i} plugin"
- emake -C "${i}" CC=$(tc-getCC)
+ emake -C "${i}" CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
done
cd ..
fi
@@ -87,12 +70,8 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install
- # install openvpn-plugin.h
- insinto /usr/include
- doins openvpn-plugin.h
-
# install documentation
- dodoc AUTHORS ChangeLog PORTS README README.IPv6 TODO.IPv6
+ dodoc AUTHORS ChangeLog PORTS README README.IPv6
# Install some helper scripts
keepdir /etc/openvpn
@@ -108,18 +87,12 @@ src_install() {
if use examples ; then
# dodoc does not supportly support directory traversal, #15193
insinto /usr/share/doc/${PF}/examples
- doins -r sample-{config-files,keys,scripts} contrib
+ doins -r sample contrib
fi
- # Install plugins and easy-rsa
- doenvd "${FILESDIR}/65openvpn" # config-protect easy-rsa
if ! use minimal ; then
- cd easy-rsa/2.0
- make install "DESTDIR=${D}" "PREFIX=${EPREFIX}/usr/share/${PN}/easy-rsa"
- cd ../..
-
exeinto "/usr/$(get_libdir)/${PN}"
- doexe plugin/*/*.so
+ doexe src/plugins/*/*.so
fi
}
@@ -162,10 +135,8 @@ pkg_postinst() {
einfo "plugins have been installed into /usr/$(get_libdir)/${PN}"
fi
- if [[ ${PV} == "9999" ]]; then
- ewarn ""
- ewarn "You are using a live ebuild building from the sources of openvpn"
- ewarn "repository from http://openvpn.git.sourceforge.net. For reporting"
- ewarn "bugs please contact: openvpn-devel@lists.sourceforge.net"
- fi
+ ewarn ""
+ ewarn "You are using a live ebuild building from the sources of openvpn"
+ ewarn "repository from http://openvpn.git.sourceforge.net. For reporting"
+ ewarn "bugs please contact: openvpn-devel@lists.sourceforge.net."
}