summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-09-02 12:11:32 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-09-02 12:11:32 +0000
commitac5ddfd3d0aa275c77fe69da20186c6e6cb379e3 (patch)
treef42d3461ea64ce36288938adc5259f6d7cff79f9 /net-misc/putty
parentupdates from cvs (diff)
downloadgentoo-2-ac5ddfd3d0aa275c77fe69da20186c6e6cb379e3.tar.gz
gentoo-2-ac5ddfd3d0aa275c77fe69da20186c6e6cb379e3.tar.bz2
gentoo-2-ac5ddfd3d0aa275c77fe69da20186c6e6cb379e3.zip
updates from cvs
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/Manifest4
-rw-r--r--net-misc/putty/files/digest-putty-200309021
-rw-r--r--net-misc/putty/putty-20030902.ebuild62
4 files changed, 71 insertions, 3 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 2161aa622238..3f2508fea3ea 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.3 2003/06/22 12:35:13 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.4 2003/09/02 12:11:28 taviso Exp $
+
+*putty-20030902 (02 Sep 2003)
+
+ 02 Sep 2003; Tavis Ormandy <taviso@gentoo.org> putty-20030902.ebuild:
+ updates from cvs.
22 Jun 2003; Tavis Ormandy <taviso@gentoo.org> putty-20030603.ebuild:
adding a warning about unix98 pty's and pterm
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 8bcdc5ea39f4..e418831edd3e 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,5 +1,5 @@
-MD5 5c2d350c5e51c4790cd110e59902c2d5 putty-20030902.ebuild 1359
-MD5 03e5b02de5daa92423cb6756bc39ab50 ChangeLog 672
+MD5 d6f12b4524798c04895f8a0be357fe99 putty-20030902.ebuild 1372
+MD5 e81d46d7332086c2401679b083cd383f ChangeLog 796
MD5 7c8f03eb56fc5a6e0230a53623eb98cb putty-20030603.ebuild 1421
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
MD5 bcc49e4648a2fa3b47fb42141928e0e0 files/digest-putty-20030603 70
diff --git a/net-misc/putty/files/digest-putty-20030902 b/net-misc/putty/files/digest-putty-20030902
new file mode 100644
index 000000000000..002c2e7ce459
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-20030902
@@ -0,0 +1 @@
+MD5 b5153e87291b69ae477fe75491e1dc30 putty-cvs-20030902.tar.gz 835580
diff --git a/net-misc/putty/putty-20030902.ebuild b/net-misc/putty/putty-20030902.ebuild
new file mode 100644
index 000000000000..e176b0989196
--- /dev/null
+++ b/net-misc/putty/putty-20030902.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-20030902.ebuild,v 1.1 2003/09/02 12:11:28 taviso Exp $
+
+DESCRIPTION="UNIX port of the famous Windows Telnet and SSH client"
+
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="mirror://gentoo/putty-cvs-${PV}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="doc"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ virtual/x11"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.0
+ >=sys-apps/sed-4
+ =x11-libs/gtk+-1.2*
+ virtual/x11"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # generate the makefiles
+ einfo "Generating Makefiles..."
+ ${S}/mkfiles.pl || die "failed to create makefiles."
+
+ # change the CFLAGS to those requested by user.
+ einfo "Setting CFLAGS..."
+ sed -i "s/-O2/${CFLAGS}/g" ${S}/unix/Makefile.gtk
+
+ # build putty.
+ einfo "Building putty..."
+ cd ${S}/unix; emake -f Makefile.gtk
+}
+
+src_install() {
+
+ cd ${S}/unix
+
+ # man pages...
+ doman plink.1 pterm.1 putty.1 puttytel.1
+
+ # binaries...
+ dobin plink pterm putty puttytel
+
+ cd ${S}
+
+ # docs...
+ dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER website.url MODULE
+ use doc && dodoc doc/*
+
+ prepallman
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires UNIX98 PTY support to operate."
+ ewarn
+ fi
+}