summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-29 07:02:31 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-29 07:02:31 +0000
commit12ca9ec1ff91163fc7e9fdcd163446d5b6831015 (patch)
tree381b4b68fd64622ae3887a30982bdc767da1e137 /net-misc/streamtuner/streamtuner-0.99.99-r2.ebuild
parentallegromp3 gone. (diff)
downloadgentoo-2-12ca9ec1ff91163fc7e9fdcd163446d5b6831015.tar.gz
gentoo-2-12ca9ec1ff91163fc7e9fdcd163446d5b6831015.tar.bz2
gentoo-2-12ca9ec1ff91163fc7e9fdcd163446d5b6831015.zip
Merge patches and changes by Pacho Ramos from bug 184869, thanks.
(Portage version: 2.1.3)
Diffstat (limited to 'net-misc/streamtuner/streamtuner-0.99.99-r2.ebuild')
-rw-r--r--net-misc/streamtuner/streamtuner-0.99.99-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/streamtuner/streamtuner-0.99.99-r2.ebuild b/net-misc/streamtuner/streamtuner-0.99.99-r2.ebuild
new file mode 100644
index 000000000000..7bfe96ada7f0
--- /dev/null
+++ b/net-misc/streamtuner/streamtuner-0.99.99-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/streamtuner/streamtuner-0.99.99-r2.ebuild,v 1.1 2007/07/29 07:02:31 drac Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils
+
+DESCRIPTION="Stream directory browser for browsing internet radio streams"
+HOMEPAGE="http://www.nongnu.org/streamtuner"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz
+ http://savannah.nongnu.org/download/${PN}/${P}-pygtk-2.6.diff"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="python"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ net-misc/curl
+ app-text/scrollkeeper
+ dev-libs/libxml2
+ >=media-libs/taglib-1.2
+ python? ( dev-python/pygtk )
+ x11-misc/xdg-utils"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS NEWS README TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${DISTDIR}"/${P}-pygtk-2.6.diff
+}
+
+src_compile() {
+ # live365 causes parse errors at connect time.
+ econf --disable-live365 $(use_enable python)
+ emake || die "emake failed."
+}