summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-25 10:25:27 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-25 10:25:27 +0000
commitf8f2a5b0fd78b12a54cd1b9b329a0f724cb1ae2c (patch)
tree51da42970256ce4db5c2a8f0ea2c121c92c20def /net-misc/stunnel/stunnel-3.22-r2.ebuild
parentgtk is optional (diff)
downloadgentoo-2-f8f2a5b0fd78b12a54cd1b9b329a0f724cb1ae2c.tar.gz
gentoo-2-f8f2a5b0fd78b12a54cd1b9b329a0f724cb1ae2c.tar.bz2
gentoo-2-f8f2a5b0fd78b12a54cd1b9b329a0f724cb1ae2c.zip
Security update
Diffstat (limited to 'net-misc/stunnel/stunnel-3.22-r2.ebuild')
-rw-r--r--net-misc/stunnel/stunnel-3.22-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/stunnel/stunnel-3.22-r2.ebuild b/net-misc/stunnel/stunnel-3.22-r2.ebuild
new file mode 100644
index 000000000000..162aa4fba00e
--- /dev/null
+++ b/net-misc/stunnel/stunnel-3.22-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-3.22-r2.ebuild,v 1.1 2003/03/25 10:25:27 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TSL/SSL - Port Wrapper"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+HOMEPAGE="http://www.stunnel.org/"
+DEPEND="virtual/glibc >=dev-libs/openssl-0.9.6c"
+RDEPEND=">=dev-libs/openssl-0.9.6c"
+KEYWORDS="x86 sparc "
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-blinding.patch
+}
+
+src_compile() {
+ ./configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dosbin stunnel
+ dodoc FAQ README HISTORY COPYING BUGS PORTS TODO transproxy.txt
+ doman stunnel.8
+ dolib.so stunnel.so
+}