summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-11-24 18:40:50 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-11-24 18:40:50 +0000
commitc5b23d212b7369f586e47a99bbc366b2d798e4af (patch)
treefa93c99bbaa96656c907a832f8e59d85c6a0adaa /net-misc/wget
parentremoved the ultra-slow gatekeeper.dec.com GNU mirror. (diff)
downloadgentoo-2-c5b23d212b7369f586e47a99bbc366b2d798e4af.tar.gz
gentoo-2-c5b23d212b7369f586e47a99bbc366b2d798e4af.tar.bz2
gentoo-2-c5b23d212b7369f586e47a99bbc366b2d798e4af.zip
removed the ultra-slow gatekeeper.dec.com mirror. This encourages me to
rewrite the portage download code to add mirroring support
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/wget-1.7-r1.ebuild57
-rw-r--r--net-misc/wget/wget-1.7-r2.ebuild5
-rw-r--r--net-misc/wget/wget-1.7.ebuild58
3 files changed, 2 insertions, 118 deletions
diff --git a/net-misc/wget/wget-1.7-r1.ebuild b/net-misc/wget/wget-1.7-r1.ebuild
deleted file mode 100644
index 9f57f2f0bb7f..000000000000
--- a/net-misc/wget/wget-1.7-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r1.ebuild,v 1.5 2001/08/19 05:43:20 drobbins Exp $
-
-A="${P}.tar.gz wget-new-percentage-1.7-20010606.diff"
-S=${WORKDIR}/${P}
-DESCRIPTION="Network utility to retrieve files from the WWW"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
- ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
- http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-1.7-20010606.diff"
-HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
-
-DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
-
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}/src
- patch -p0 < ${DISTDIR}/wget-new-percentage-1.7-20010606.diff
-}
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-# if [ "`use ssl`" ] ; then
-# myconf="$myconf --with-ssl=/usr"
-# fi
- if [ -z "$DEBUG" ] ; then
- myconf="$myconf --disable-debug"
- fi
- try ./configure --prefix=/usr --sysconfdir=/etc/wget \
- --infodir=/usr/share/info --mandir=usr/share/man $myconf
- if [ "`use static`" ] ; then
- try make -e LDFLAGS="--static"
- else
- try make
- fi
-}
-
-src_install() {
- if [ "`use build`" ] || [ "`use bootcd`" ] ; then
- insinto /usr
- dobin ${S}/src/wget
- return
- fi
-
- try make prefix=${D}/usr sysconfdir=${D}/etc/wget \
- mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
-}
-
-
diff --git a/net-misc/wget/wget-1.7-r2.ebuild b/net-misc/wget/wget-1.7-r2.ebuild
index a446440bdf81..425779f428ec 100644
--- a/net-misc/wget/wget-1.7-r2.ebuild
+++ b/net-misc/wget/wget-1.7-r2.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r2.ebuild,v 1.1 2001/10/12 00:35:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7-r2.ebuild,v 1.2 2001/11/24 18:40:50 drobbins Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Network utility to retrieve files from the WWW"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
- ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
+SRC_URI="ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-1.7-20010606.diff"
HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
diff --git a/net-misc/wget/wget-1.7.ebuild b/net-misc/wget/wget-1.7.ebuild
deleted file mode 100644
index 5d49a410bf00..000000000000
--- a/net-misc/wget/wget-1.7.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.7.ebuild,v 1.4 2001/08/11 04:53:17 drobbins Exp $
-
-A="${P}.tar.gz wget-new-percentage-1.7-20010606.diff"
-S=${WORKDIR}/${P}
-DESCRIPTION="Network utility to retrieve files from the WWW"
-SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/wget/${P}.tar.gz
- ftp://prep.ai.mit.edu/gnu/wget/${P}.tar.gz
- http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-1.7-20010606.diff"
-HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
-
-DEPEND="virtual/glibc sys-devel/perl
- nls? ( sys-devel/gettext )"
-
-RDEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}/src
- patch -p0 < ${DISTDIR}/wget-new-percentage-1.7-20010606.diff
-}
-
-src_compile() {
- local myconf
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-# if [ "`use ssl`" ] ; then
-# myconf="$myconf --with-ssl=/usr"
-# fi
- if [ -z "$DEBUG" ] ; then
- myconf="$myconf --disable-debug"
- fi
- try ./configure --prefix=/usr --sysconfdir=/etc/wget \
- --infodir=/usr/share/info --mandir=usr/share/man $myconf
- if [ "`use static`" ] ; then
- try make -e LDFLAGS="--static"
- else
- try make
- fi
-}
-
-src_install() {
-
- if [ "`use build`" ] ; then
- dobin src/wget
- else
- try make prefix=${D}/usr sysconfdir=${D}/etc/wget \
- mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
-
- dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
- dodoc doc/sample.wgetrc
- fi
-}
-
-