summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-01-02 03:00:50 +0000
committerMike Frysinger <vapier@gentoo.org>2003-01-02 03:00:50 +0000
commit44d2a150b41f7a3afdd523f5477c12d57055db99 (patch)
treef4fb43bc8ff63499ed4d074dafc27f5ddf7661ab /net-misc
parentnew version (diff)
downloadgentoo-2-44d2a150b41f7a3afdd523f5477c12d57055db99.tar.gz
gentoo-2-44d2a150b41f7a3afdd523f5477c12d57055db99.tar.bz2
gentoo-2-44d2a150b41f7a3afdd523f5477c12d57055db99.zip
linux namespace collision fixes
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ntp/ChangeLog6
-rw-r--r--net-misc/ntp/files/linux-config-phone.patch34
-rw-r--r--net-misc/ntp/ntp-4.1.1b-r3.ebuild7
3 files changed, 43 insertions, 4 deletions
diff --git a/net-misc/ntp/ChangeLog b/net-misc/ntp/ChangeLog
index 677c549b008d..743b7bac5001 100644
--- a/net-misc/ntp/ChangeLog
+++ b/net-misc/ntp/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for net-misc/ntp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.16 2003/01/01 01:27:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.17 2003/01/02 03:00:50 vapier Exp $
*ntp-4.1.1b-r3 (31 Dec 2002)
+ 01 Jan 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added a patch to fix the namespace collision with linux include files.
+ Check Bugs #13001 #6432 #8807
+
31 Dec 2002; Mike Frysinger <vapier@gentoo.org> :
Hopefully this will keep everyone happy
Added ntpd.confd back in but with the ability for the end
diff --git a/net-misc/ntp/files/linux-config-phone.patch b/net-misc/ntp/files/linux-config-phone.patch
new file mode 100644
index 000000000000..c5bcf92c4339
--- /dev/null
+++ b/net-misc/ntp/files/linux-config-phone.patch
@@ -0,0 +1,34 @@
+--- ntpd/ntp_config.c.orig 2001-11-19 21:12:15.000000000 -0500
++++ ntpd/ntp_config.c 2003-01-01 21:50:37.000000000 -0500
+@@ -9,15 +9,6 @@
+ # include <netinfo/ni.h>
+ #endif
+
+-#include "ntpd.h"
+-#include "ntp_io.h"
+-#include "ntp_unixtime.h"
+-#include "ntp_refclock.h"
+-#include "ntp_filegen.h"
+-#include "ntp_stdlib.h"
+-#include "ntp_config.h"
+-#include "ntp_cmdargs.h"
+-
+ #ifdef PUBKEY
+ # include "ntp_crypto.h"
+ #endif /* PUBKEY */
+@@ -42,6 +33,15 @@
+ extern HANDLE ResolverThreadHandle;
+ #endif /* SYS_WINNT */
+
++#include "ntpd.h"
++#include "ntp_io.h"
++#include "ntp_unixtime.h"
++#include "ntp_refclock.h"
++#include "ntp_filegen.h"
++#include "ntp_stdlib.h"
++#include "ntp_config.h"
++#include "ntp_cmdargs.h"
++
+ extern int priority_done;
+
+ /*
diff --git a/net-misc/ntp/ntp-4.1.1b-r3.ebuild b/net-misc/ntp/ntp-4.1.1b-r3.ebuild
index aacac151df26..ec7bf2a442c4 100644
--- a/net-misc/ntp/ntp-4.1.1b-r3.ebuild
+++ b/net-misc/ntp/ntp-4.1.1b-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.1b-r3.ebuild,v 1.1 2003/01/01 01:27:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.1b-r3.ebuild,v 1.2 2003/01/02 03:00:50 vapier Exp $
inherit eutils
@@ -17,8 +17,9 @@ DEPEND="virtual/glibc
>=sys-libs/readline-4.1"
src_unpack() {
- unpack ${A}
- cd ${S}; epatch ${FILESDIR}/ntp-bk.diff
+ unpack ${A} ; cd ${S}
+ epatch ${FILESDIR}/ntp-bk.diff
+ epatch ${FILESDIR}/linux-config-phone.patch
aclocal -I . || die
automake || die
autoconf || die