summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-01-31 16:47:57 +0000
committerDan Armak <danarmak@gentoo.org>2003-01-31 16:47:57 +0000
commit4a069e2cd01f042b6988261456f1c1d8f38bf66e (patch)
tree94b49b3f11c2154ed441df40d76a881540dca8db /net-misc
parentupdated digest (diff)
downloadgentoo-2-4a069e2cd01f042b6988261456f1c1d8f38bf66e.tar.gz
gentoo-2-4a069e2cd01f042b6988261456f1c1d8f38bf66e.tar.bz2
gentoo-2-4a069e2cd01f042b6988261456f1c1d8f38bf66e.zip
add warning msg
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/kio_fish/ChangeLog10
-rw-r--r--net-misc/kio_fish/kio_fish-1.1.2.ebuild23
2 files changed, 29 insertions, 4 deletions
diff --git a/net-misc/kio_fish/ChangeLog b/net-misc/kio_fish/ChangeLog
index fbac879d8339..a599b69e0780 100644
--- a/net-misc/kio_fish/ChangeLog
+++ b/net-misc/kio_fish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/kio_fish
-# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/kio_fish/ChangeLog,v 1.5 2002/12/13 11:00:12 blizzy Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kio_fish/ChangeLog,v 1.6 2003/01/31 16:45:57 danarmak Exp $
+
+ 31 Jan 2003; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Added warning message: this app is part of KDE 3.1 (kdebase). You really
+ should upgrade to kde 3.1 and use it from there. This old standalone
+ version is not being updated or fixed anymore.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-misc/kio_fish/kio_fish-1.1.2.ebuild b/net-misc/kio_fish/kio_fish-1.1.2.ebuild
index 8baa059bd41e..812ffb4c9512 100644
--- a/net-misc/kio_fish/kio_fish-1.1.2.ebuild
+++ b/net-misc/kio_fish/kio_fish-1.1.2.ebuild
@@ -1,20 +1,39 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/kio_fish/kio_fish-1.1.2.ebuild,v 1.8 2002/12/09 04:33:16 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kio_fish/kio_fish-1.1.2.ebuild,v 1.9 2003/01/31 16:45:57 danarmak Exp $
inherit kde-base
need-kde 3
newdepend ">=net-misc/openssh-3.1_p1"
-DESCRIPTION="a kioslave for KDE 3 that lets you view and manipulate your remote files using SSH"
+DESCRIPTION="a kioslave for KDE 3 that lets you view and manipulate your remote files using SSH."
SRC_URI="http://ich.bin.kein.hoschi.de/fish/${P}.tar.bz2"
HOMEPAGE="http://ich.bin.kein.hoschi.de/fish/"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc "
+warning_msg() {
+
+ewarn "WARNING: this app is now part of kdebase-3.1. It is very much recommended that you"
+ewarn "upgrade to kde 3.1 instead of using this standalone app, because it is no longer being"
+ewarn "updated or fixed. In addition, it won't even compile on a kde 3.1 system."
+
+}
+
+src_unpack() {
+
+ warning_msg
+ kde_src_unpack
+
+}
+
src_install() {
dodir /usr/kde/3/share/services
make DESTDIR=${D} install || die
}
+
+src_postinst() {
+ warning_msg
+}