summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-04 13:07:09 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-04 13:07:09 +0000
commitad77f7e62dc0a10ae94a04427e47fee0787d4b2b (patch)
tree9f5d05f6491130ea8e4471d43a16cc072b41c876 /net-misc
parenttetex goes in DEPEND, not RDEPEND. (diff)
downloadgentoo-2-ad77f7e62dc0a10ae94a04427e47fee0787d4b2b.tar.gz
gentoo-2-ad77f7e62dc0a10ae94a04427e47fee0787d4b2b.tar.bz2
gentoo-2-ad77f7e62dc0a10ae94a04427e47fee0787d4b2b.zip
restore
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nforce-net/files/digest-nforce-net-1.0.02561
-rw-r--r--net-misc/nforce-net/nforce-net-1.0.0256.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/nforce-net/files/digest-nforce-net-1.0.0256 b/net-misc/nforce-net/files/digest-nforce-net-1.0.0256
new file mode 100644
index 000000000000..d18cd981bcb1
--- /dev/null
+++ b/net-misc/nforce-net/files/digest-nforce-net-1.0.0256
@@ -0,0 +1 @@
+MD5 3ad2e2371946b7881471e4cadddf108e NVIDIA_nforce-1.0-0256.tar.gz 75752
diff --git a/net-misc/nforce-net/nforce-net-1.0.0256.ebuild b/net-misc/nforce-net/nforce-net-1.0.0256.ebuild
new file mode 100644
index 000000000000..9ba427d5340a
--- /dev/null
+++ b/net-misc/nforce-net/nforce-net-1.0.0256.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nforce-net/nforce-net-1.0.0256.ebuild,v 1.5 2003/08/04 13:07:09 vapier Exp $
+
+inherit gcc
+
+# Make sure Portage does _NOT_ strip symbols. Need both lines for
+# Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+
+NV_V="${PV/1.0./1.0-}"
+NV_PACKAGE="NVIDIA_nforce-${NV_V}"
+S="${WORKDIR}/nforce"
+DESCRIPTION="Linux kernel module for the NVIDIA's nForce network chip"
+SRC_URI="http://download.nvidia.com/XFree86/nforce/${NV_V}/${NV_PACKAGE}.tar.gz"
+HOMEPAGE="http://www.nvidia.com/"
+
+# The slow needs to be set to $KV to prevent unmerges of
+# modules for other kernels.
+LICENSE="NVIDIA"
+SLOT="${KV}"
+KEYWORDS="-* x86"
+
+DEPEND="virtual/linux-sources >=sys-apps/portage-1.9.10"
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ cd ${S}/nvnet
+ make KERNSRC="/usr/src/linux" || die
+}
+
+src_install() {
+ # The driver goes into the standard modules location
+ insinto /lib/modules/${KV}/kernel/drivers/net
+ doins nvnet/nvnet.o
+
+ # Docs
+ dodoc ${S}/ReleaseNotes.html
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ # Update module dependency
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ echo
+ einfo "You need to add \"nvnet\" to your /etc/modules.autoload to load"
+ einfo "this module when the system is started. Alternatively, you can"
+ einfo "use the 'hotplug' package ('emerge hotplug' then 'rc-update add"
+ einfo "hotplug default') to auto-detect and load \"nvnet\" on startup."
+}
+