summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-30 18:07:29 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-30 18:07:29 +0000
commitc5cc2644f1eb4082698680763438070283a9e040 (patch)
tree98e0f72701e5b39d877dd1fa3072d5e76bd71331 /net-misc
parentQA: Remove default src_compile. (diff)
downloadgentoo-2-c5cc2644f1eb4082698680763438070283a9e040.tar.gz
gentoo-2-c5cc2644f1eb4082698680763438070283a9e040.tar.bz2
gentoo-2-c5cc2644f1eb4082698680763438070283a9e040.zip
QA: Remove default src_compile
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/knock/knock-0.1.ebuild11
-rw-r--r--net-misc/knock/knock-0.3.ebuild11
2 files changed, 6 insertions, 16 deletions
diff --git a/net-misc/knock/knock-0.1.ebuild b/net-misc/knock/knock-0.1.ebuild
index cadfb84fc080..eec0a73f3e1b 100644
--- a/net-misc/knock/knock-0.1.ebuild
+++ b/net-misc/knock/knock-0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.1.ebuild,v 1.12 2005/03/14 17:49:52 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.1.ebuild,v 1.13 2005/07/30 18:07:29 swegener Exp $
inherit eutils
@@ -21,16 +21,11 @@ src_unpack() {
epatch ${FILESDIR}/knockd.conf.patch
}
-src_compile() {
- econf || die "could not configure"
- emake || die "emake failed"
-}
-
src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc README
dohtml doc/index.html
- insinto /etc/conf.d; newins ${FILESDIR}/knockd.confd knock
- exeinto /etc/init.d; newexe ${FILESDIR}/knockd.initd knock
+ newconfd ${FILESDIR}/knockd.confd knock
+ newinitd ${FILESDIR}/knockd.initd knock
}
diff --git a/net-misc/knock/knock-0.3.ebuild b/net-misc/knock/knock-0.3.ebuild
index ce5b91926ceb..4864a45d9c67 100644
--- a/net-misc/knock/knock-0.3.ebuild
+++ b/net-misc/knock/knock-0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.3.ebuild,v 1.11 2005/03/14 17:49:52 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/knock/knock-0.3.ebuild,v 1.12 2005/07/30 18:07:29 swegener Exp $
inherit eutils
@@ -21,16 +21,11 @@ src_unpack() {
epatch ${FILESDIR}/knockd.conf.patch
}
-src_compile() {
- econf || die "could not configure"
- emake || die "emake failed"
-}
-
src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc README
dohtml doc/index.html
- insinto /etc/conf.d; newins ${FILESDIR}/knockd.confd knock
- exeinto /etc/init.d; newexe ${FILESDIR}/knockd.initd knock
+ newconfd ${FILESDIR}/knockd.confd knock
+ newinitd ${FILESDIR}/knockd.initd knock
}