summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-10 20:10:05 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-10 20:10:05 +0000
commitf6994e0abd34678f7488c1f55fa32f047304099c (patch)
tree9d39c4f38d214c5a34eff3c9325d4f5a9baf434c /net-misc
parentnet-misc/ntp rc5/rc6 support (diff)
downloadgentoo-2-f6994e0abd34678f7488c1f55fa32f047304099c.tar.gz
gentoo-2-f6994e0abd34678f7488c1f55fa32f047304099c.tar.bz2
gentoo-2-f6994e0abd34678f7488c1f55fa32f047304099c.zip
doc location fixup
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ntp/ntp-4.1.71.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/net-misc/ntp/ntp-4.1.71.ebuild b/net-misc/ntp/ntp-4.1.71.ebuild
index 483a0ca42137..bdafdc9618c1 100644
--- a/net-misc/ntp/ntp-4.1.71.ebuild
+++ b/net-misc/ntp/ntp-4.1.71.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Terry Chan <tchan@enteract.com>
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.71.ebuild,v 1.1 2001/10/05 23:13:51 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.71.ebuild,v 1.2 2001/10/10 20:10:05 woodchip Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Network Time Protocol suite/programs"
@@ -9,8 +9,8 @@ SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${P}.tar.gz"
HOMEPAGE="http://www.ntp.org/"
DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.1"
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
src_compile() {
cp configure configure.orig
@@ -18,7 +18,8 @@ src_compile() {
LDFLAGS="$LDFLAGS -lncurses"
./configure --prefix=/usr --mandir=/usr/share/man \
- --host=${CHOST} --build=${CHOST} || die
+ --host=${CHOST} --build=${CHOST} || die
+
emake || die
}
@@ -26,10 +27,11 @@ src_install () {
make prefix=${D}/usr mandir=${D}/usr/share/man install || die
dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
- docinto html ; dodoc html/*.htm
- docinto html/hints ; dodoc html/hints/*
- docinto html/pic ; dodoc html/pic/*
+ insinto /usr/share/doc/${PF}/html ; doins html/*.htm
+ insinto /usr/share/doc/${PF}/html/hints ; doins html/hints/*
+ insinto /usr/share/doc/${PF}/html/pic ; doins html/pic/*
+
+ insinto /usr/share/ntp ; doins scripts/*
- insinto /usr/share/ntp
- doins scripts/*
+ exeinto /etc/rc.d/init.d ; newexe ${FILESDIR}/ntpd.rc5 ntpd
}