summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-09 23:55:48 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-09 23:55:48 +0000
commit7867edded4eff19064b5b3409724fd07f854e302 (patch)
tree2234383605052138195ddb9a1a3873c8a1ba10b4 /net-nds/ypbind
parent*** empty log message *** (diff)
downloadgentoo-2-7867edded4eff19064b5b3409724fd07f854e302.tar.gz
gentoo-2-7867edded4eff19064b5b3409724fd07f854e302.tar.bz2
gentoo-2-7867edded4eff19064b5b3409724fd07f854e302.zip
*** empty log message ***
Diffstat (limited to 'net-nds/ypbind')
-rw-r--r--net-nds/ypbind/files/digest1
-rwxr-xr-xnet-nds/ypbind/files/ypbind38
-rw-r--r--net-nds/ypbind/ypbind-1.6-r1.ebuild34
3 files changed, 73 insertions, 0 deletions
diff --git a/net-nds/ypbind/files/digest b/net-nds/ypbind/files/digest
new file mode 100644
index 000000000000..69538539ae69
--- /dev/null
+++ b/net-nds/ypbind/files/digest
@@ -0,0 +1 @@
+MD5 903b483e2434230c63407216380b6fc9 ypbind-mt-1.6.tar.gz
diff --git a/net-nds/ypbind/files/ypbind b/net-nds/ypbind/files/ypbind
new file mode 100755
index 000000000000..dea310acba80
--- /dev/null
+++ b/net-nds/ypbind/files/ypbind
@@ -0,0 +1,38 @@
+#!/bin/sh
+#RCUPDATE:2 3 4:75:This line is required for script management
+
+. /etc/rc.d/config/functions
+. /etc/rc.d/config/basic
+
+SERVICE="NIS Client"
+opts="start stop restart"
+
+EXE="/usr/sbin/ypbind"
+PID="/var/run/ypbind.pid"
+
+start() {
+ domainname ${YP_DOMAIN}
+ ebegin "Starting $SERVICE..."
+ start-stop-daemon --start --quiet --exec $EXE
+ eend $? "Started $SERVICE." "Error Starting $SERVICE."
+}
+
+stop() {
+ ebegin "Stopping $SERVICE..."
+ start-stop-daemon --stop --quiet --signal 9 --pid $PID
+ eend $? "Stopped $SERVICE." "Error Stopping $SERVICE."
+
+ # Remove binding files, if ypbind "forget" it
+ rm -f /var/yp/binding/*
+ rm -f /var/lock/subsys/ypbind
+}
+
+restart() {
+ stop
+ start
+}
+
+doservice ${@}
+
+
+
diff --git a/net-nds/ypbind/ypbind-1.6-r1.ebuild b/net-nds/ypbind/ypbind-1.6-r1.ebuild
new file mode 100644
index 000000000000..56f15a749ca8
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.6-r1.ebuild,v 1.1 2000/08/09 23:55:48 achim Exp $
+
+P=ypbind-1.6
+A=ypbind-mt-1.6.tar.gz
+S=${WORKDIR}/ypbind-mt-1.6
+CATEGORY="net-nds"
+DESCRIPTION="Multithreaded NIS bind service"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/"${A}
+HOMEPAGE="http://www.suse.de/~kukuk/nis/ypbind-mt/index.html"
+src_unpack() {
+ unpack ${A}
+}
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/yp --with-catgets
+ make
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR=${D} install
+ insinto /etc/rc.d/init.d
+ doins ${O}/files/ypbind
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc/yp
+ doins etc/yp.conf
+}
+
+
+