summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-01-11 15:35:00 +0000
committerJeroen Roovers <jer@gentoo.org>2013-01-11 15:35:00 +0000
commitd37cf97b5ed90a95ce59e832b7d70ec212133f36 (patch)
treee0ed5947abb136d56a12948bb65f28fc76ec054d /net-nntp
parentVersion bump. Use max_filedescriptors to determine the max number of files sq... (diff)
downloadgentoo-2-d37cf97b5ed90a95ce59e832b7d70ec212133f36.tar.gz
gentoo-2-d37cf97b5ed90a95ce59e832b7d70ec212133f36.tar.bz2
gentoo-2-d37cf97b5ed90a95ce59e832b7d70ec212133f36.zip
Respect AR, RANLIB, CFLAGS (bug #451086 by Vicente Olivert Riera).
(Portage version: 2.2.0_alpha150/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/ChangeLog6
-rw-r--r--net-nntp/tin/tin-2.0.1.ebuild10
-rw-r--r--net-nntp/tin/tin-2.1.0.ebuild93
-rw-r--r--net-nntp/tin/tin-2.1.2.ebuild6
4 files changed, 14 insertions, 101 deletions
diff --git a/net-nntp/tin/ChangeLog b/net-nntp/tin/ChangeLog
index d70b5d889443..549a8b03d9eb 100644
--- a/net-nntp/tin/ChangeLog
+++ b/net-nntp/tin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/tin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.41 2013/01/08 18:08:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.42 2013/01/11 15:35:00 jer Exp $
+
+ 11 Jan 2013; Jeroen Roovers <jer@gentoo.org> tin-2.0.1.ebuild,
+ -tin-2.1.0.ebuild, tin-2.1.2.ebuild:
+ Respect AR, RANLIB, CFLAGS (bug #451086 by Vicente Olivert Riera).
08 Jan 2013; Jeroen Roovers <jer@gentoo.org> tin-2.1.2.ebuild:
Switch to xz tarball.
diff --git a/net-nntp/tin/tin-2.0.1.ebuild b/net-nntp/tin/tin-2.0.1.ebuild
index a1633cbb6abe..5896a6333ee5 100644
--- a/net-nntp/tin/tin-2.0.1.ebuild
+++ b/net-nntp/tin/tin-2.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.0.1.ebuild,v 1.3 2012/10/30 23:02:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.0.1.ebuild,v 1.4 2013/01/11 15:35:00 jer Exp $
EAPI=4
-inherit eutils toolchain-funcs versionator
+inherit autotools eutils toolchain-funcs versionator
DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
HOMEPAGE="http://www.tin.org/"
@@ -36,6 +36,8 @@ DEPEND="
src_prepare() {
# Do not strip
sed -i src/Makefile.in -e '388s|-s ||g' || die "sed src/Makefile.in failed"
+ sed -i configure.in -e '/CFLAGS/s|-g||g' || die
+ eautoreconf
}
src_configure() {
@@ -53,7 +55,7 @@ src_configure() {
use etiquette || myconf="${myconf} --disable-etiquette"
- tc-export CC
+ tc-export AR CC RANLIB
econf \
$(use_enable cancel-locks) \
diff --git a/net-nntp/tin/tin-2.1.0.ebuild b/net-nntp/tin/tin-2.1.0.ebuild
deleted file mode 100644
index c4133b3c1fa7..000000000000
--- a/net-nntp/tin/tin-2.1.0.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.1.0.ebuild,v 1.1 2012/10/30 23:02:13 jer Exp $
-
-EAPI=4
-inherit eutils toolchain-funcs versionator
-
-DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
-HOMEPAGE="http://www.tin.org/"
-SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v$(get_version_component_range 1-2)/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="cancel-locks debug doc +etiquette evil forgery gpg idn ipv6 mime nls sasl socks5 spell unicode"
-
-RDEPEND="
- dev-libs/libpcre
- dev-libs/uulib
- gpg? ( app-crypt/gnupg )
- idn? ( net-dns/libidn )
- mime? ( net-mail/metamail )
- net-misc/urlview
- nls? ( sys-devel/gettext )
- sasl? ( virtual/gsasl )
- socks5? ( net-proxy/dante )
- sys-libs/ncurses[unicode?]
- unicode? ( dev-libs/icu )
-"
-
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- # Do not strip
- sed -i src/Makefile.in -e '388s|-s ||g' || die "sed src/Makefile.in failed"
-}
-
-src_configure() {
- if use evil || use cancel-locks; then
- sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
- fi
-
- if use forgery
- then
- sed -i -e"s/^CPPFLAGS.*/& -DFORGERY/" src/Makefile.in
- fi
-
- local screen="ncurses"
- use unicode && screen="ncursesw"
-
- use etiquette || myconf="${myconf} --disable-etiquette"
-
- tc-export CC
-
- econf \
- $(use_enable cancel-locks) \
- $(use_enable debug) \
- $(use_enable gpg pgp-gpg) \
- $(use_enable ipv6) \
- $(use_enable nls) \
- $(use_with mime metamail /usr) \
- $(use_with socks5 socks) $(use_with socks5) \
- $(use_with spell ispell /usr) \
- --disable-mime-strict-charset \
- --enable-echo \
- --enable-nntp-only \
- --enable-prototypes \
- --with-coffee \
- --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
- --with-pcre=/usr \
- --with-screen=${screen} \
- ${myconf}
-}
-
-src_compile() {
- emake build
-}
-
-src_install() {
- default
-
- # File collision?
- rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
-
- dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
- use doc && dodoc doc/{*.sample,*.txt}
-
- insinto /etc/tin
- doins doc/tin.defaults
-}
diff --git a/net-nntp/tin/tin-2.1.2.ebuild b/net-nntp/tin/tin-2.1.2.ebuild
index e566785f355a..d828612651c9 100644
--- a/net-nntp/tin/tin-2.1.2.ebuild
+++ b/net-nntp/tin/tin-2.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.1.2.ebuild,v 1.2 2013/01/08 18:08:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.1.2.ebuild,v 1.3 2013/01/11 15:35:00 jer Exp $
EAPI=4
inherit eutils toolchain-funcs versionator
@@ -36,8 +36,8 @@ DEPEND="
"
src_prepare() {
- # Do not strip
sed -i src/Makefile.in -e 's| -s | |g' || die
+ sed -i configure -e '/CFLAGS/s|-g||g' || die
}
src_configure() {
@@ -53,7 +53,7 @@ src_configure() {
local screen="ncurses"
use unicode && screen="ncursesw"
- tc-export CC
+ tc-export AR CC RANLIB
econf \
$(use_enable cancel-locks) \