summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-01-26 23:18:33 +0000
committerMike Frysinger <vapier@gentoo.org>2003-01-26 23:18:33 +0000
commit9a94778c471d1712fdbbf26f42c1cd7e565e9163 (patch)
tree917b2bfb33502170a298806d03a782595e1c2ae4 /net-p2p/dchub/dchub-0.2.5.ebuild
parentadded missing glib depend (diff)
downloadgentoo-2-9a94778c471d1712fdbbf26f42c1cd7e565e9163.tar.gz
gentoo-2-9a94778c471d1712fdbbf26f42c1cd7e565e9163.tar.bz2
gentoo-2-9a94778c471d1712fdbbf26f42c1cd7e565e9163.zip
version bump #14577
Diffstat (limited to 'net-p2p/dchub/dchub-0.2.5.ebuild')
-rw-r--r--net-p2p/dchub/dchub-0.2.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/dchub/dchub-0.2.5.ebuild b/net-p2p/dchub/dchub-0.2.5.ebuild
new file mode 100644
index 000000000000..81309ad720b1
--- /dev/null
+++ b/net-p2p/dchub/dchub-0.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dchub/dchub-0.2.5.ebuild,v 1.1 2003/01/26 23:18:33 vapier Exp $
+
+HOMEPAGE="http://www.ac2i.tzo.com/dctc/#dchub"
+DESCRIPTION="dchub (Direct Connect Hub), a linux hub for the p2p 'direct connect'"
+SRC_URI="http://ac2i.tzo.com/dctc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="virtual/glibc
+ =dev-libs/glib-1*
+ sys-devel/perl
+ dev-db/edb"
+
+src_install() {
+ einstall || die "install problem"
+
+ dodoc Documentation/*
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+ dodir /etc/{conf,init}.d /etc/dchub
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dchub.init.d dchub
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dchub.conf.d dchub
+}