summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-27 16:46:11 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-27 16:46:11 +0000
commit7897cd239b318fdb4fa6237cf858e11bb0296d98 (patch)
treed867e03b44e9499c25648e3d266333cea3931b45 /net-p2p/gnunet
parentAdded mysql support (diff)
downloadgentoo-2-7897cd239b318fdb4fa6237cf858e11bb0296d98.tar.gz
gentoo-2-7897cd239b318fdb4fa6237cf858e11bb0296d98.tar.bz2
gentoo-2-7897cd239b318fdb4fa6237cf858e11bb0296d98.zip
Updated ebuild with some fixes. Submitted by Jeremiah Mahler. Fixes #6915
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/ChangeLog9
-rw-r--r--net-p2p/gnunet/files/digest-gnunet-0.4.61
-rw-r--r--net-p2p/gnunet/gnunet-0.4.6.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index 28a3d938d55c..8a3a20e938cd 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/gnunet
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.2 2002/08/19 00:34:46 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.3 2002/08/27 16:46:11 rphillips Exp $
+
+*gnunet-0.4.6 (27 Aug 2002)
+
+ 27 Aug 2002; Ryan Phillips <rphillips@gentoo.org> gnunet-0.4.6.ebuild :
+
+ Some changes to the ebuild and an updated version. Fixes bug #6915
+ Submitted by Jeremiah Mahler
*gnunet-0.4.4 (18 Aug 2002)
diff --git a/net-p2p/gnunet/files/digest-gnunet-0.4.6 b/net-p2p/gnunet/files/digest-gnunet-0.4.6
new file mode 100644
index 000000000000..bee5c3de51a7
--- /dev/null
+++ b/net-p2p/gnunet/files/digest-gnunet-0.4.6
@@ -0,0 +1 @@
+MD5 be99b483b512d0d60345fdc5a0a749b4 GNUnet-0.4.6.tar.bz2 222641
diff --git a/net-p2p/gnunet/gnunet-0.4.6.ebuild b/net-p2p/gnunet/gnunet-0.4.6.ebuild
new file mode 100644
index 000000000000..9a45feecef9d
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.4.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.ovmj.org/GNUnet/"
+SRC_URI="http://www.ovmj.org/GNUnet/download/GNUnet-${PV}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=dev-libs/openssl-0.9.6d
+ >=sys-libs/gdbm-1.8.0
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libextractor-0.1.0"
+
+RDEPEND="${DEPEND}"
+
+src_compile () {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+ docinto contrib
+ dodoc contrib/*
+}