summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
commit840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8 (patch)
treeb7fb21135562109c7d3faef78deeeb62db5981c3 /net-p2p/gnut
parentnew version, compiles with gcc 3.1 (diff)
downloadgentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.tar.gz
gentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.tar.bz2
gentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.zip
initial commit for net-p2p - these are all the p2p ebuilds listed in my mail. Note: they have not yet been removed from net-misc or media-sound
Diffstat (limited to 'net-p2p/gnut')
-rw-r--r--net-p2p/gnut/ChangeLog13
-rw-r--r--net-p2p/gnut/files/digest-gnut-0.4.281
-rw-r--r--net-p2p/gnut/gnut-0.4.28.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/net-p2p/gnut/ChangeLog b/net-p2p/gnut/ChangeLog
new file mode 100644
index 000000000000..73525f9aa883
--- /dev/null
+++ b/net-p2p/gnut/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-p2p/gnut
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnut/ChangeLog,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+*gnut-0.4.28 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-p2p/gnut/files/digest-gnut-0.4.28 b/net-p2p/gnut/files/digest-gnut-0.4.28
new file mode 100644
index 000000000000..6c088eee9e31
--- /dev/null
+++ b/net-p2p/gnut/files/digest-gnut-0.4.28
@@ -0,0 +1 @@
+MD5 bade24c9838d390de41f5ea0c80dc22f gnut-0.4.28.tar.gz 333625
diff --git a/net-p2p/gnut/gnut-0.4.28.ebuild b/net-p2p/gnut/gnut-0.4.28.ebuild
new file mode 100644
index 000000000000..8522a49322c4
--- /dev/null
+++ b/net-p2p/gnut/gnut-0.4.28.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnut/gnut-0.4.28.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text-mode gnutella client"
+SRC_URI="http://www.gnutelliums.com/linux_unix/gnut/tars/gnut-0.4.28.tar.gz"
+HOMEPAGE="http://http://www.gnutelliums.com/linux_unix/gnut/"
+
+DEPEND="virtual/glibc"
+RDEPEND="$DEPEND"
+
+src_compile() {
+ cat /dev/null | ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dohtml doc/*.html
+ dodoc doc/TUTORIAL AUTHORS COPYING ChangeLog GDJ HACKING \
+ INSTALL NEWS README TODO
+}