summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2005-02-25 03:09:46 +0000
committerJon Hood <squinky86@gentoo.org>2005-02-25 03:09:46 +0000
commit846d05d3f2462da4cb82be077b35209cfc9abd4c (patch)
treef8535b33d601ad47625db0aed76fe4c11b3a5912 /net-p2p/lopster/files
parentRemove mask of libgdiplus versions that work with cairo-0.3.0 (diff)
downloadgentoo-2-846d05d3f2462da4cb82be077b35209cfc9abd4c.tar.gz
gentoo-2-846d05d3f2462da4cb82be077b35209cfc9abd4c.tar.bz2
gentoo-2-846d05d3f2462da4cb82be077b35209cfc9abd4c.zip
minor bugfix updates
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-p2p/lopster/files')
-rw-r--r--net-p2p/lopster/files/1.2.2-bugfixes-1.patch160
-rw-r--r--net-p2p/lopster/files/digest-lopster-1.0.1.200207021
-rw-r--r--net-p2p/lopster/files/digest-lopster-1.2.11
-rw-r--r--net-p2p/lopster/files/digest-lopster-1.2.2-r11
4 files changed, 161 insertions, 2 deletions
diff --git a/net-p2p/lopster/files/1.2.2-bugfixes-1.patch b/net-p2p/lopster/files/1.2.2-bugfixes-1.patch
new file mode 100644
index 000000000000..979c6ac98632
--- /dev/null
+++ b/net-p2p/lopster/files/1.2.2-bugfixes-1.patch
@@ -0,0 +1,160 @@
+diff -Naur lopster-1.2.2/configure.in lopster/configure.in
+--- lopster-1.2.2/configure.in 2004-08-29 17:34:29.000000000 +0200
++++ lopster/configure.in 2005-02-10 19:55:27.000000000 +0100
+@@ -1,7 +1,7 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+ AC_INIT(configure.in)
+-AM_INIT_AUTOMAKE(lopster, "1.2.2")
++AM_INIT_AUTOMAKE(lopster, "1.2.2-fix1")
+ AM_CONFIG_HEADER(config.h)
+
+ AC_PROG_CC
+diff -Naur lopster-1.2.2/src/browse.c lopster/src/browse.c
+--- lopster-1.2.2/src/browse.c 2004-08-28 23:27:06.000000000 +0200
++++ lopster/src/browse.c 2005-02-10 19:55:39.000000000 +0100
+@@ -1683,9 +1683,9 @@
+
+ clist = gtk_clist_new(5);
+ tree->clist = GTK_CLIST(clist);
+- gtk_clist_set_sort_column(GTK_CLIST(clist), 0);
+- gtk_clist_set_sort_type(GTK_CLIST(clist), GTK_SORT_ASCENDING);
+- gtk_clist_set_auto_sort(GTK_CLIST(clist), 1);
++ // gtk_clist_set_sort_column(GTK_CLIST(clist), 0);
++ // gtk_clist_set_sort_type(GTK_CLIST(clist), GTK_SORT_ASCENDING);
++ // gtk_clist_set_auto_sort(GTK_CLIST(clist), 1);
+ gtk_widget_show(clist);
+ gtk_widget_set_events(clist,
+ GDK_POINTER_MOTION_MASK | GDK_LEAVE_NOTIFY_MASK);
+diff -Naur lopster-1.2.2/src/files.c lopster/src/files.c
+--- lopster-1.2.2/src/files.c 2004-08-29 17:33:38.000000000 +0200
++++ lopster/src/files.c 2005-02-10 19:55:40.000000000 +0100
+@@ -195,7 +195,6 @@
+ dest->frequency = file->frequency;
+ dest->duration = file->duration;
+ dest->linespeed = file->linespeed;
+- dest->media_type = file->media_type;
+ dest->ping = file->ping;
+ dest->vbr = file->vbr;
+
+diff -Naur lopster-1.2.2/src/global.c lopster/src/global.c
+--- lopster-1.2.2/src/global.c 2004-08-29 17:33:38.000000000 +0200
++++ lopster/src/global.c 2005-02-10 19:55:40.000000000 +0100
+@@ -434,7 +434,6 @@
+ switch (level) {
+ case L_LEECH: return "Leech";
+ case L_USER: return "User";
+- case L_CHAT: return "Chatter";
+ case L_MOD: return "Moderator";
+ case L_ADMIN: return "Administrator";
+ case L_ELITE: return "Elite";
+@@ -446,7 +445,6 @@
+ switch (level) {
+ case L_LEECH: return "Leech";
+ case L_USER: return "User";
+- case L_CHAT: return "Chatter";
+ case L_MOD: return "Mod";
+ case L_ADMIN: return "Admin";
+ case L_ELITE: return "Elite";
+@@ -3398,6 +3396,7 @@
+ global.timer = -1;
+
+ global.usermode = ModeMask[N_UNKNOWN];
++ global.linespeed = 0;
+
+ global.status.exiting = E_NONE;
+
+diff -Naur lopster-1.2.2/src/log.c lopster/src/log.c
+--- lopster-1.2.2/src/log.c 2004-01-11 16:50:30.000000000 +0100
++++ lopster/src/log.c 2005-02-10 19:55:42.000000000 +0100
+@@ -147,8 +147,13 @@
+ g_free(log->description);
+ g_free(log);
+ }
+- g_list_free(net?net->logs:other_logs);
+- net?net->logs:other_logs = NULL;
++ if (net) {
++ g_list_free(net->logs);
++ net->logs = NULL;
++ } else {
++ g_list_free(other_logs);
++ other_logs = NULL;
++ }
+ }
+
+ void log_file_destroy(log_file_t* lf) {
+diff -Naur lopster-1.2.2/src/lopster.h lopster/src/lopster.h
+--- lopster-1.2.2/src/lopster.h 2004-08-29 17:33:39.000000000 +0200
++++ lopster/src/lopster.h 2005-02-10 19:55:42.000000000 +0100
+@@ -365,7 +365,6 @@
+ typedef enum {
+ L_LEECH,
+ L_USER,
+- L_CHAT,
+ L_MOD,
+ L_ADMIN,
+ L_ELITE,
+diff -Naur lopster-1.2.2/src/napster_handler.c lopster/src/napster_handler.c
+--- lopster-1.2.2/src/napster_handler.c 2004-08-28 23:27:09.000000000 +0200
++++ lopster/src/napster_handler.c 2005-02-10 19:55:42.000000000 +0100
+@@ -780,9 +780,6 @@
+ pos = strchr(pos+28, '(');
+ if (!pos) return 1;
+ level = atoi(pos+1);
+- // need to add one level on slavanap (and maybe other non-opennaps)
+- // because there is no chatter
+- if (net->subtype != N_OPENNAP && level >= L_CHAT) level++;
+ }
+ if (net->user.level != (unsigned)level)
+ set_user_level(net, level);
+@@ -806,9 +803,6 @@
+ pos = strchr(pos+24, '(');
+ if (!pos) return 1;
+ level = atoi(pos+1);
+- // need to add one level on slavanap (and maybe other non-opennaps)
+- // because there is no chatter
+- if (net->subtype != N_OPENNAP && level >= L_CHAT) level++;
+ }
+ if (net->user.level != (unsigned)level)
+ set_user_level(net, level);
+diff -Naur lopster-1.2.2/src/search.c lopster/src/search.c
+--- lopster-1.2.2/src/search.c 2004-05-03 18:47:03.000000000 +0200
++++ lopster/src/search.c 2005-02-10 19:55:42.000000000 +0100
+@@ -774,14 +774,17 @@
+ }
+ }
+
+- command_send(net, CMD_SEARCH,
+- pattern->include, pattern->exclude,
+- pattern->max_results, pattern->media_type,
+- pattern->bitrate_lo, pattern->bitrate_hi,
+- pattern->freq_lo, pattern->freq_hi,
+- pattern->speed_lo, pattern->speed_hi,
+- pattern->size_lo, pattern->size_hi,
+- pattern->duration_lo, pattern->duration_hi);
++ // send as unimportant command to make sure it comes after
++ // the library is shared.
++ command_send_unimportant
++ (net, CMD_SEARCH,
++ pattern->include, pattern->exclude,
++ pattern->max_results, pattern->media_type,
++ pattern->bitrate_lo, pattern->bitrate_hi,
++ pattern->freq_lo, pattern->freq_hi,
++ pattern->speed_lo, pattern->speed_hi,
++ pattern->size_lo, pattern->size_hi,
++ pattern->duration_lo, pattern->duration_hi);
+
+ #ifdef SEARCH_DEBUG
+ printf("[SEARCH] doing (%s) on %s (%d)\n",
+diff -Naur lopster-1.2.2/src/transfer.c lopster/src/transfer.c
+--- lopster-1.2.2/src/transfer.c 2004-08-29 17:33:39.000000000 +0200
++++ lopster/src/transfer.c 2005-02-10 19:55:43.000000000 +0100
+@@ -918,7 +918,7 @@
+ char buf[MAX_PUSH + 1];
+ int n, sent;
+ long maxpush;
+-
++
+ if (condition != GDK_INPUT_WRITE) {
+ socket_end(socket, S_INCOMPLETE);
+ return 1;
diff --git a/net-p2p/lopster/files/digest-lopster-1.0.1.20020702 b/net-p2p/lopster/files/digest-lopster-1.0.1.20020702
deleted file mode 100644
index 6da8fedcc080..000000000000
--- a/net-p2p/lopster/files/digest-lopster-1.0.1.20020702
+++ /dev/null
@@ -1 +0,0 @@
-MD5 089d063575c99295b4520d270e075db2 lopster-1.0.1.20020702.tar.bz2 980583
diff --git a/net-p2p/lopster/files/digest-lopster-1.2.1 b/net-p2p/lopster/files/digest-lopster-1.2.1
deleted file mode 100644
index 8938ffd0af7f..000000000000
--- a/net-p2p/lopster/files/digest-lopster-1.2.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c6b192a4c62b50999fa1117924204156 lopster-1.2.1.tar.gz 632376
diff --git a/net-p2p/lopster/files/digest-lopster-1.2.2-r1 b/net-p2p/lopster/files/digest-lopster-1.2.2-r1
new file mode 100644
index 000000000000..5c115a9615cb
--- /dev/null
+++ b/net-p2p/lopster/files/digest-lopster-1.2.2-r1
@@ -0,0 +1 @@
+MD5 ae857116eddd01f1f7d2769908a142c0 lopster-1.2.2.tar.gz 630325