summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-04-20 04:32:39 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-04-20 04:32:39 +0000
commit6e0c07fbb38df53c12141cf74d6e26675d31175a (patch)
treeef87a72833507aa7960f00e1b9c423611e3a345e /net-p2p
parentAdd sys-libs/readline dependency (#215079). (diff)
downloadgentoo-2-6e0c07fbb38df53c12141cf74d6e26675d31175a.tar.gz
gentoo-2-6e0c07fbb38df53c12141cf74d6e26675d31175a.tar.bz2
gentoo-2-6e0c07fbb38df53c12141cf74d6e26675d31175a.zip
version bump from upstream
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog9
-rw-r--r--net-p2p/transmission/files/transmission-1.11-libnotify-option.patch35
-rw-r--r--net-p2p/transmission/transmission-1.11.ebuild41
3 files changed, 84 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 9fd581ee5688..5d5c65cb4146 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.56 2008/04/10 15:39:52 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.57 2008/04/20 04:32:38 compnerd Exp $
+
+*transmission-1.11 (20 Apr 2008)
+
+ 20 Apr 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/transmission-1.11-libnotify-option.patch,
+ +transmission-1.11.ebuild:
+ Version bump from upstream (bug #215525)
10 Apr 2008; Samuli Suominen <drac@gentoo.org> transmission-1.0.6.ebuild:
amd64 stable
diff --git a/net-p2p/transmission/files/transmission-1.11-libnotify-option.patch b/net-p2p/transmission/files/transmission-1.11-libnotify-option.patch
new file mode 100644
index 000000000000..41f5bcd18afe
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-1.11-libnotify-option.patch
@@ -0,0 +1,35 @@
+--- /tmp/configure.ac.orig 2008-04-19 20:47:55.000000000 -0700
++++ /tmp/configure.ac 2008-04-19 21:10:12.000000000 -0700
+@@ -106,13 +106,16 @@
+ AC_DEFINE([HAVE_GIO], 1)
+ fi
+
+-PKG_CHECK_MODULES([LIBNOTIFY],
+- [libnotify >= $LIBNOTIFY_MINIMUM],
+- [use_libnotify=yes],
+- [use_libnotify=no])
+-AC_SUBST(LIBNOTIFY_LIBS)
+-AC_SUBST(LIBNOTIFY_CFLAGS)
+-if test "x$use_libnotify" = "xyes"; then
++AC_ARG_ENABLE([libnotify],
++ AS_HELP_STRING([--enable-libnotify], [enable notifications]),,
++ [enable_libnotify=yes])
++
++if test x$enable_libnotify = xyes ; then
++ PKG_CHECK_MODULES([LIBNOTIFY], [libnotify >= $LIBNOTIFY_MINIMUM])
++
++ AC_SUBST(LIBNOTIFY_LIBS)
++ AC_SUBST(LIBNOTIFY_CFLAGS)
++
+ AC_DEFINE([HAVE_LIBNOTIFY], 1)
+ fi
+
+@@ -288,7 +291,7 @@
+ Build Daemon: ${build_daemon}
+ Build BeOS client: ${build_beos}
+ Build GTK+ client: ${build_gtk}
+- ... libnotify support: ${use_libnotify}
++ ... libnotify support: ${enable_libnotify}
+ ... gio support: ${use_gio}
+ Build OS X client: ${build_darwin}
+ Build wxWidgets client: ${build_wx}
diff --git a/net-p2p/transmission/transmission-1.11.ebuild b/net-p2p/transmission/transmission-1.11.ebuild
new file mode 100644
index 000000000000..a47629108500
--- /dev/null
+++ b/net-p2p/transmission/transmission-1.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-1.11.ebuild,v 1.1 2008/04/20 04:32:38 compnerd Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com/"
+SRC_URI="http://download.transmissionbt.com/transmission/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk libnotify"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/openssl-0.9.8
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ libnotify? ( >=x11-libs/libnotify-0.4.4 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ gtk? ( >=dev-util/intltool-0.35 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/transmission-1.11-libnotify-option.patch"
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+ econf $(use_with gtk) $(use_enable libnotify) --with-wx-config=no || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS
+}