summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-04-07 21:17:01 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-04-07 21:17:01 +0000
commitd894d9ec1430a3f06ab4c3482b2ec6ae9e9c4dc0 (patch)
tree71d4cff04b890886e2a6d2d59876dafdada0c8ea /net-p2p
parentDrop old EAPI=1 version (diff)
downloadgentoo-2-d894d9ec1430a3f06ab4c3482b2ec6ae9e9c4dc0.tar.gz
gentoo-2-d894d9ec1430a3f06ab4c3482b2ec6ae9e9c4dc0.tar.bz2
gentoo-2-d894d9ec1430a3f06ab4c3482b2ec6ae9e9c4dc0.zip
Drop to testing (nothing depends on it), remove EAPI=1 versions
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0B08240A96F66571)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linuxdcpp/ChangeLog8
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild52
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-9999.ebuild51
3 files changed, 6 insertions, 105 deletions
diff --git a/net-p2p/linuxdcpp/ChangeLog b/net-p2p/linuxdcpp/ChangeLog
index b58620979bec..56f036dd2d12 100644
--- a/net-p2p/linuxdcpp/ChangeLog
+++ b/net-p2p/linuxdcpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/linuxdcpp
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.45 2014/11/21 09:48:26 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.46 2015/04/07 21:17:01 dilfridge Exp $
+
+ 07 Apr 2015; Andreas K. Huettel <dilfridge@gentoo.org>
+ -linuxdcpp-1.0.3.ebuild, -linuxdcpp-9999.ebuild:
+ Drop to testing (nothing depends on it), remove EAPI=1 versions
21 Nov 2014; Mike Frysinger <vapier@gentoo.org> linuxdcpp-1.0.3-r1.ebuild,
linuxdcpp-1.0.3.ebuild, linuxdcpp-9999.ebuild:
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
deleted file mode 100644
index f0f40808cbc1..000000000000
--- a/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild,v 1.7 2014/11/21 09:48:26 vapier Exp $
-
-EAPI="1"
-
-# TODO: This needs to use the escons eclass.
-inherit eutils
-
-DESCRIPTION="Direct connect client, looks and works like famous DC++"
-HOMEPAGE="https://launchpad.net/linuxdcpp"
-SRC_URI="http://launchpad.net/linuxdcpp/1.0/${PV}/+download/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="debug"
-
-RDEPEND=">=gnome-base/libglade-2.4:2.0
- >=x11-libs/gtk+-2.6:2
- app-arch/bzip2
- dev-libs/openssl"
-DEPEND="${RDEPEND}
- media-libs/fontconfig
- >=dev-util/scons-0.96
- virtual/pkgconfig"
-
-src_compile() {
- local myconf=""
- use debug && myconf="${myconf} debug=1"
-
- scons ${myconf} ${MAKEOPTS} CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
-}
-
-src_install() {
- insinto /usr/share/${PN}
- doins -r ${PN} pixmaps glade
-
- dodoc Readme.txt Changelog.txt Credits.txt
-
- dosym /usr/share/${PN}/${PN} /usr/bin/${PN}
- fperms +x /usr/share/${PN}/${PN}
-
- doicon pixmaps/${PN}.png
-
- make_desktop_entry ${PN} ${PN}
-}
-
-pkg_postinst() {
- elog
- elog "After adding first directory to shares you might need to restart linuxdcpp."
- elog
-}
diff --git a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild b/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
deleted file mode 100644
index 1162a8a88400..000000000000
--- a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild,v 1.17 2014/11/21 09:48:26 vapier Exp $
-
-EAPI="1"
-
-# TODO: This needs to use the escons eclass.
-inherit bzr eutils multiprocessing
-
-DESCRIPTION="Direct connect client, looks and works like famous DC++"
-HOMEPAGE="https://launchpad.net/linuxdcpp"
-SRC_URI=""
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug"
-
-EBZR_REPO_URI="lp:linuxdcpp"
-
-S=${WORKDIR}/${P}
-
-RDEPEND=">=gnome-base/libglade-2.4:2.0
- >=x11-libs/gtk+-2.6:2
- app-arch/bzip2
- dev-libs/openssl"
-DEPEND="${RDEPEND}
- media-libs/fontconfig
- >=dev-util/scons-0.96
- virtual/pkgconfig
- >=dev-libs/boost-1.35.0-r2"
-
-src_compile() {
- local myconf=""
- use debug && myconf="${myconf} debug=1"
-
- scons ${myconf} -j$(makeopts_jobs) CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
-}
-
-src_install() {
- # linuxdcpp does not install docs according to gentoos naming scheme, so do it by hand
- dodoc Readme.txt Changelog.txt Credits.txt
- rm "${S}"/*.txt
-
- scons install PREFIX="/usr" FAKE_ROOT="${D}" || die "scons install failed"
-}
-
-pkg_postinst() {
- elog
- elog "After adding first directory to shares you might need to restart linuxdcpp."
- elog
-}