summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-07-20 12:28:50 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-07-20 12:28:50 +0000
commitd012e493366141ff33940822865fd45eefa6b1be (patch)
tree56514ceb3f3cf5bc90485a949f3e5a68dd273e25 /net-print/hplip
parentMasked due to authentication and wins name mapping: bug #140332, upstream bug... (diff)
downloadgentoo-2-d012e493366141ff33940822865fd45eefa6b1be.tar.gz
gentoo-2-d012e493366141ff33940822865fd45eefa6b1be.tar.bz2
gentoo-2-d012e493366141ff33940822865fd45eefa6b1be.zip
bump the foomatic-db, properly name 1.6.6a
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog8
-rw-r--r--net-print/hplip/files/digest-hplip-1.6.6a6
-rw-r--r--net-print/hplip/hplip-1.6.6a.ebuild118
3 files changed, 131 insertions, 1 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index ecaf5b0d1149..5fe456034797 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.38 2006/07/01 05:25:39 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.39 2006/07/20 12:28:50 genstef Exp $
+
+*hplip-1.6.6a (20 Jul 2006)
+
+ 20 Jul 2006; Stefan Schweizer <genstef@gentoo.org> -hplip-1.6.6.ebuild,
+ -hplip-1.6.6-r1.ebuild, +hplip-1.6.6a.ebuild:
+ bump the foomatic-db, properly name 1.6.6a
*hplip-1.6.6-r1 (01 Jul 2006)
diff --git a/net-print/hplip/files/digest-hplip-1.6.6a b/net-print/hplip/files/digest-hplip-1.6.6a
new file mode 100644
index 000000000000..f4e0126e9fbd
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-1.6.6a
@@ -0,0 +1,6 @@
+MD5 1c4b65222333d048450d37082d521b1e foomatic-db-hpijs-20060720.tar.gz 98252
+RMD160 0c2c09f3cea6fc2a8e5da216bd9996b96d91613d foomatic-db-hpijs-20060720.tar.gz 98252
+SHA256 1e50f603b46b1d07980212b2e5dfc5d72d07c889259e79ecbf09469fef5ad20e foomatic-db-hpijs-20060720.tar.gz 98252
+MD5 606704fc8b2fe344e49190b592b438e0 hplip-1.6.6a.tar.gz 10447071
+RMD160 546d4f86c715f760aebff57ba59f08ef4bd20e36 hplip-1.6.6a.tar.gz 10447071
+SHA256 e87ab9bc4e4a3229dafc154f91d9860a9ae15532118bfad7fb791331340a9d8d hplip-1.6.6a.tar.gz 10447071
diff --git a/net-print/hplip/hplip-1.6.6a.ebuild b/net-print/hplip/hplip-1.6.6a.ebuild
new file mode 100644
index 000000000000..2326374e2044
--- /dev/null
+++ b/net-print/hplip/hplip-1.6.6a.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.6.6a.ebuild,v 1.1 2006/07/20 12:28:50 genstef Exp $
+
+inherit eutils
+
+DB_V=20060720
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ foomaticdb? (
+ http://gentooexperimental.org/~genstef/dist/foomatic-db-hpijs-${DB_V}.tar.gz
+ http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="foomaticdb snmp X qt3 ppds scanner"
+
+DEPEND=">=dev-lang/python-2.2.0
+ snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+ !net-print/hpijs
+ !net-print/hpoj"
+
+RDEPEND="virtual/ghostscript
+ scanner? (
+ >=media-gfx/sane-backends-1.0.9
+ || (
+ X? ( >=media-gfx/xsane-0.89 )
+ >=media-gfx/sane-frontends-1.0.9
+ )
+ )
+ qt3? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
+ >=dev-libs/libusb-0.1.10a
+ sys-apps/hotplug
+ net-print/cups
+ foomaticdb? ( net-print/foomatic-db-engine )
+ >=net-print/foomatic-filters-3.0.2
+ ${DEPEND}"
+
+pkg_setup() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+ rm -f ${ROOT}/usr/libexec/cups/backend/hp{,fax};
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
+ hpssd.py
+}
+src_compile() {
+ econf \
+ $(use_enable snmp network-build) \
+ $(use_enable cups cups-install) \
+ $(use_enable ppds foomatic-install) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ emake || die "emake failed"
+ fi
+}
+
+
+src_install() {
+ # cups-1.2 installation paths, make sure that the .desktop is installed
+ sed -i -e "s:/usr/lib/cups:$(cups-config --serverbin):" \
+ -e 's:\(ICON_FILE = \).*:\1hplip.desktop:' \
+ -e 's:\(ICON_PATH = \).*:\1/usr/share/applications:' \
+ Makefile
+
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/hplip.init.d hplip
+
+ if use scanner; then
+ insinto /etc/sane.d
+ echo "hpaio" > dll.conf
+ doins dll.conf
+
+ dodir /usr/lib/sane
+ dosym /usr/lib/libsane-hpaio.la /usr/lib/sane/libsane-hpaio.la
+ dosym /usr/lib/libsane-hpaio.so /usr/lib/sane/libsane-hpaio.so
+ dosym /usr/lib/libsane-hpaio.so.1 /usr/lib/sane/libsane-hpaio.so.1
+ dosym /usr/lib/libsane-hpaio.so.1.0.0 /usr/lib/sane/libsane-hpaio.so.1.0.0
+ else
+ rm -f "${D}"/usr/lib/libsane-hpaio.la
+ rm -f "${D}"/usr/lib/libsane-hpaio.so
+ rm -f "${D}"/usr/lib/libsane-hpaio.so.1
+ rm -f "${D}"/usr/lib/libsane-hpaio.so.1.0.0
+ fi
+
+ # bug 106035
+ if ! use qt3 ; then
+ rm -f "${D}"/usr/bin/hp-print
+ rm -f "${D}"/usr/bin/hp-toolbox
+ rm -f "${D}"/usr/share/hplip/print
+ rm -f "${D}"/usr/share/hplip/toolbox
+ rm -f "${D}"/usr/share/applications/hplip.desktop
+ rm -f "${D}"/usr/lib/menu/hplip
+ fi
+
+ rm -rf ${D}/$(cups-config --serverbin)/filter ${D}/usr/bin/foomatic-rip
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ emake DESTDIR="${D}" install || die "emake install failed"
+ fi
+}