summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-02 17:57:12 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-02 17:57:12 +0000
commit597a207b38db045b31a5233671851c951f1abeed (patch)
tree0e3feb570cdc43fe25891fb409e3293d3701326d /net-print/pykota
parentStable on amd64 wrt bug #369681 (diff)
downloadgentoo-2-597a207b38db045b31a5233671851c951f1abeed.tar.gz
gentoo-2-597a207b38db045b31a5233671851c951f1abeed.tar.bz2
gentoo-2-597a207b38db045b31a5233671851c951f1abeed.zip
General cleanup and fix documentation location, bug 295314
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'net-print/pykota')
-rw-r--r--net-print/pykota/ChangeLog8
-rw-r--r--net-print/pykota/pykota-1.25_p2437-r1.ebuild37
2 files changed, 26 insertions, 19 deletions
diff --git a/net-print/pykota/ChangeLog b/net-print/pykota/ChangeLog
index 52825cb9c407..9de5837f14b9 100644
--- a/net-print/pykota/ChangeLog
+++ b/net-print/pykota/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/pykota
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.26 2010/06/17 21:58:40 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/ChangeLog,v 1.27 2011/06/02 17:57:12 dilfridge Exp $
+
+ 02 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ pykota-1.25_p2437-r1.ebuild:
+ General cleanup and fix documentation location, bug 295314
17 Jun 2010; Patrick Lauer <patrick@gentoo.org>
pykota-1.25_p2437-r1.ebuild:
diff --git a/net-print/pykota/pykota-1.25_p2437-r1.ebuild b/net-print/pykota/pykota-1.25_p2437-r1.ebuild
index afb3ee31cd6a..604c56bdc332 100644
--- a/net-print/pykota/pykota-1.25_p2437-r1.ebuild
+++ b/net-print/pykota/pykota-1.25_p2437-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.25_p2437-r1.ebuild,v 1.6 2010/10/31 18:57:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/pykota/pykota-1.25_p2437-r1.ebuild,v 1.7 2011/06/02 17:57:12 dilfridge Exp $
-EAPI="3"
+EAPI=3
PYTHON_DEPEND="2"
inherit distutils
@@ -31,7 +31,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
-DOCS="README MANIFEST.in TODO SECURITY NEWS CREDITS FAQ"
+DOCS="README TODO SECURITY NEWS CREDITS FAQ"
pkg_setup() {
python_set_active_version 2
@@ -39,24 +39,27 @@ pkg_setup() {
}
src_install() {
- mkdir -p "${D}"/etc/${PN}
+ dodir /etc/${PN} || die
distutils_src_install
- #cups backend ----------------------------------------------
- mkdir -p "${D}"$(cups-config --serverbin)/backend
- dosym /usr/share/pykota/cupspykota $(cups-config --serverbin)/backend/cupspykota
- #extra docs: inits -----------------------------------------
- init_dir=/usr/share/doc/${P}/initscripts
- insinto ${init_dir}
- cp -pPR initscripts/* "${D}"/${init_dir}
+
+ # cups backend ----------------------------------------------
+
+ dodir $(cups-config --serverbin)/backend || die
+ dosym /usr/share/pykota/cupspykota $(cups-config --serverbin)/backend/cupspykota || die
+
+ # extra docs: inits -----------------------------------------
+
+ init_dir="/usr/share/doc/${PF}/initscripts"
+ insinto "${init_dir}"
+ doins -r initscripts/* || die
# Fixes permissions for bug 155865
chmod 700 "${D}"/usr/share/pykota/cupspykota
for doc in ${DOCS}; do
- rm -f "${D}"/usr/share/doc/${PN}/${doc}
+ rm "${D}"/usr/share/doc/${PN}/${doc} || die
done
-
- rm -f "${D}"/usr/share/doc/${PN}/{LICENSE,COPYING}
- mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${P}
- rmdir "${D}"/usr/share/doc/${PN}
+ rm "${D}"/usr/share/doc/${PN}/{LICENSE,COPYING} || die
+ mv "${D}"/usr/share/doc/${PN}/* "${D}"/usr/share/doc/${PF}/ || die
+ rmdir "${D}"/usr/share/doc/${PN} || die
}