summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-08-21 19:21:15 +0000
committerAlin Năstac <mrness@gentoo.org>2007-08-21 19:21:15 +0000
commita081b36aabfd611174e8b33b51ddae9bc9a430a7 (patch)
tree9c4ef38de83c9de879c0473f5486037a37c02fc3 /net-proxy
parentstable x86, bug 189327 (diff)
downloadgentoo-2-a081b36aabfd611174e8b33b51ddae9bc9a430a7.tar.gz
gentoo-2-a081b36aabfd611174e8b33b51ddae9bc9a430a7.tar.bz2
gentoo-2-a081b36aabfd611174e8b33b51ddae9bc9a430a7.zip
Version bump.
(Portage version: 2.1.2.12)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/wwwoffle/ChangeLog7
-rw-r--r--net-proxy/wwwoffle/files/digest-wwwoffle-2.9c3
-rw-r--r--net-proxy/wwwoffle/wwwoffle-2.9c.ebuild127
3 files changed, 136 insertions, 1 deletions
diff --git a/net-proxy/wwwoffle/ChangeLog b/net-proxy/wwwoffle/ChangeLog
index 7a05096a9cfb..6e40cd3735b0 100644
--- a/net-proxy/wwwoffle/ChangeLog
+++ b/net-proxy/wwwoffle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/wwwoffle
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.31 2007/06/17 16:19:30 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.32 2007/08/21 19:21:15 mrness Exp $
+
+*wwwoffle-2.9c (21 Aug 2007)
+
+ 21 Aug 2007; Alin Năstac <mrness@gentoo.org> +wwwoffle-2.9c.ebuild:
+ Version bump.
17 Jun 2007; Alin Năstac <mrness@gentoo.org>
-files/wwwoffle-2.9-gcc41.patch, -files/wwwoffle-2.9-reload.patch,
diff --git a/net-proxy/wwwoffle/files/digest-wwwoffle-2.9c b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9c
new file mode 100644
index 000000000000..43a64ae99610
--- /dev/null
+++ b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9c
@@ -0,0 +1,3 @@
+MD5 50208b5c8d5c125accd18f9760225f9e wwwoffle-2.9c.tgz 1078788
+RMD160 d46829c2d51cb60bf303ef2c19a66abc1e8f86fb wwwoffle-2.9c.tgz 1078788
+SHA256 6b134ac08daf1186c1cdd34fea4ad8c4f1ad2f52307db98786e262dc4243256c wwwoffle-2.9c.tgz 1078788
diff --git a/net-proxy/wwwoffle/wwwoffle-2.9c.ebuild b/net-proxy/wwwoffle/wwwoffle-2.9c.ebuild
new file mode 100644
index 000000000000..a730796708f8
--- /dev/null
+++ b/net-proxy/wwwoffle/wwwoffle-2.9c.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9c.ebuild,v 1.1 2007/08/21 19:21:15 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="wwwoffle = WWW Offline Explorer, an adv. caching proxy especially suitable for nonpermanent (e.g. dialup) Internet connections"
+SRC_URI="http://www.gedanken.demon.co.uk/download-wwwoffle/${P}.tgz"
+HOMEPAGE="http://www.gedanken.demon.co.uk/wwwoffle"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gnutls ipv6 zlib"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib )"
+DEPEND="dev-lang/perl
+ sys-devel/flex
+ ${RDEPEND}"
+
+# Unsure whether to depend on >=www-misc/htdig-3.1.6-r4 or not
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's#$(TAR) xpf #$(TAR) --no-same-owner -xpf #' \
+ "${S}/cache/Makefile.in"
+}
+
+src_compile() {
+ econf $(use_with zlib) \
+ $(use_with gnutls) \
+ $(use_with ipv6) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # documentation fix
+ # del empty doc dirs
+ rmdir "${D}/usr/doc/${PN}"/{it,nl,ru}
+ dodir /usr/share/doc
+ mv "${D}/usr/doc/wwwoffle" "${D}/usr/share/doc/${PF}"
+
+ # install the wwwoffled init script
+ newinitd "${FILESDIR}/${PN}.initd" wwwoffled
+ newinitd "${FILESDIR}/${PN}-online.initd" wwwoffled-online
+ newconfd "${FILESDIR}/${PN}-online.confd" wwwoffled-online
+
+ keepdir /var/spool/wwwoffle/{http,outgoing,monitor,lasttime,lastout,local}
+ for number in 1 2 3 4 5 6 7 8 9; do
+ keepdir "/var/spool/wwwoffle/prevtime${number}" "/var/spool/wwwoffle/prevout${number}"
+ done
+
+ # empty dirs are removed during update
+ keepdir \
+ /var/spool/wwwoffle/search/{mnogosearch/db,htdig/tmp,htdig/db-lasttime,htdig/db,namazu/db}
+
+ touch \
+ "${D}/var/spool/wwwoffle/search/htdig/wwwoffle-htdig.log" \
+ "${D}/var/spool/wwwoffle/search/mnogosearch/wwwoffle-mnogosearch.log" \
+ "${D}/var/spool/wwwoffle/search/namazu/wwwoffle-namazu.log"
+
+ # TODO htdig indexing as part of initscripts
+
+ # robots.txt modification - /var/spool/wwwoffle/html/en
+ # - remove Disallow: /index
+ sed -i -e "s|Disallow:.*/index|#Disallow: /index|" "${D}/var/spool/wwwoffle/html/en/robots.txt"
+
+ rmdir "${D}/usr/doc"
+}
+
+pkg_preinst() {
+ # Add a wwwoffle user
+ enewgroup wwwoffle
+ enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
+
+ # Changing the user:group to wwwoffle:woffle
+ fowners -R wwwoffle:wwwoffle /var/spool/wwwoffle /etc/wwwoffle
+ sed -i -e 's/^[# \t]\(run-[gu]id[ \t]*=[ \t]*\)[a-zA-Z0-9]*[ \t]*$/ \1wwwoffle/g' \
+ "${D}/etc/wwwoffle/wwwoffle.conf"
+
+ # Stop the service if it is started
+ if [ "${ROOT}" = "/" ] ; then
+ source /etc/init.d/functions.sh
+ if [ -L "${svcdir}/started/wwwoffled" ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+ restart the script."
+ /etc/init.d/wwwoffled stop
+ # Just to be sure...
+ start-stop-daemon --stop --quiet --name wwwoffled
+ touch "${T}/stopped"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ # fix permissions for those upgrading
+ for number in 1 2 3 4 5 6 7 8 9;
+ do
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevtime${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevtime${number}"
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevout${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevout${number}"
+ done
+ chown -R wwwoffle:wwwoffle "${ROOT}/var/spool/wwwoffle" "${ROOT}/etc/wwwoffle"
+
+ [ -f "${T}/stopped" ] && \
+ ewarn "wwwoffled was stopped. /etc/init.d/wwwoffled start to restart AFTER etc-update"
+
+ einfo "wwwoffled should run as an ordinary user now. The run-uid and run-gid should be set"
+ einfo "to \"wwwoffle\" in your /etc/wwwoffle/wwwoffle.conf. Please uncomment this if it hasn't been already"
+
+ einfo "This is for your own security. Otherwise wwwoffle is run as root which is relay bad if"
+ einfo "there is an exploit in this program that allows remote/local users to execute arbitary"
+ einfo "commands as the root user."
+
+ if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
+ ewarn "Configuration file is /etc/wwwoffle/wwwoffle.conf now"
+ ewarn "Suggest you move ${ROOT}etc/wwwoffle.conf"
+ fi
+
+ # if htdig - run script for full database index
+ # TODO
+}