summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-07-07 16:49:15 +0000
committerRick Farina <zerochaos@gentoo.org>2013-07-07 16:49:15 +0000
commitd687645bae6217ce1ef856bf432bf1dfc1620644 (patch)
treecb1b71ad6153c7d8d0c7e888018d891986950236 /net-wireless
parentmasking gr-iqbal-0.37.0 and gr-osmosdr-0.1.0 (diff)
downloadgentoo-2-d687645bae6217ce1ef856bf432bf1dfc1620644.tar.gz
gentoo-2-d687645bae6217ce1ef856bf432bf1dfc1620644.tar.bz2
gentoo-2-d687645bae6217ce1ef856bf432bf1dfc1620644.zip
adding gr-3.7 compat version p.masked since it doesn't work with gr-osmosdr
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gr-iqbal/ChangeLog7
-rw-r--r--net-wireless/gr-iqbal/gr-iqbal-0.37.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/net-wireless/gr-iqbal/ChangeLog b/net-wireless/gr-iqbal/ChangeLog
index 29a6ba441212..7c29cb187c19 100644
--- a/net-wireless/gr-iqbal/ChangeLog
+++ b/net-wireless/gr-iqbal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/gr-iqbal
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/gr-iqbal/ChangeLog,v 1.3 2013/06/25 13:33:34 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gr-iqbal/ChangeLog,v 1.4 2013/07/07 16:49:15 zerochaos Exp $
+
+*gr-iqbal-0.37.0 (07 Jul 2013)
+
+ 07 Jul 2013; Rick Farina <zerochaos@gentoo.org> +gr-iqbal-0.37.0.ebuild:
+ adding gr-3.7 compat version p.masked since it doesn't work with gr-osmosdr
25 Jun 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gr-iqbal-0.36.0.ebuild, gr-iqbal-9999.ebuild:
diff --git a/net-wireless/gr-iqbal/gr-iqbal-0.37.0.ebuild b/net-wireless/gr-iqbal/gr-iqbal-0.37.0.ebuild
new file mode 100644
index 000000000000..f310a9633984
--- /dev/null
+++ b/net-wireless/gr-iqbal/gr-iqbal-0.37.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gr-iqbal/gr-iqbal-0.37.0.ebuild,v 1.1 2013/07/07 16:49:15 zerochaos Exp $
+
+EAPI=5
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python
+
+DESCRIPTION="gnuradio I/Q balancing"
+HOMEPAGE="http://git.osmocom.org/gr-iqbal/"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=
+ net-libs/libosmo-dsp:="
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 "${S}"
+}