summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Coles <sj7trunks@gentoo.org>2003-12-01 16:34:25 +0000
committerBenjamin Coles <sj7trunks@gentoo.org>2003-12-01 16:34:25 +0000
commitd79cd59f5d1d382afc178014727c484ca1e208b3 (patch)
tree965d8a7a11d461d8392dba27efa23b9434f978e4 /net-www/bugzilla
parentInitial version of bugzilla - Works - (diff)
downloadgentoo-2-d79cd59f5d1d382afc178014727c484ca1e208b3.tar.gz
gentoo-2-d79cd59f5d1d382afc178014727c484ca1e208b3.tar.bz2
gentoo-2-d79cd59f5d1d382afc178014727c484ca1e208b3.zip
Initial version of bugzilla - Works -
Diffstat (limited to 'net-www/bugzilla')
-rw-r--r--net-www/bugzilla/ChangeLog9
-rw-r--r--net-www/bugzilla/Manifest5
-rw-r--r--net-www/bugzilla/bugzilla-2.17.6-r1.ebuild121
-rw-r--r--net-www/bugzilla/files/bugzilla.conf8
-rw-r--r--net-www/bugzilla/files/bugzilla.cron.daily5
-rw-r--r--net-www/bugzilla/files/bugzilla.cron.tab1
-rw-r--r--net-www/bugzilla/files/bz.cfg.templ13
-rw-r--r--net-www/bugzilla/files/cronset.sh5
-rw-r--r--net-www/bugzilla/files/digest-bugzilla-2.17.6-r11
-rw-r--r--net-www/bugzilla/files/firstcheck.sh4
-rw-r--r--net-www/bugzilla/metadata.xml5
11 files changed, 175 insertions, 2 deletions
diff --git a/net-www/bugzilla/ChangeLog b/net-www/bugzilla/ChangeLog
new file mode 100644
index 000000000000..10224bf607ab
--- /dev/null
+++ b/net-www/bugzilla/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-www/bugzilla
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/bugzilla/ChangeLog,v 1.1 2003/12/01 16:34:24 sj7trunks Exp $
+
+ 01 Dec 2003; Benjamin Coles <sj7trunks@gentoo.org> bugzilla-2.17.6-r1.ebuild:
+ Thanks to Abhishek@gentoo.org for submitting this ebuild; bug #15031
+ Updated ebuild to work with 2.17.6
+ Moved ebuild install directtory to /var/www
+ Todo: Update ebuild to better support upgrades
diff --git a/net-www/bugzilla/Manifest b/net-www/bugzilla/Manifest
index b0b94dbdfcd3..36a6d1d2b97d 100644
--- a/net-www/bugzilla/Manifest
+++ b/net-www/bugzilla/Manifest
@@ -1,5 +1,6 @@
-MD5 a22df1207b92c855b458ee1f7fcaad4c bugzilla-2.17.6-r1.ebuild 4386
-MD5 c1045bb42b7c4f6f1aec821aef19266e ChangeLog 408
+MD5 4e14ff280bd43cd61d9cc8781a96f1d5 bugzilla-2.17.6-r1.ebuild 4362
+MD5 91588680fb5295294450f2d8a5174fb0 ChangeLog 500
+MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
MD5 0606a9da89d19a505c52818d14de61e3 files/cronset.sh 70
MD5 b38d67b03726b84833bd8c5f632e4020 files/bugzilla.cron.tab 54
MD5 8a1339d54a8d4525959a5d398300e7ee files/bz.cfg.templ 323
diff --git a/net-www/bugzilla/bugzilla-2.17.6-r1.ebuild b/net-www/bugzilla/bugzilla-2.17.6-r1.ebuild
new file mode 100644
index 000000000000..96c70a4e8de6
--- /dev/null
+++ b/net-www/bugzilla/bugzilla-2.17.6-r1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="Bugzilla is the Bug-Tracking System from the Mozilla project"
+SRC_URI="http://ftp.mozilla.org/pub/webtools/${P}.tar.gz"
+HOMEPAGE="http://www.bugzilla.org"
+
+LICENSE="MPL-1.1 NPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+# See http://www.bugzilla.org/docs216/html/stepbystep.html to verify dependancies
+DEPEND=">=dev-db/mysql-3.22.5
+ >=dev-lang/perl-5.01
+ >=dev-perl/AppConfig-1.52
+ dev-perl/Template-Toolkit
+ >=dev-perl/Text-Tabs+Wrap-2001.0131
+ >=dev-perl/File-Spec-0.8.2
+ >=dev-perl/DBD-mysql-1.2209
+ >=dev-perl/DBI-1.13
+ dev-perl/TimeDate
+ >=dev-perl/CGI-2.88
+ >=dev-perl/GD-1.19
+ dev-perl/GDGraph
+ >=dev-perl/Chart-0.99c
+ dev-perl/XML-Parser
+ dev-perl/MIME-tools
+ net-www/apache"
+
+# removed deps: dev-perl/Data-Dumper
+
+src_compile() {
+ :;
+}
+
+src_install () {
+ dodir /usr/bonsaitools/bin /etc/apache/conf
+ cd ${S}
+
+ # Bugzilla originally needs perl to be installed in /usr/bonsaitools/bin
+ # So let's change it for /usr/bin/perl
+ perl -pi -e 's@#\!/usr/bonsaitools/bin/perl@#\!/usr/bin/perl@' *cgi *pl Bug.pm processmail || die
+ # syncshadowdb is gone
+ # Copy files to /var/www/bugzilla
+ insinto /var/www/bugzilla
+
+# doins * doesn't work recursively
+ cp -r ${S}/* ${D}/var/www/bugzilla || die
+# htdocs is for common apache docs, while bugzilla is a web app
+# So, it's better to keep it outside
+
+ cp ${FILESDIR}/bugzilla.conf ${D}/etc/apache/conf || die
+ cp ${FILESDIR}/bugzilla.cron.* ${D}/var/www/bugzilla || die
+ cp ${FILESDIR}/bz.cfg.templ ${D}/var/www/bugzilla || die
+ cp ${FILESDIR}/firstcheck.sh ${D}/var/www/bugzilla || die
+ cp ${FILESDIR}/cronset.sh ${D}/var/www/bugzilla || die
+ chown -R apache:apache ${D}/var/www/bugzilla || die
+}
+
+pkg_config() {
+ # moved here as it doesn't work in a sandbox
+ cd /var/www/bugzilla || die
+ if ( test -a localconfig ) ; then
+ die "The following does not work on previous installations, please run checksetup.pl in /var/www/bugzilla followed by a chown -R apache:apache /var/www/bugzilla."
+ fi
+
+ einfo "Finalizing the installation of bugzilla in /var/www/bugzilla"
+
+ echo -n "mysql root dbuser password: "; read myrootpwd
+ if (test -z $myrootpwd) ; then eerror "No root db password" ; die ; fi
+
+ echo -n "mysql bugs db name [bugs]: "; read mybugsdb
+ if (test -z $mybugsdb) ; then mybugsdb="bugs" ; fi
+
+ echo -n "mysql bugs db host [localhost]: "; read mybugshost
+ if (test -z $mybugshost) ; then mybugshost="localhost" ; fi
+
+ echo -n "mysql bugs dbuser name [bugs]: "; read mybugsuser
+ if (test -z $mybugsuser) ; then mybugsuser="bugs" ; fi
+
+ echo -n "mysql bugs dbuser password: "; read mybugspwd
+ if (test -z $mybugspwd) ; then eerror "No dbuser password" ; die ; fi
+
+ cat bz.cfg.templ | sed -e "s/tmpdbname/${mybugsdb}/" > bz.cfg.templ.1
+ cat bz.cfg.templ.1 | sed -e "s/tmphost/${mybugshost}/" > bz.cfg.templ.2
+ cat bz.cfg.templ.2 | sed -e "s/tmpdbuser/${mybugsuser}/" > bz.cfg.templ.3
+ cat bz.cfg.templ.3 | sed -e "s/tmpdbpass/${mybugspwd}/" > bz.cfg.pl
+
+ if [ ! -f bz.cfg.pl ] ; then eerror "No template for db vars" ; die ; fi
+
+ rm bz.cfg.templ.[0-9]* || die
+
+ einfo "Setting correct privelegies"
+ mysql --password=${myrootpwd} mysql --exec="GRANT SELECT,INSERT,UPDATE,DELETE,INDEX, ALTER,CREATE,DROP,REFERENCES ON ${mybugsdb}.* TO ${mybugsuser}@${mybugshost} IDENTIFIED BY '${mybugspwd}'; FLUSH PRIVILEGES;" || die
+
+ einfo "Setting the template for localconfig variables"
+ ./checksetup.pl bz.cfg.pl || die
+ chown -R apache:apache /var/www/bugzilla || die
+
+ einfo "Final step: setting all html templates and db tables"
+ chmod 750 /var/www/bugzilla/firstcheck.sh
+ ./firstcheck.sh || die
+
+ echo -n "Do you want to set a crontab [y/N]" ; read cronyes
+ chmod 750 /var/www/bugzilla/cronset.sh
+ if ( test $cronyes = "y") ; then su - apache -c /var/www/bugzilla/cronset.sh ; fi
+
+ chown -R apache:apache /var/www/bugzilla || die
+
+ einfo "Then you just have to :"
+ einfo "append to apache/conf: Include conf/bugzilla.conf"
+ einfo "Restart Apache"
+ einfo "login on http://yourhost/bugzilla/index.cgi and edit global parameters click *parameters* at the bottom"
+ einfo "enjoy bugzilla!"
+
+}
+
+pkg_postinst() {
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+}
diff --git a/net-www/bugzilla/files/bugzilla.conf b/net-www/bugzilla/files/bugzilla.conf
new file mode 100644
index 000000000000..648e317c5c90
--- /dev/null
+++ b/net-www/bugzilla/files/bugzilla.conf
@@ -0,0 +1,8 @@
+Alias /bugzilla /var/www/bugzilla
+<Directory /var/www/bugzilla>
+ Order Allow,Deny
+ Options ExecCGI
+ AllowOverride All
+ Allow from all
+</Directory>
+
diff --git a/net-www/bugzilla/files/bugzilla.cron.daily b/net-www/bugzilla/files/bugzilla.cron.daily
new file mode 100644
index 000000000000..e3e86589891d
--- /dev/null
+++ b/net-www/bugzilla/files/bugzilla.cron.daily
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /var/www/bugzilla/
+./collectstats.pl
+./whineatnews.pl
+echo "*** Bugzilla nighlty flush has done! ***"
diff --git a/net-www/bugzilla/files/bugzilla.cron.tab b/net-www/bugzilla/files/bugzilla.cron.tab
new file mode 100644
index 000000000000..0ac2ef6d65a6
--- /dev/null
+++ b/net-www/bugzilla/files/bugzilla.cron.tab
@@ -0,0 +1 @@
+0 0 * * * /var/www/bugzilla/bugzilla.cron.daily
diff --git a/net-www/bugzilla/files/bz.cfg.templ b/net-www/bugzilla/files/bz.cfg.templ
new file mode 100644
index 000000000000..ecd9fc5c90f7
--- /dev/null
+++ b/net-www/bugzilla/files/bz.cfg.templ
@@ -0,0 +1,13 @@
+
+$answer{'db_host'} = '$db_host = "tmphost";
+$db_port = 3306;
+$db_name = "tmpdbname";
+$db_user = "tmpdbuser";';
+
+$answer{'db_pass'} = q[$db_pass = 'tmpdbpass';];
+
+$answer{'ADMIN_OK'} = 'Y';
+$answer{'ADMIN_EMAIL'} = 'tmpadmemail';
+$answer{'ADMIN_PASSWORD'} = 'tmpadmpwd';
+$answer{'ADMIN_REALNAME'} = 'tmpadmname';
+
diff --git a/net-www/bugzilla/files/cronset.sh b/net-www/bugzilla/files/cronset.sh
new file mode 100644
index 000000000000..4a3dd3e24bd7
--- /dev/null
+++ b/net-www/bugzilla/files/cronset.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+cd /var/www/bugzilla
+/usr/bin/crontab ./bugzilla.cron.tab
+
+
diff --git a/net-www/bugzilla/files/digest-bugzilla-2.17.6-r1 b/net-www/bugzilla/files/digest-bugzilla-2.17.6-r1
new file mode 100644
index 000000000000..bf009c3e8f1f
--- /dev/null
+++ b/net-www/bugzilla/files/digest-bugzilla-2.17.6-r1
@@ -0,0 +1 @@
+MD5 1fd6bdcd18838d54f54b30eeaa7d14ce bugzilla-2.17.6.tar.gz 1226064
diff --git a/net-www/bugzilla/files/firstcheck.sh b/net-www/bugzilla/files/firstcheck.sh
new file mode 100644
index 000000000000..27c9c7d04a3c
--- /dev/null
+++ b/net-www/bugzilla/files/firstcheck.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /var/www/bugzilla
+./checksetup.pl
+
diff --git a/net-www/bugzilla/metadata.xml b/net-www/bugzilla/metadata.xml
new file mode 100644
index 000000000000..95c06f0095bb
--- /dev/null
+++ b/net-www/bugzilla/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>