summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-05-12 18:39:34 +0000
committerDean Bailey <alron@gentoo.org>2003-05-12 18:39:34 +0000
commitea8fa1fe73906ba01eb26996c2befa174bade47a (patch)
treee3fc1fcde0dfed6dc8c0011a1d792f96e008b42a /net-www/horde-kronolith
parentnoticed bug with permissions on /usr/include/packer.h, fixed. (diff)
downloadgentoo-2-ea8fa1fe73906ba01eb26996c2befa174bade47a.tar.gz
gentoo-2-ea8fa1fe73906ba01eb26996c2befa174bade47a.tar.bz2
gentoo-2-ea8fa1fe73906ba01eb26996c2befa174bade47a.zip
Version bump of horde-kronolith to 1.1 final
Diffstat (limited to 'net-www/horde-kronolith')
-rw-r--r--net-www/horde-kronolith/ChangeLog6
-rw-r--r--net-www/horde-kronolith/files/digest-horde-kronolith-1.11
-rw-r--r--net-www/horde-kronolith/horde-kronolith-1.1.ebuild67
3 files changed, 73 insertions, 1 deletions
diff --git a/net-www/horde-kronolith/ChangeLog b/net-www/horde-kronolith/ChangeLog
index 68eb8f89a9be..ead32eb69eea 100644
--- a/net-www/horde-kronolith/ChangeLog
+++ b/net-www/horde-kronolith/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/horde-kronolith
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/ChangeLog,v 1.4 2003/04/10 19:47:55 alron Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/ChangeLog,v 1.5 2003/05/12 18:39:34 alron Exp $
+
+*horde-kronolith-1.1 (11 May 2003)
+ 11 May 2003; Dean Bailey <alron@gentoo.org> horde-kronolith-1.1 :
+ Version bump to 1.1 final.
*horde-kronolith-1.1_rc3 (10 Apr 2003)
10 Apr 2003; Dean Bailey <alron@gentoo.org> horde-kronolith-1.1_rc3 :
diff --git a/net-www/horde-kronolith/files/digest-horde-kronolith-1.1 b/net-www/horde-kronolith/files/digest-horde-kronolith-1.1
new file mode 100644
index 000000000000..5ff50f679c56
--- /dev/null
+++ b/net-www/horde-kronolith/files/digest-horde-kronolith-1.1
@@ -0,0 +1 @@
+MD5 a4081e8fdf241dca2fe6707e9ce77850 kronolith-1.1.tar.gz 437938
diff --git a/net-www/horde-kronolith/horde-kronolith-1.1.ebuild b/net-www/horde-kronolith/horde-kronolith-1.1.ebuild
new file mode 100644
index 000000000000..a98e8cab0778
--- /dev/null
+++ b/net-www/horde-kronolith/horde-kronolith-1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-kronolith/horde-kronolith-1.1.ebuild,v 1.1 2003/05/12 18:39:34 alron Exp $
+
+DESCRIPTION="Kronolith ${PV} is the Horde calendar application"
+HOMEPAGE="http://www.horde.org"
+P=kronolith-1.1
+SRC_URI="ftp://ftp.horde.org/pub/kronolith/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2.1"
+IUSE=""
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
+ GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
+ return 0
+ else
+ eerror "Missing SQL or LDAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+ dodir ${HTTPD_ROOT}/horde/kronolith
+ cp -r . ${D}/${HTTPD_ROOT}/horde/kronolith
+
+ # protecting files
+ chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/kronolith
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/kronolith/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ einfo "Please read ${HTTPD_ROOT}/horde/kronolith/docs/INSTALL !"
+}