summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:04:39 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:04:39 +0000
commitf36a1a245888c41000a086800a2721de0d54fe95 (patch)
tree75f3e9a085aa853abc95018ebb6602f01eedbca4 /net-www/horde-turba
parentRemove portion of configure that forces itself to be run as root, so (diff)
downloadgentoo-2-f36a1a245888c41000a086800a2721de0d54fe95.tar.gz
gentoo-2-f36a1a245888c41000a086800a2721de0d54fe95.tar.bz2
gentoo-2-f36a1a245888c41000a086800a2721de0d54fe95.zip
Fixes #6047.
Diffstat (limited to 'net-www/horde-turba')
-rw-r--r--net-www/horde-turba/ChangeLog8
-rw-r--r--net-www/horde-turba/files/digest-horde-turba-1.11
-rw-r--r--net-www/horde-turba/horde-turba-1.1.ebuild85
3 files changed, 94 insertions, 0 deletions
diff --git a/net-www/horde-turba/ChangeLog b/net-www/horde-turba/ChangeLog
new file mode 100644
index 000000000000..d23c772bbb60
--- /dev/null
+++ b/net-www/horde-turba/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/horde-turba
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/ChangeLog,v 1.1 2002/10/31 20:04:39 karltk Exp $
+
+*horde-turba-1.1 (31 Oct 2002)
+
+ 31 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> horde-turba-1.1.ebuild files/digest-horde-turba-1.1 :
+ Initial import. Ebuild submitted by Christophe GUILLOUX <cg@rootix.info>.
diff --git a/net-www/horde-turba/files/digest-horde-turba-1.1 b/net-www/horde-turba/files/digest-horde-turba-1.1
new file mode 100644
index 000000000000..c57bbfb06df8
--- /dev/null
+++ b/net-www/horde-turba/files/digest-horde-turba-1.1
@@ -0,0 +1 @@
+MD5 1b5b3cdf1eeb80fe8a1e9a2ae9000723 turba-1.1.tar.gz 260558
diff --git a/net-www/horde-turba/horde-turba-1.1.ebuild b/net-www/horde-turba/horde-turba-1.1.ebuild
new file mode 100644
index 000000000000..99464cac2538
--- /dev/null
+++ b/net-www/horde-turba/horde-turba-1.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/horde-turba-1.1.ebuild,v 1.1 2002/10/31 20:04:39 karltk Exp $
+
+DESCRIPTION="Turba is the Horde address book / contact management program"
+HOMEPAGE="http://www.horde.org"
+P=turba-1.1
+SRC_URI="ftp://ftp.horde.org/pub/turba/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.1"
+IUSE=""
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
+ GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
+ return 0
+ else
+ eerror "Missing SQL or LDAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+ dodir ${HTTPD_ROOT}/horde/turba
+ cp -r . ${D}/${HTTPD_ROOT}/horde/turba
+
+ # protecting files
+ chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/turba
+ find ${D}/${HTTPD_ROOT}/horde/turba/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/turba/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ # add module in horde
+ sed -e "/^\/\/.*\(\$this->applications\['turba'\].*\)/ \
+ { : next ; N ; /\;/ { s/\/\///g ; b } ; b next }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+
+ einfo "Please read ${HTTPD_ROOT}/horde/turba/docs/INSTALL !"
+}
+
+pkg_prerm() {
+ find_http_root
+ # rm module from horde
+ sed -e "/\(\$this->applications\['turba'\].*\)/ \
+ { s/\(.*\)/\/\/\1/g; : suite ; N ; /\;/ { s/\n/\n\/\//g ; b } ; \
+ b suite }" \
+ < ${REGISTRY} > ${REGISTRY}.temp
+ cp ${REGISTRY}.temp ${REGISTRY}
+ rm ${REGISTRY}.temp
+}