summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2005-01-07 19:39:38 +0000
committerMichael Stewart <vericgar@gentoo.org>2005-01-07 19:39:38 +0000
commit22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae (patch)
tree0a3d030aa333d67834a951c65fa58ba7ad1f2d2a /net-www/mod_throttle
parentApache herd package refresh (Manifest recommit) (diff)
downloadgentoo-2-22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae.tar.gz
gentoo-2-22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae.tar.bz2
gentoo-2-22a9c19dee7aaaa59d32f1d7acb72fa31aed60ae.zip
Apache herd package refresh
Diffstat (limited to 'net-www/mod_throttle')
-rw-r--r--net-www/mod_throttle/Manifest15
-rw-r--r--net-www/mod_throttle/files/10_mod_throttle.conf28
-rw-r--r--net-www/mod_throttle/files/digest-mod_throttle-3.1.2-r21
-rw-r--r--net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild35
4 files changed, 68 insertions, 11 deletions
diff --git a/net-www/mod_throttle/Manifest b/net-www/mod_throttle/Manifest
index a03b73f45d80..115769a90130 100644
--- a/net-www/mod_throttle/Manifest
+++ b/net-www/mod_throttle/Manifest
@@ -1,15 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 37851a802f831271cbb0b721934f6341 mod_throttle-3.1.2-r1.ebuild 1295
MD5 6cc62b1c23c97c72cf80c4e3d766a5f8 ChangeLog 1294
MD5 4b562dac77e8dcbc4aaea4b9bf4dbac2 metadata.xml 264
+MD5 37851a802f831271cbb0b721934f6341 mod_throttle-3.1.2-r1.ebuild 1295
+MD5 ac08191265b9006691938a6b598ab9e8 mod_throttle-3.1.2-r2.ebuild 688
MD5 758dec7efa2b34d6c0b42a8b911ae163 files/digest-mod_throttle-3.1.2-r1 63
MD5 d4ffd33a5f0149ab2dfae75270f26d94 files/mod_throttle.conf 528
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFB2un7Z/iYVBmujdURAvSBAKCEUaoko+XHFEAXpHledChuwpG82gCgiVXb
-Uau0ymJ8TUEZanNWWRZLEIc=
-=FPmH
------END PGP SIGNATURE-----
+MD5 758dec7efa2b34d6c0b42a8b911ae163 files/digest-mod_throttle-3.1.2-r2 63
+MD5 43ab7b458532778476d9f2bc9121933c files/10_mod_throttle.conf 513
diff --git a/net-www/mod_throttle/files/10_mod_throttle.conf b/net-www/mod_throttle/files/10_mod_throttle.conf
new file mode 100644
index 000000000000..0552fe52c296
--- /dev/null
+++ b/net-www/mod_throttle/files/10_mod_throttle.conf
@@ -0,0 +1,28 @@
+<IfDefine THROTTLE>
+ <IfModule !mod_throttle.c>
+ LoadModule throttle_module modules/mod_throttle.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_throttle.c>
+ ThrottlePolicy none
+
+ <Location /throttle-status>
+ SetHandler throttle-status
+ Order deny,allow
+ Allow from localhost
+ </Location>
+
+ <Location /throttle-me>
+ SetHandler throttle-me
+ Order deny,allow
+ Allow from localhost
+ </Location>
+
+ <Location /~*/throttle-me>
+ SetHandler throttle-me
+ Order deny,allow
+ Allow from localhost
+ </Location>
+
+</IfModule>
diff --git a/net-www/mod_throttle/files/digest-mod_throttle-3.1.2-r2 b/net-www/mod_throttle/files/digest-mod_throttle-3.1.2-r2
new file mode 100644
index 000000000000..df3d69409322
--- /dev/null
+++ b/net-www/mod_throttle/files/digest-mod_throttle-3.1.2-r2
@@ -0,0 +1 @@
+MD5 6edc45c3ea8a0855d4b0b14cf0f76404 mod_throttle312.tgz 41397
diff --git a/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild b/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..70ea3a3e2e0e
--- /dev/null
+++ b/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_throttle/mod_throttle-3.1.2-r2.ebuild,v 1.1 2005/01/07 19:39:38 vericgar Exp $
+
+inherit apache-module
+
+# test target in Makefile isn't sane
+RESTRICT="maketest"
+
+MY_PV=${PV//./}
+
+DESCRIPTION="Bandwidth and request throttling for Apache"
+HOMEPAGE="http://www.snert.com/Software/mod_throttle/"
+
+KEYWORDS="~x86 ~sparc ~ppc"
+SRC_URI="http://www.snert.com/Software/${PN}/${PN}${MY_PV}.tgz"
+DEPEND=""
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+
+APACHE1_MOD_CONF="10_${PN}"
+APACHE1_MOD_DEFINE="THROTTLE"
+
+need_apache1
+
+src_install() {
+
+ apache1_src_install
+
+ sed 's/Img\///g' < index.shtml > index.html
+ dodoc CHANGES.txt LICENSE.txt
+ dohtml -r index.html Img/
+
+}